BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-20-2009, 01:17 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2009
Location: New York
Model: 9550
OS: 5.0.0.713
PIN: no
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Curve Problem... this is my 2nd phone

Please Login to Remove!

Ok... So got a curve 8310 last month and i had a problem where the edge would not go uppercase. i was on phone with att for hours several times. they could not get it uppercase. and all i wanted to do was set up my email, which i didnt have an option to do. So after the 8th call to att the 8th different person, 8 different answers to my problem and they said the phone was defective and needs to be replaces. so i got a replacement. it came yesterday, poped sim in and hey look EDGE. so excited i went to my computer to load my contacts and bb desktop mgr said Update 4.5 avail. so i did, loaded contacts, then edge.... it would not go uppercase, Tried registering host tables 100 times, battery pulled 100 times. and nothing. i even downgraded back to 4.2 and still nothing. so i called att and on the 1st time they said the phone was defective. is the phone defective or is there somthing i can do to fix this damn thing. im actually about to just go down to att and buy a new phone.

and just to answer the ovbious questions....

I DO have a BB Data Plan
Data is ON
the correct IMEI is ON my account.

just getting very angry.
Offline  
Old 02-20-2009, 02:49 PM   #2 (permalink)
Thumbs Must Hurt
 
A10TXChick's Avatar
 
Join Date: Dec 2008
Location: Texas
Model: 8320
OS: 4.5.0.81
PIN: Don't Use BB Messenger
Carrier: TMobile w/Unlimited Data Plan
Posts: 98
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem with my TMobile Curve 8320, the problem actually was in the SIM card. The card was so old and outdated it wasn't working correctly. Went into a TMobile store the transfered all my info to a new SIM card turned it on and EDGE right away. I would suggest trying that, I know AT&T does SIM cards so maybe that is an issue. It should be free and will only cost you 5 minutes of your time... best of luck!
Offline  
Old 02-20-2009, 03:02 PM   #3 (permalink)
Stuck In The '70's Mod
 
ndub33's Avatar
 
Join Date: Feb 2006
Location: The 'burbs east of Seattle.
Model: 9810
Carrier: T-Mobile
Posts: 7,599
Post Thanks: 0
Thanked 4 Times in 4 Posts
Default

The SIM card could be the issue...what does your signal strength meter read where you are trying to activate the device?
__________________
1st Step in Troubleshooting: Do you have a BlackBerry Data Plan?
2nd Step in Troubleshooting: Pull the Battery.
Offline  
Old 02-20-2009, 03:41 PM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2009
Location: New York
Model: 9550
OS: 5.0.0.713
PIN: no
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Well with the first phoneb att said it was the sim so I got a brand new sim. And it still gave me the problem. I actually just borrowed my friend 8310 and it worked instantly
Offline  
Old 02-20-2009, 08:44 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2009
Location: New York
Model: 9550
OS: 5.0.0.713
PIN: no
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

if i unlocked the non working phone, does anyone know if that will solve the problem? or should i just return it and keep the working one my friend gave me
Offline  
Old 02-22-2009, 04:09 PM   #6 (permalink)
Thumbs Must Hurt
 
A10TXChick's Avatar
 
Join Date: Dec 2008
Location: Texas
Model: 8320
OS: 4.5.0.81
PIN: Don't Use BB Messenger
Carrier: TMobile w/Unlimited Data Plan
Posts: 98
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not sure about that one, I would ask one of the experts.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.