BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-27-2009, 09:37 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Denver, CO
Model: Hero
OS: Android.
Carrier: Sprint
Posts: 166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems after SIM replacement

Please Login to Remove!

Today after a routine battery pull, my Curve presented a message which stated, "SIM Card Rejected". I had no phone connection, but I did have data via UMA through my wireless router.

I pulled the battery again and the messages persisted. I pulled the battery AND the SIM, replaced them, and the message persisted. I contacted T-MO Customer Service who had me do the same, then tried sending "something" to the phone, still the message persisted. I was informed I would need to go to a T-MO store and have the SIM replaced, which I did. Phone connection was restored.

Upon returning home, I noticed the Curve did see my wireless network, but won't switch to UMA. I've tried battery pulls, bouncing my router, checking the Curve's WiFi settings (which worked this morning) and resending the service books (which I was pretty sure wouldn't help).

Also, since the SIM swap, I have the voicemail message icon on the screen, but I have no vmails. I imagine the trick to this is to have my wife call, leave a message and clear it, but she's at work for a little while yet. This isn't a big deal but I thought I should include it in case it's remotely relevant.

I'm out of ideas. Why won't my Curve switch to UMA?

Thanks.

Last edited by nathanotis : 03-27-2009 at 09:39 PM.
Offline  
Old 03-28-2009, 03:51 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Denver, CO
Model: Hero
OS: Android.
Carrier: Sprint
Posts: 166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

I thought I'd update... I'm at a robo-competition today @ Denver Uni and the WiFi here is so thick, you can see it (no, not really). My Curve sees WiFi, and I connected easily... But Curvey won't go UMA.
Offline  
Old 03-29-2009, 10:44 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Denver, CO
Model: Hero
OS: Android.
Carrier: Sprint
Posts: 166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

C'mon guys... Someone has to have an idea... Or is this the dumbest question ever and this is your way of making me pay?
Offline  
Old 03-29-2009, 07:18 PM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Denver, CO
Model: Hero
OS: Android.
Carrier: Sprint
Posts: 166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, I'm out of options. TMo wants me to perform a master reset. As I see it I don't have a choice ... I'm not finding any other answers anywhere.

I'll post back later.
Offline  
Old 03-29-2009, 10:49 PM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Denver, CO
Model: Hero
OS: Android.
Carrier: Sprint
Posts: 166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, I backed up and performed a "Master Reset", which is just a wipe of the device. No change. I'm waiting for a call from TMO Customer Service... This is a drag. Daddy needs some UMA.
Offline  
Old 03-30-2009, 01:16 AM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Denver, CO
Model: Hero
OS: Android.
Carrier: Sprint
Posts: 166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

At the request of the 2nd level blackberry expert, I swapped my sim for my wife's (non-bb). Lo and behold, my Curve switched over to uma (albeit lowercase). This proves it isn't my router or phone, so I get to go back to the T-MO store tomorrow and get another new sim. Fingers crossed, but this should fix the issue.

Good thing I'm unemployed right now... I have plenty of time to run all over the place to get new sims.
Offline  
Old 03-30-2009, 08:39 AM   #7 (permalink)
Thumbs Must Hurt
 
bcinelli's Avatar
 
Join Date: Jun 2006
Location: New York
Model: 8320
OS: 4.5.0.124
PIN: 24338892
Carrier: T-Mobile
Posts: 195
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had a topic recently just like this. Where my blackberrys SIM card fried, as well as fried the phones SIM port. TMO replaced the phone and the SIM card, but the SIM card they returned to me was also broken. Third time was a charm and the SIM card worked in the new phone.

TMO support was clueless when it was saying the SIM REJECTED message. At least they did right and sent me a new phone, luckily i was 10 days away from warranty ending.. whoo.
__________________
Websites (SFW) - - DirtyDalerz.com / ZooYorkFreak.com
Offline  
Old 03-30-2009, 02:07 PM   #8 (permalink)
BlackBerry Mensa
 
takeshi's Avatar
 
Join Date: Jan 2005
Location: Houston
Model: 8310
Carrier: at&t
Posts: 7,741
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nathanotis View Post
Well, I backed up and performed a "Master Reset", which is just a wipe of the device.
Actually on the BB resets and device wipes are completely different. Resets do not affect data. Wipes do.
Offline  
Old 03-30-2009, 04:39 PM   #9 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Denver, CO
Model: Hero
OS: Android.
Carrier: Sprint
Posts: 166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Today, after a second sim swap, I'm back home with uma (lowercase only) so I'm not through yet...

Saw the 8900 @ the Tmo store. Maybe its time for an upgrade.
Offline  
Old 03-30-2009, 10:46 PM   #10 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2008
Location: Denver, CO
Model: Hero
OS: Android.
Carrier: Sprint
Posts: 166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Battery pull got me back to uppercase UMA. Looks like I'm all good.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.