BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-29-2009, 05:09 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Location: Georgia
Model: 8330
PIN: N/A
Carrier: Sprint
Posts: 40
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8330 Keyboard- no response HELP!

Please Login to Remove!

Went to use my (Sprint) 8330 BB earlier (had been working fine), the screen was off. Touched a key, no response. Phone appeared dead thought battery was charged-- Did a battery pull, phone rebooted-- started okay-- saw desktop but screen was unresponsive to key touch, trackball, etc. Screen went black again, no response. Traded batteries as a test with another 8330. No change. Changed back-- again booted but no keyboard response. Multiple battery pulls tried, no change.

Then I noticed if I plug in the phone (external power), the screen comes right on as usual-- so the phone isn't shutting down as I first thought, the screen is just going to sleep but I have zero control over the thing waking or using the keyboard-- This also means that I cannot answer phone calls-- the phone is stuck on "silent" (in fact the volume setting is highlighted and will not change even on reboot). Note that I can see when I have missed calls but I cannot make the phone "view" missed calls. It is much like the keyboard to a computer being unplugged. So what can I do to clear this?

Note that the "plugged in" power indicator continues to work, and the auto-dim feature still responds to changing light, etc. if that means anything...

Had one problem months ago with facebook app. Deleted and reinstalled the bad app to fix but at that time only the email had locked up, the actual phone and keyboard still worked. This time the phone is totally unresponsive to all keys.

Suggestions?
Offline  
Old 03-29-2009, 05:15 PM   #2 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,069
Post Thanks: 138
Thanked 139 Times in 120 Posts
Default

Has the device come in contact with moisture or been dropped recently?
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Old 03-29-2009, 08:15 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Location: Georgia
Model: 8330
PIN: N/A
Carrier: Sprint
Posts: 40
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, definitely not. To be clear it was working fine all day and for the last several months. This morning/afternoon, I'd had it in my pocket the whole time, except when I used it several times and had used it 5 or 10 minutes before with no issues, then I pulled it back out and got no response. It was only indoors, and only in my (dry) pocket.

I did have that problem before with Facebook and I think the last thing I did before it locked up was start to post something through the facebook app but I never finished-- I put my BB away mid-posting to try and stop a small child of mine from getting into mischief. Normally I'd hit the sleep button (or whatever it is called) on top of the BB but I have no idea if I did that or not this time-- thought that might have helped cause the problem if something got "pocket-dialed" by accident, but surely that should reset and clear with a battery pull, so I am truly stumped.

Is there any reset "trick" that does more than a battery pull? What I really want to do it figure out how to get facebook off of the BB somehow and see if the problem will go away, but I have no way to access and delete that app. (Well, none that I'm aware of.)
Offline  
Old 03-29-2009, 10:11 PM   #4 (permalink)
BlackBerryForums.com Super Moderator
 
SteveO86's Avatar
 
Join Date: Sep 2007
Location: Florida
Model: 9650
OS: 6.0.0.280
PIN: I heard it drop!
Carrier: VZW BIS
Posts: 6,534
Post Thanks: 0
Thanked 4 Times in 1 Post
Default

You cna try wiping your device JL_CMDer, instructions in the FAQ section of the site, but this will wipe everything from your phone.
__________________
8830 -> 8330 -> 9550 -> 9650
Just think about how far BlackBerries have come from then till now... And what else is coming.

Follow me on Twitter
Offline  
Old 03-29-2009, 11:56 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Location: Georgia
Model: 8330
PIN: N/A
Carrier: Sprint
Posts: 40
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks-- I guess it may come to that but I'd sure rather not loose everything on it.

I was hoping others had heard of this problem but it sounds rare-- Was wondering if there could be a loose cable or the like, but that would make more sense if the phone had been dropped-- I put it in my pocket and it was working then took it out and it was not-- just that simple.

What a drag...
Offline  
Old 03-30-2009, 08:00 AM   #6 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8330
PIN: N/A
Carrier: nTelos
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Are you sure your pocket was dry? It doesn't take much moisture/humidity at all to cause this. I've had the same issue with a phone that was loose in my pocket after a short hike. Even though I wasn't too hot or sweaty, the humidity in my pocket just got too high. Take the battery out, leave the cover off, lay the phone face down in a dry place and let it sit overnight.
Offline  
Old 03-31-2009, 12:23 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2008
Location: Georgia
Model: 8330
PIN: N/A
Carrier: Sprint
Posts: 40
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Aquilon View Post
Wirelessly posted

Are you sure your pocket was dry?
Yes, I'm certain-- this was Sunday, at Church-- dry, clean dress clothes and no sweaty activities at all. Also, I did do an overnight battery pull with the cover off and so forth-- still nothing. It is as if the keyboard was "unplugged" and nothing has changed since.

Both my local (Sprint-owned) Sprint store when i came by and the Sprint folks on the phone were rather baffled when I called today-- said they had never had this exact problem-- how lucky for me...

All were confident we could resolve this for a fee-- $100 or so. Seems the term "warranty" means something different to them than it does to me in my native language of "English".

I did finally find someone who understand the concept and I now have a free replacement headed my way (or so I am told). Cross your fingers!....

Thanks for your suggestions though!
Offline  
Old 04-01-2009, 05:42 AM   #8 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8310
PIN: N/A
Carrier: aljawal
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Same Problem

I have the exact same problem!

Though there might have been some humidity damage to my phone, but it was out of my pocket for atleast good hour, working perfectly, until this happened.

I would really rather not have all the info deleted, but seeing that I dont have a warranty of anything else anymore, it may be my only solution short of buying a new phone.

Ive considered ramming it open my self to see if anything is loose at all, but I just might do more harm than good.

Any suggestions please!

Thanks!
Offline  
Old 05-01-2009, 03:11 AM   #9 (permalink)
New Member
 
Join Date: May 2009
Model: Pearl
PIN: N/A
Carrier: Sprint
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Yep.... Me too.

Same thing happened to me. It seems like the keyboard/ball lost a connection somewhere but it's not frozen because, like you noticed, if you plug it in to charge, it responds to that kind of input.

Wish there was some easy solution....
Offline  
Old 10-06-2009, 08:13 PM   #10 (permalink)
New Member
 
Join Date: Oct 2009
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OOPS! tha's I have exactly the same problem -- -dead keyboard, but the phone lights up with incoming. Curve 8310 AT&T. Any solutions? email me at ccollin690*gmail.com
Offline  
Old 10-09-2009, 09:56 AM   #11 (permalink)
New Member
 
Join Date: Oct 2009
Model: 8330
PIN: N/A
Carrier: Sprint
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Took my phone in to Sprint, tech took it appart showed me a pink sticker that says it proves moisture has got in to it. He also showed me discoloration on the copper contacts under the buttons. Said since the sticker is pink, warranty is void. Store manager said I have to buy a new phone.

Went home took the phone apart and cleaned the copper contacts with mineral spirits put the phone back together and has been working frine for 6 weeks.

Never dropped it in water, but I occasionally clean the screen with Windex and used to keep the phone in my pockets. I have stopped the Windex and the pockets.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.