BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-23-2009, 09:25 PM   #1 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Ugh, issues..

Please Login to Remove!

So I finally got my (previously used)8310 hooked up, and I was enjoying the hell out of it...until today. I was on my break at work and the BB was working as usual. I head downstairs, and I go to check a text about 20 minutes later and the trackball doesn't work. Since then, the ball only works, it seems, when it wants to. In addition, it won't shut down completely- the keyboard and trackball are faintly lit. I've tried pulling the battery an restarting several times over the course of the day, but always with the same result. Any ideas? My buddy suggested reinstalling the latest firmware. Any other suggestions?

Last edited by tedszpara : 04-23-2009 at 09:42 PM.
Offline  
Old 04-24-2009, 12:09 AM   #2 (permalink)
Thumbs Must Hurt
 
BobbehsBerry's Avatar
 
Join Date: Apr 2009
Location: Las Vegas
Model: iPh4
OS: 4.0.0
PIN: Ask politely. ;]
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (Curve 8310)

Interesting.. My 8310 keyboard and ball are only "always" on when its on the charger.. By that I mean the faint glow you speak of. There is a sticky in the forums here for "how-to clean your trackball" I'd give that a look through.
__________________
My Devices:
Blackberry 8310 >> iPhone 4
Offline  
Old 04-24-2009, 05:52 PM   #3 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah I was on the phone with techsupport and they said the keyboard light adjusts to the light of the room so you can find it in the dark I guess...I didn't know that since I just got it.

As for the trackball, I'm going to try cleaning it tonight. I reloaded the OS and it was fine last night, but this morning the same problem started happening again. Hopefully cleaning it will do the trick.
Offline  
Old 04-24-2009, 06:16 PM   #4 (permalink)
Stuck In The '70's Mod
 
ndub33's Avatar
 
Join Date: Feb 2006
Location: The 'burbs east of Seattle.
Model: 9810
Carrier: T-Mobile
Posts: 7,599
Post Thanks: 0
Thanked 4 Times in 4 Posts
Default

Work it back and forth repeatedly in whatver direction it will allow you. Not the most throrough clean you could do, but it may dislodge some debris that is keeping it from functioning.
__________________
1st Step in Troubleshooting: Do you have a BlackBerry Data Plan?
2nd Step in Troubleshooting: Pull the Battery.
Offline  
Old 04-24-2009, 06:24 PM   #5 (permalink)
Retired BBF Moderator
 
Thatzmister2u's Avatar
 
Join Date: Feb 2007
Location: Nor Cal
Model: 9000
PIN: ups! ;)
Carrier: AT&T
Posts: 5,890
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

And a battery pull after what Ndub said to hopefully clear the lighting issue. That is if you didn't somehow expose the device to moisture or liquid. If you did you need to yank the battery and leave it out until you are 100% certain there is no moisture left in the device.

E_
__________________
Unlocked | AT&T BES
*gasp* Un-protected...


www.horizonwirelessonline.com - Unlocks and Repairs
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.