BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-05-2009, 07:53 AM   #1 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8330
PIN: N/A
Carrier: Sprint
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default strange 8330 problem

Please Login to Remove!

I have used the search function but wasnt able to find anyone with the same, strange problem that I have. I hope that I didnt miss it. If I did I am sorry.

Last week I got an 8330 and I loved it, notsomuch now. The problem started when I left it connected to the computer one night by mistake. Since that night my BB wont charge and I get really bad battery life. The strange thing is that I'm able to connect it to the pc, its recognized and I can transfer files. When I connect it to the charger the little charging icon comes up but it's draining the battery instead of charging it.

I've tried using the wall charger, the car charger and charging it off the computer but the same thing happens. The icon appears but nothing is happening. When I first got it I was able to go 2 or 3 days on a single charge. Now I'm lucky to get 6 hours before I have to switch the battery out. I have an old Verizon BB that uses the same type of battery, I'm using that one to keep a spare battery charged.

I'm completely confused. If the USB port was broken I wouldnt be able to connect to transfer files but I can so that cant be the problem. I read a few threads here that suggested turning it off to charge. When it's off and connected to the wall charger the green light flashes but a few hours later it stops flashing and the battery is completely dead.

I've tried updating the OS (desktop manager says there is an available update) It gets about 90% complete then it hangs there and wont ever complete.

Can anybody help me please?
Offline  
Old 06-06-2009, 05:53 AM   #2 (permalink)
No longer Registered.
 
Dawg's Avatar
 
Join Date: Mar 2005
Location: Atlanta
Model: 8330
OS: 4.5.0.138
PIN: 31a6c9c9
Carrier: Verizon BIS
Posts: 13,962
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

sounds like a defective charging port. Could be a damaged pin in the port which would still allow you to transfer stuff
Offline  
Old 06-08-2009, 04:24 PM   #3 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8330
PIN: N/A
Carrier: Sprint
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's interesting. I could've sworn the connector was fine since I'm able to sync it. Thanks for the advice. I'll return it right away
Offline  
Old 06-13-2009, 07:26 PM   #4 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8330
PIN: N/A
Carrier: Sprint
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The power pins and data pins are separate so you can transfer data without a good power connection, but I would try with a different usb cable or a car one to see if it is the cable.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.