BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-20-2009, 11:51 PM   #1 (permalink)
New Member
 
Join Date: Jul 2009
Model: 8320
OS: 4.5.0.161
PIN: 219A2201
Carrier: China Mobile;Vadofone
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Red face Help!My 8320 BB Vodafone can't be used in India

Please Login to Remove!

I bought my BB 8320 Vodafone in HK 2 weeks ago and it was unlocked by software in China. The BB can be very normally used in China and HK. But now when I come to Mumbai, India and put a local Vodafone SIM card into it, it can't be used. It keeps searching the network, but failed to find any and the battery runs out very fast. Sometimes, it can find the Vodafone India networks, but it broke very fast and cannot process any call. It seems the mobile network signal is very not stable. My OS is 4.5.0.161, I just updated it from 4.5.0.124 before I left China. This OS can work very well in China and HK. Now I am in a hurry to buy another simple Sumsong phone. BUt I still want to use my BB. Does anyone know why? pls kindly help me. I will be very grateful.

Last edited by frankyoung1982 : 07-20-2009 at 11:55 PM.
Offline  
Old 07-21-2009, 04:47 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Oct 2007
Location: Los Angeles
Model: None
PIN: N/A
Carrier: ATT
Posts: 1,638
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try checking that it is unlocked:
How do I determine if my BlackBerry is "unlocked"? - BlackBerryFAQ
Offline  
Old 07-21-2009, 12:44 PM   #3 (permalink)
New Member
 
Join Date: Jul 2009
Model: 8320
OS: 4.5.0.161
PIN: 219A2201
Carrier: China Mobile;Vadofone
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have checked that it is surely unlocked as u suggested. All the items show "disable" just as the BlackBerryFAQ instruction said. Is it possible that the problem is caused by OS? When I install the OS, I choosed the country as China, so now after I come to India, should I reinstall the OS and choose the country as India? Could that cause the problem? Now I don't how to remove the OS in it, I failed to reinstall Os cos when it already has an OS inside, the installing procedure doesn't work on it. Now I want to remove the OS and reinstall it to have a try. I hope somebody can help me find what is wrong with my phone. I will be very grateful for ur tips.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.