BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-21-2009, 07:24 AM   #1 (permalink)
New Member
 
Join Date: Jul 2009
Model: Curve
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Curve battery problem - maybe hardware ?

Please Login to Remove!

Curve. Battery was draining after 2 hours. Took to VZ, they replaced battery. GPS turned off. Unit only 4 months old. Cleaned contacts. Checked charger - works fine with other Curve in family.

Still draining in a couple hours with new battery.

Is there any kind of "hard reset" for Curve ? My old Samsung had soft and hard resets - sometimes a hard, back to out-of-the-box reset was required.

Thanks for your help !
Offline  
Old 08-21-2009, 07:29 AM   #2 (permalink)
EPIC MOD
 
ezrunner's Avatar
 
Join Date: Mar 2006
Location: Virginia Beach
Model: ZED10
OS: DOS 3.1
PIN: INK STICK
Carrier: Tmobile
Posts: 12,214
Post Thanks: 9
Thanked 6 Times in 6 Posts
Default

Wirelessly posted (overwhelmingly stressed)

Try a battery pull while powered on!

What apps are running in the background?
__________________
ZED 10
Offline  
Old 08-21-2009, 11:57 AM   #3 (permalink)
Thumbs Must Hurt
 
monkeee2002's Avatar
 
Join Date: Aug 2009
Location: boise, Idaho
Model: 8330m
PIN: s and needles
Carrier: Sprint
Posts: 101
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sounds like your phone is busted.
Give VZW Tech support a call, tell them about the battery swap & the charger works on another BB. They can send you a replacement. (Be advised they may recommend that you "wipe" the device before they process your replacement, so you may want to back it up on BBDM before calling). How long have you had the phone? If you're still in your 30 days, they'll send you a brand new replacement.
Offline  
Old 08-21-2009, 03:46 PM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Aug 2009
Location: UK
Model: 8900
PIN: 256E6891
Carrier: t-mobile
Posts: 98
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay try thes first...
Turn off bluetooth
Turn off wifi...big factor
Reduce screen brightness to 0%
Dont use Vibration ring........and see if you get at least a day.

Its possible that your charger is not sending the right charge. Check if uts the correct charger for the battery.

Next if the above is sorted and not resolve still then wipe the handset. This will restore the BB to factory settings....Options/security options/general settings....BB key and then click wipe handheld.

Now give it a full charge and see what happens. If all this does not work then yes your BB is busted. Be sure that you get your diagnostics documented with your provider so that if they have to relook at anything then they have the notes to look at. That way you save yourself the hassel of going through repetetive processes.

Hope this helps!
__________________
Amod Wadhi
Blackberry Support Specialist
http://chumedh.com
No more outsmarting smartphones!!...We will fix it!
[email address]
Offline  
Old 08-22-2009, 06:45 AM   #5 (permalink)
New Member
 
Join Date: Jul 2009
Model: Curve
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for everyone's comments ! I'll try everything above.

Could Google Sync get corrupted and drain battery constantly ?

Problem BB is my wife's. She uses Google Sync. Right around time of battery problems, she says she's "lost contacts" on BB and google contacts. Shows she has 800 unread email. When I look at Google Sync - says something about synchronization problems and duplicate profiles.

I'm turning automatic sync off and seeing what happens.

Have a great day !
Offline  
Old 08-25-2009, 12:52 PM   #6 (permalink)
Knows Where the Search Button Is
 
sixballer's Avatar
 
Join Date: May 2009
Model: 8530
PIN: N/A
Carrier: Verizon
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Turning "auto dim" off and setting backlight brightness to a VERY low setting will help you a lot and you won't notice a big change. I also set my backlight timeout to 10secs.

Where do you turn off wifi? I didn't know I had wifi.
Offline  
Old 08-25-2009, 01:42 PM   #7 (permalink)
New Member
 
Join Date: Jul 2009
Model: Curve
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for everyone's help. Wife turned off "encrypt files" and turned Google Sync to manual - seems like hardware and battery are behaving normally now.

There's some Google Sync logs that suggest sync corruption - so I think the machine was on some "runaway sync-ing".

Have a great day !
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.