BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 10-31-2009, 02:40 PM   #1 (permalink)
New Member
Join Date: Oct 2008
Model: 8703e
Carrier: Verizon Wireless
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8703e seems dead

Please Login to Remove!

My 8703e won't turn on. I've tried charging it in different outlets, and also at the VZW store. They had no luck either. I've taken the battery out 4 or 5 times and reinserted it. I bought the device fairly recently new (maybe a year ago) - the device, the battery included and the charger from a Verizon Wireless store. The only life I see on the screen is a big battery symbol, with a lightning bolt through it on a greyish background. This shows randomly. The signal light is steady red or usually nothing. VZW does not have the replacement batteries anymore. Any ideas? Thanks.
Old 10-31-2009, 04:44 PM   #2 (permalink)
Dubdub's Avatar
Join Date: Nov 2005
Location: New Hampshire
Model: App6+
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,038
Post Thanks: 54
Thanked 783 Times in 743 Posts

Try eBay for a replacement battery.

Did the device get wet by any chance?

And is it inserted correctly?
-->>BB FAQ

-->>Stinsonddog's Tip Site!


If someone helps, tell them by clicking the Thanks button.!!
Old 10-31-2009, 04:50 PM   #3 (permalink)
Grumpy Moderator
NJBlackBerry's Avatar
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: iPh6
Carrier: AT&T
Posts: 27,867
Post Thanks: 34
Thanked 455 Times in 391 Posts

The 8703 uses the blue battery, right?
Last time I checked, Best Buy carried them. That might be a place to start.
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.