BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-09-2009, 01:13 PM   #1 (permalink)
New Member
 
Join Date: May 2009
Model: 8330
PIN: N/A
Carrier: Cellular South
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Reloading OS problem

Please Login to Remove!

I have the error 507 white screen and I need to reload the OS. I've followed the tutorials of how to do this, but AppLoader gives the following error:

"The BlackBerry Desktop Software does not have BlackBerry Device Software for the device that you have connected to the computer. Contact your wireless service provider or systems adminstrator."

This is what I have tried:

I did the complete removal of Blackberry Desktop (unistalled, removed from registry and removed folders)

I downloaded the 8330 software for my Cellular South 8330 (not an 8330m) from blackberry (8330uAMEA_PBr4.5.0_rel281_PL3.4.0.51_A4.5.0.169_C ellular_South.exe)

I used JL_Cmder v1.9.1 to be sure the phone was wiped

Any ideas of why apploader can't find the OS or am I just missing something?
Offline  
Old 12-09-2009, 01:13 PM   #2 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,806
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

Did you search for and delete VENDOR.XML from your PC C: drive?

Also after you downloaded the handheld OS, you have to install it to your PC:
Offline  
Old 12-09-2009, 01:18 PM   #3 (permalink)
New Member
 
Join Date: May 2009
Model: 8330
PIN: N/A
Carrier: Cellular South
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, I tried deleting the vender.xml too and after completely removing all of the desktop software, i installed the cellular south .exe i downloaded.
Offline  
Old 12-09-2009, 01:23 PM   #4 (permalink)
BlackBerry Mensa
 
MidnightDraven's Avatar
 
Join Date: Jan 2009
Location: Chester,UK
Model: 9000
PIN: N/A
Carrier: Tesco Mobile
Posts: 9,481
Post Thanks: 2
Thanked 110 Times in 110 Posts
Default

You did re-install desktop manager, right?
(Sounds stupid, but you didnt mention it)
__________________
~Midnight Draven

"That's it then. Cancel the kitchen scraps for lepers and orphans, no more merciful beheadings... and call off Christmas."
Offline  
Old 12-09-2009, 01:25 PM   #5 (permalink)
New Member
 
Join Date: May 2009
Model: 8330
PIN: N/A
Carrier: Cellular South
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That's actually what I'm checking out, the cell south download only has applauncher, ("C:\Program Files\Common Files\Research In Motion\AppLoader\Loader.exe") not the full desktop manager. I'm going to install the full desktop manager as well and see if it makes a difference.

Whatever the problem is, I know in the end it will be a bonehead mistake

Last edited by J-Fu : 12-09-2009 at 01:33 PM.
Offline  
Old 12-09-2009, 04:15 PM   #6 (permalink)
New Member
 
Join Date: May 2009
Model: 8330
PIN: N/A
Carrier: Cellular South
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I installed desktop manager. I got a little further. I clicked the application loader and clicked the start button. I connected my device with came up as unknown, then it listed the choices for app install including the OS. When I try to install I get the following error:
Invalid Configuration
The application "email setup application" cannot be loaded because some required files are not available.

I also tried by launching launcher.exe from windows explorer, I received the same error in my first post.

I downloaded desktop manager and the os from blackberry under the cellular south link.
Offline  
Old 12-09-2009, 04:22 PM   #7 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,806
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

OK - here's what should have been down.

Download and install the latest desktop manager (5.0.1)
Download and install the correct 8330 handheld OS

Locate and delete VENDOR.XML on your PC C: drive (it will be in c:\program files\common files\research in motion\apploader)

Then connect your BB and run LOADER from the same sb directory
Offline  
Old 12-09-2009, 04:51 PM   #8 (permalink)
New Member
 
Join Date: May 2009
Model: 8330
PIN: N/A
Carrier: Cellular South
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, 5.0.1 downloading now, i'll uninstall 4.6 first then see how it goes
Thanks!
Offline  
Old 12-09-2009, 10:37 PM   #9 (permalink)
New Member
 
Join Date: May 2009
Model: 8330
PIN: N/A
Carrier: Cellular South
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just gave it a go. Appears to be working! I guess I just needed the correct order Thanks for all the help!
Offline  
Old 12-09-2009, 11:51 PM   #10 (permalink)
New Member
 
Join Date: May 2009
Model: 8330
PIN: N/A
Carrier: Cellular South
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

scratch that, DM seemed to be working but gave an unspecified error. I tried again by using launcher.exe and still got the same message...
Offline  
Old 12-10-2009, 06:10 PM   #11 (permalink)
New Member
 
Join Date: Dec 2009
Model: 8330
PIN: N/A
Carrier: verizon
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Latest version of Crackmem does a nice job of finding and killing vendor.xml
Offline  
Old 12-11-2009, 03:08 PM   #12 (permalink)
New Member
 
Join Date: May 2009
Model: 8330
PIN: N/A
Carrier: Cellular South
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I finally broke down and went by cellular south and they reloaded. First thing I checked was the OS version....found my mistake....yep, it was a bonehead mistake. Live and learn. I checked on the label under the battery to be sure of the model number, it says 8330, under about it says 8330m. Then I searched for the difference and learned. So all I should have needed was the 8330m device software whereas I was downloading the 8330. Cellular South has both. Thanks for all the help!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.