BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-02-2010, 11:21 AM   #1 (permalink)
New Member
 
Join Date: Jan 2010
Model: 8330
PIN: N/A
Carrier: Bell Mobility
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Send and receive data issue

Please Login to Remove!

Hi and thank you for allowing me to be a part of your community.
I have a Bell Mobility BB Curve 8330, It's activated on a BB plan and from what the Bell reps tell me, the problem is with the phone.

The data arrows in the top right of the screen only point/flash upwards (sending) I never get a downwards (receiving) arrow.
I have installed and re-installed several versions of s/w but nothing seems to help. I cannot place/receive a call or txt msg. Upon placing a call, I don't get a ring tone, all I get is "call FAILED please try again"

Some insight would be appreciated
Thanks,
Dan
Offline  
Old 01-02-2010, 11:33 AM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,016
Post Thanks: 54
Thanked 778 Times in 740 Posts
Default

Have you tried a battery pull?

Has the device been dropped or has it gotten wet?

Was this working properly and then just stopped working or did you buy it used and it never worked?
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 01-02-2010, 11:33 AM   #3 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

I would agree with the Bell reps. Sounds like a problem with the BlackBerry hardware.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 01-02-2010, 12:22 PM   #4 (permalink)
New Member
 
Join Date: Jan 2010
Model: 8330
PIN: N/A
Carrier: Bell Mobility
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dubdub View Post
Have you tried a battery pull?

Has the device been dropped or has it gotten wet?

Was this working properly and then just stopped working or did you buy it used and it never worked?
Never been dropped but it was shipped UPS
Never worked and it is a factory refurb from a reputable ebay seller. He will refund payment but has no more stock so I guess Im SOL.
Offline  
Old 01-02-2010, 12:25 PM   #5 (permalink)
New Member
 
Join Date: Jan 2010
Model: 8330
PIN: N/A
Carrier: Bell Mobility
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dubdub View Post
Have you tried a battery pull?

has it gotten wet?
Many battery pulls and I have no idea if it has gotten wet, visually it does not look like it. The phone appears to be brand spanking new, not a mark on it.
Offline  
Old 01-02-2010, 03:48 PM   #6 (permalink)
BlackBerry Master
 
Trimix's Avatar
 
Join Date: Apr 2008
Location: smelLA, caLAMEfornia
Model: 8320
OS: 4.5.0.182
PIN: infarina
Carrier: of alotta bacteria
Posts: 4,932
Post Thanks: 1
Thanked 6 Times in 6 Posts
Default

Wirelessly posted (The Dacia Sandero of data plan)

Never worked...I'd get a refund and try to find another BB.
Offline  
Old 01-02-2010, 05:06 PM   #7 (permalink)
Thumbs Must Hurt
 
monkeee2002's Avatar
 
Join Date: Aug 2009
Location: boise, Idaho
Model: 8330m
PIN: s and needles
Carrier: Sprint
Posts: 101
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

At the risk of pointing out the obvious, did you register it when you got it?
( options, advanced options, host routing table, menu key-'register now' )

Or set it up on BIS?
__________________
LET ME GOOGLE THAT FOR YOU
Offline  
Old 01-04-2010, 05:40 AM   #8 (permalink)
New Member
 
Join Date: Jan 2010
Model: 8330
PIN: N/A
Carrier: Bell Mobility
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by monkeee2002 View Post
At the risk of pointing out the obvious, did you register it when you got it?
( options, advanced options, host routing table, menu key-'register now' )

Or set it up on BIS?
Yep
Offline  
Old 01-04-2010, 06:58 AM   #9 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,697
Post Thanks: 15
Thanked 498 Times in 485 Posts
Default

Wirelessly posted

I agree with the others. I hope you've already done it: Get your money back.
__________________
- Ira
Offline  
Old 01-04-2010, 07:54 AM   #10 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,016
Post Thanks: 54
Thanked 778 Times in 740 Posts
Default

Agree with returning for a refund.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.