BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-28-2010, 12:43 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2008
Model: 8320
PIN: N/A
Carrier: T-Mobile
Posts: 27
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unlocked 8320 and T-Mobile certificates

Please Login to Remove!

Hi, a friend of mine is a cellphone tech that fixes cellphones for a living, recently he got a few unlocked Blackberry 8320s that still won't work with T-Mobile sim cards.

When we put a T-Mobile sim card in the phone, the indicator in the top right corner turns to arrows as if it was trying to connect to the servers and doesn't matter how long it tries it just won't connect.

After playing around with the phones a bit I found out that under Options ==> Security Options ==> Certificates, all the T-Mobile USA certificates (4 tmobile ones in total) have a red cross next to them. I'm guessing that's what's causing the problem.

So does anyone have any clue how that can be fixed? I've already flashed the firmwares on all the phones to 4.5 and that still didn't fix it.
Offline  
Old 04-28-2010, 07:19 AM   #2 (permalink)
Thumbs Must Hurt
 
d1ulove's Avatar
 
Join Date: Apr 2009
Location: Northern Mariana Islands
Model: 9700
PIN: N/A
Carrier: FEDEX
Posts: 81
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I already encounter that my diagnose is the hardware problem. I do everything that i can, but still same problem.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.