BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-12-2007, 11:33 AM   #1 (permalink)
New Member
 
Join Date: Jun 2007
Model: CURVE
PIN: N/A
Carrier: AT&T
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default "Appointment deleted externally. Changes will be lost and the viewer closed."

Please Login to Remove!

I seem to get this message on many of my calander entries when i try to edit them. Any ideas?
Offline  
Old 11-21-2007, 07:07 PM   #2 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8320
PIN: N/A
Carrier: T-Mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default "appointment deleted externally"

I've been having this issue with my new Blackberry Curve 8320. Does anyone know what is causing it?
Elise
Offline  
Old 11-22-2007, 10:08 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: May 2007
Location: New Mexico
Model: 8320
OS: 4.5.0.55
Carrier: T-Mobile
Posts: 1,461
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

edit

Last edited by sgtcasey : 12-24-2007 at 06:39 PM.
Offline  
Old 11-29-2007, 11:14 AM   #4 (permalink)
New Member
 
Join Date: Nov 2006
Model: 8130
Carrier: Bell
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Same error

I have the same error on one of my recurring entries.

I recently bought my own Internet Blackberry and gave my old BES Blackberry back to my old company when I quit. I backed up and restored my calendar and address book (and so much more that I didn't want) to my new BB. (Yes, I had to get my service books replaced after that. Oops.)

Anyway, I've been able to delete a bunch of old stuff, but this one recurring just won't go away, reporting that error.
Offline  
Old 11-30-2007, 04:41 PM   #5 (permalink)
Thumbs Must Hurt
 
Airmark1's Avatar
 
Join Date: Mar 2006
Location: 94564
Model: 8300
Carrier: ATT uhhhh Cingular uhhh I mean ATT
Posts: 195
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This happened to me me. This is my theory.

I am on a 8300 ATT - BIS

When I create appointments, I usually end up "inviting" my my wife so that she can see my schedule. For whatever reason, AOL was my default "send meeting request using" email address. I was able to change it to gmail or whatever when I made that appointment, but AOL was the default.

One day, i finally decided to get ride of AOL account. I did this via my BB online.

As soon as deleted the AOL account, every appointment that I had set up without inviting using a different email account had this "appointment deleted externally" issue. Ones that I had sent with invite and even ones ones that I had not! ALL of them were jacked. NOT GOOD.

So, when making an appointment, I wonder if there is a hidden "tag" that gets attached to appointments. Delete an email account, and you confuse the BB.

----

Happily, my default Invite Sending email address is now my gmail account. When I invite people, my appointments automatically get copied to my Google Calendar. Pretty cool.

Anywho, I am wondering since
__________________
Intelligent design my ass


?was it a cat i saw?

Last edited by Airmark1 : 11-30-2007 at 04:43 PM.
Offline  
Old 01-25-2008, 12:32 AM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2008
Location: Colorado
Model: 9800
OS: 6.0.0.600
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 4
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Airmark1 View Post
This happened to me me. This is my theory.

I am on a 8300 ATT - BIS

When I create appointments, I usually end up "inviting" my my wife so that she can see my schedule. For whatever reason, AOL was my default "send meeting request using" email address. I was able to change it to gmail or whatever when I made that appointment, but AOL was the default.

One day, i finally decided to get ride of AOL account. I did this via my BB online.

As soon as deleted the AOL account, every appointment that I had set up without inviting using a different email account had this "appointment deleted externally" issue. Ones that I had sent with invite and even ones ones that I had not! ALL of them were jacked. NOT GOOD.

So, when making an appointment, I wonder if there is a hidden "tag" that gets attached to appointments. Delete an email account, and you confuse the BB.

----

Happily, my default Invite Sending email address is now my gmail account. When I invite people, my appointments automatically get copied to my Google Calendar. Pretty cool.

Anywho, I am wondering since
I've seen this problem as well, but my situation is a little different.
I've never sent an e-mail from a calendar item.

My calendar seemed to be working correctly until I tried setting up an e-mail account (connection to existing earthlink account). Having the e-mail account setup made my BB seem very sluggish, so I deleted it. It was after this that I noticed all my appointments had this "deleted" problem. I popped the battery and rebooted, and then all appointments were gone!

So, I restored them from a recent backup, but had no idea what caused the issue. Then I saw this thread and tried an experiment. I set up the e-mail again. The act of setting it up this time caused all appointments to be duplicated in my day view! One copy had the "deleted" behavior, and the other copy seemed normal. So, I deleted the e-mail account. Still had duplicates. Rebooted the BB, and now all duplicate items are "valid". Not sure what happened.

I've got an 8310 running 4.2.2.170.

Seems there is an issue with setting up e-mail. I'm using BIS, not BES. Not only does the e-mail setup seem to corrupt the calendar database, it makes the BB run very sluggishly. (I've got ~19Mb free, no SD card.)
Offline  
Old 01-25-2008, 09:59 AM   #7 (permalink)
CrackBerry Addict
 
Jagga's Avatar
 
Join Date: Oct 2004
Location: Toronto
Model: Z10
Carrier: Lord Rogers - 107
Posts: 862
Post Thanks: 6
Thanked 6 Times in 5 Posts
Default

Quote:
Originally Posted by MikeCheng View Post
I seem to get this message on many of my calander entries when i try to edit them. Any ideas?
Never seen this before. Was the appointment setup by you initially, because it sounds as though its not, and it was deleted by another party set for that appointment - the person that created it. I'm thinking since you're deleting an appointment that no longer exists on the server, or calendar app elsewhere (or native on the BB HH) then you cannot delete for it to sync.

BINGO ... I was wrong found the issue ....


BlackBerry Search Results

Problem

When you select an appointment in the Calendar, the following message appears: Appointment deleted externally, changes will be lost and viewer closed.

Cause

The Calendar database is corrupted.


Definately read this if you're using Content Protection.
__________________
Senior help desk administrator (rim_db_admin_sr_helpdesk)
Serious Mobile
Offline  
Old 01-25-2008, 12:03 PM   #8 (permalink)
New Member
 
Join Date: Jan 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same issue and found a thread on this on another board. Some people (including me) were able to resolve the problem by doing a battery pull. Hope this works.
Offline  
Old 01-26-2008, 09:34 PM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
Baggman's Avatar
 
Join Date: Mar 2006
Location: Hill Country, TX
Model: 9800
PIN: 7-10 split
Carrier: AT&T Mobility
Posts: 241
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mervynle View Post
I had the same issue and found a thread on this on another board. Some people (including me) were able to resolve the problem by doing a battery pull. Hope this works.


Worked. Amazing what a battery pull will cure (VD?) !!
__________________
Baggman 9800 now; 9700, 9000, 8300, 8700g, 7105t, & 7100t past
Offline  
Old 03-20-2008, 01:21 PM   #10 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Mar 2008
Location: Newcastle, England
Model: 9520
OS: 5.0.0.436
Carrier: Vodafone
Posts: 251
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't have the issue with the calendar items any more cos a battery pull got rid of all my calendar items bar 1

I tried to sync to my outlook which has my correct data on it but the thing tries to delete my outlook data also no matter how much i try to tell it that outlook wins in any conflicts.

i then followed some instructions to delete my calendar via the Advanced section in the DM.

This got rid of the lot and when i went back in and tried to sync again with the settings i wanted it all worked and i now have my calendar back on track.

Ta Da.

Last edited by aapierre : 03-20-2008 at 01:25 PM.
Offline  
Old 05-16-2008, 12:27 PM   #11 (permalink)
New Member
 
Join Date: May 2008
Model: 8320
PIN: N/A
Carrier: Orange
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi, i tried taking out the battery as suggested below on my 8320. I didnt switch it off first, just pulled it straight out and put it back in after about 5 seconds or so. The phone took a while to start up but it certainly fixed the problem. I've only just done that so I will write another post if teh problem reoccurs anytime soon. Hope this helps
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.