BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-09-2007, 05:36 PM   #1 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Curve & Vista

Please Login to Remove!

I downloaded the newest version of the Desktop Manager software (4.2 Sp2) and I installed it. When I hook up my Blackberry it installs one driver (for Blackberry Device) but it can't seem to find the driver for RIM Composite Device.

I have googled and googled and not found a solution to this though I've read of people using their blackberry with Vista and having no problems.

I hope this has an easy fix.

Thanks in advance!
Offline  
Old 07-09-2007, 06:04 PM   #2 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Bump

Please do help me, or direct me to where I could find some help.
Offline  
Old 07-09-2007, 08:01 PM   #3 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

So seriously, no one can help me?

I know I'm not the only one with this problem.
Offline  
Old 07-09-2007, 08:44 PM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Iowa
Model: none
Carrier: Sprint
Posts: 49
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default "Composite Device" ?

Hi,

What do you mean by "Composite Device"? Had the program not installed correctly so far? Is there something you're trying to do specifically that's not working correctly?

Please let me know and I'll see what I can do to help. Had you attempted to clean uninstall it and reinstall it again at any point?

Thank you,

BBTech

Quote:
Originally Posted by braulio View Post
I downloaded the newest version of the Desktop Manager software (4.2 Sp2) and I installed it. When I hook up my Blackberry it installs one driver (for Blackberry Device) but it can't seem to find the driver for RIM Composite Device.

I have googled and googled and not found a solution to this though I've read of people using their blackberry with Vista and having no problems.

I hope this has an easy fix.

Thanks in advance!
__________________
BB Tech Rep
Offline  
Old 07-09-2007, 08:56 PM   #5 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

On my computer, Vista OS. When I plug in my Curve via USB, it begins installing the drivers automatically, two of them. One of them is "Blackberry Device" and that installs correctly. Then, the second installation which is for "RIM Composite Device" (as it shows up on my computer) fails.

I installed the Desktop Manager software that came on the disc included with my Curve but that didn't work. Then I went through and uninstalled it to reinstall with the newer 4.2 Sp2 version of the software.

Still, the "RIM Composite Device" seems to bar it from working.

What I'm trying to do at the least is to just get the Desktop Manager software and my PC to recognize the Curve.
Offline  
Old 07-09-2007, 09:07 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Iowa
Model: none
Carrier: Sprint
Posts: 49
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default "Composite Device"

Hi,

Hmm.. what is this "COMPOSITE DEVICE" supposed to be used for? Could it be some type of MODEM driver? Had you gone to BlackBerry - BlackBerry Support | Knowledge Base, Product Documentation Software & Support Programs and make certain to download the DTM 4.2 SP2 file? If so, what specific file name did you download? The same website, I believe, has some modem drivers available and also, I believe, the BlackBerry Device Manager program in case you need that too.

I'll see what I can find on the BB Tech Knowledge Base dealing with "composite devices" and see what comes up. Does that have some video / camera support? Can you play some mpegs or other video formats on it? It could involve those too. Don't know what I can find but I'll do some searching and see what I find.

__________________
BB Tech Rep
Offline  
Old 07-09-2007, 09:10 PM   #7 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'll look around too, thanks for helping. I did download that file though. The exact filename for what I downloaded and installed is "Desktop Software v4.2 SP2 without Media Manager (English)."
Offline  
Old 07-09-2007, 09:15 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Iowa
Model: none
Carrier: Sprint
Posts: 49
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default "Handheld Not Found"

Hi again,

Here is some information from the BB Knowledge Base that may prove helpful. To me it sounds like a "Handheld Not Found" type error. These steps are provided by RIM which may help in resolving this issue. Try it and let me know how it turns out:

BlackBerry Search Results

Quote:
Originally Posted by braulio View Post
What I'm trying to do at the least is to just get the Desktop Manager software and my PC to recognize the Curve.
__________________
BB Tech Rep
Offline  
Old 07-09-2007, 09:20 PM   #9 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

None of that really helped but honestly thanks for taking the time to help me.

I will keep looking at what you showed me as well as elsewhere on the Blackberry support site.
Offline  
Old 07-09-2007, 09:36 PM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Iowa
Model: none
Carrier: Sprint
Posts: 49
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Connection problems?

Have you maybe attempted to change USB ports? Checked the USB cord itself for defects? Clean uninstalled/reinstalled the DTM at any time? How about disabling the RIM Virtual Serial Ports and then rebooting the PC? Any of those steps done?

Sorry it wasn't much help.

Offline  
Old 07-09-2007, 09:44 PM   #11 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just uninstalled and reinstalled the DTM. I also installed the Device Handler and the Modem Drivers from the Blackberry Software site. DTM is installing as I type and I rebooted my phone. I have cycled through all three of my USB ports, and checked the cable. I don't know about disabling the RIM Virtual Serial Ports however.
Offline  
Old 07-09-2007, 10:01 PM   #12 (permalink)
New Member
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

And none of that has worked, ugh. It still shows the "RIM Composite Device" failing installing.

I hate this.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.