BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-09-2007, 07:02 PM   #1 (permalink)
New Member
 
Join Date: Aug 2007
Model: Curve
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Curve with TMO?

Please Login to Remove!

Hey all!

Bought my first Curve and unlocked it so I can use it with T-Mobile. The thing is I called tmo reps and they said that Curve wont work with tmo as far as data (emails, internet, messengers etc...) but when I first turned it on, internet worked for like 15 min then stopped. Then started working again next day.

Email wont work at all. I tried resending the service books or reregistering and nothing helped.

So basically what Im asking is, is there some way of encoding the Curve or doing something to its OS so it can fully function with TMO?

Any help, much appreciated!
Offline  
Old 08-09-2007, 07:06 PM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
AlexKidd's Avatar
 
Join Date: Apr 2007
Location: Louisville, KY
Model: 8300
PIN: N/A
Carrier: ▪T▪▪▪Mobile▪
Posts: 262
Post Thanks: 0
Thanked 0 Times in 0 Posts
Arrow

Quote:
Originally Posted by Unknown View Post
So basically what Im asking is, is there some way of encoding the Curve or doing something to its OS so it can fully function with TMO?
There are lots of people using the BB Curve on T-Mobile, including myself. Just read through the threads in this forum and do a search before posting your specific problems.

--Kidd
Offline  
Old 08-09-2007, 07:44 PM   #3 (permalink)
Latino Hasta La Muerte
 
Join Date: Jan 2005
Location: Denville, NJ.
Model: 7250
OS: 4.1
PIN: G!!!
Carrier: Verizon
Posts: 9,045
Post Thanks: 52
Thanked 305 Times in 293 Posts
Default

The trick to using the Curve with TMO is to install the British carrier O2's operating system. Then you get your browser. Here's the O2 Download Page.
Offline  
Old 08-09-2007, 07:57 PM   #4 (permalink)
New Member
 
Join Date: Aug 2007
Model: Curve
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rambo47 View Post
The trick to using the Curve with TMO is to install the British carrier O2's operating system. Then you get your browser. Here's the O2 Download Page.

Will that allow me to use my email as well?

Thanks for your help
Offline  
Old 08-09-2007, 08:17 PM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Dec 2005
Location: Chicago - Atlanta - Houston
Model: 9700
PIN: 30EC5097
Carrier: T-Mobile
Posts: 421
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am wondering if there might be a simpler option than loading the O2 OS. When I spoke to someone at Blackberry about the issue of the browser not showing up it was suggested that I perform the following:

Go into Options - Advanced Options - Host Routing Table. Then, scroll to the entry in bold and click the Menu button on your device. Scroll to "Register Now" and then you are done.

According to the person I spoke to this should work and I did it to someone else's device with success. However, it may be that the Curve needs the O2 OS. I can't say for certain but this may be an option for you.
Offline  
Old 08-09-2007, 08:31 PM   #6 (permalink)
New Member
 
Join Date: Aug 2007
Model: Curve
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ye that didnt work with Curve :( but I need my email back too

Quote:
Originally Posted by pinhead View Post
I am wondering if there might be a simpler option than loading the O2 OS. When I spoke to someone at Blackberry about the issue of the browser not showing up it was suggested that I perform the following:

Go into Options - Advanced Options - Host Routing Table. Then, scroll to the entry in bold and click the Menu button on your device. Scroll to "Register Now" and then you are done.

According to the person I spoke to this should work and I did it to someone else's device with success. However, it may be that the Curve needs the O2 OS. I can't say for certain but this may be an option for you.
Offline  
Old 08-09-2007, 08:50 PM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Dec 2005
Location: Chicago - Atlanta - Houston
Model: 9700
PIN: 30EC5097
Carrier: T-Mobile
Posts: 421
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Then you will probably have to load the O2 OS to your device...that is what I did with mine and it is working flawlessly.
Offline  
Old 08-09-2007, 09:02 PM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2006
Location: Bronx, NY
Model: Bold
Carrier: ATT
Posts: 199
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am running the O2 software on an unlocked O2 curve since June. It is flawless. Email, browser. Perfect.
Offline  
Old 08-09-2007, 09:02 PM   #9 (permalink)
Thumbs Must Hurt
 
sjsilverman's Avatar
 
Join Date: May 2005
Model: 9700
Carrier: T-Mobile & China Mobile
Posts: 191
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

have you gone into the mytmobile web page and changed your pin to your new device? This would have a direct effect on whether you receive your emails.
Offline  
Old 08-09-2007, 09:15 PM   #10 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

There is a known issue with the service book not being pushed for Curves on TMo running OS's newer than the O2 OS linked above. The later OS's will work fine but no browser service book will be pushed.
Offline  
Old 08-09-2007, 09:23 PM   #11 (permalink)
New Member
 
Join Date: Aug 2007
Model: Curve
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ye, I reinstalled the OS and nothing changed. Same issue :(

PS Before installing the new british OS do I delete the vendor.xml file or not? Cause I did.
Offline  
Old 08-09-2007, 10:03 PM   #12 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

What exactly is the issue? What does it say below your bars? EDGE, edge, GPRS, gprs, or GSM? Does it say data connection refused?

If the Curve is unlocked then all should work fine. did you do as suggested above and change your pin and imei on the tmobile website for your email?
Offline  
Old 08-09-2007, 10:31 PM   #13 (permalink)
CrackBerry Addict
 
noeffectx's Avatar
 
Join Date: Apr 2006
Location: nyc & pt. pleasant beach, nj
Model: 8320
PIN: 123456
Carrier: T-mobile
Posts: 565
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Unknown View Post
Ye, I reinstalled the OS and nothing changed. Same issue :(

PS Before installing the new british OS do I delete the vendor.xml file or not? Cause I did.
yep you are supposed to delete the vendor.xml
__________________
Exchange 2007
BES 4.1.6.9

http://www.flickr.com/groups/blackberry/
Offline  
Old 08-10-2007, 12:55 AM   #14 (permalink)
New Member
 
Join Date: Aug 2007
Model: Curve
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I didnt change the pin from tmo site cause I couldn find it anywhere, it says "EDGE" but the browser icon and email icon is missing. I can always call tmo and change the pin and imei settings but even after I do that myt browser still wont work cause that has nothing to do with my internet. So if I can atleast get the internet back first, I can then play with the email
Offline  
Old 08-10-2007, 01:37 AM   #15 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Quote:
Originally Posted by Unknown View Post
I didnt change the pin from tmo site cause I couldn find it anywhere, it says "EDGE" but the browser icon and email icon is missing. I can always call tmo and change the pin and imei settings but even after I do that myt browser still wont work cause that has nothing to do with my internet. So if I can atleast get the internet back first, I can then play with the email
I think you have two problems here.

1. No Browser: Check the OS installed to the device. Go to Options >About. What is the version number? It should start with 4.2.2.xx. If the last two numbers are higher than .67 that is why you don't have a browser. You need to have OS 4.2.2.67 in order to get a browser.

2. No email: Go to TMobile, sign in, and go to setup internet email. Change the PIN and IMEI to the PIN and IMEI of the Curve. You can find the pin and IMEI on the sticker under the battery. You need this info entered into the TMobile BIS website in order to get your email.
Offline  
Old 08-10-2007, 02:03 AM   #16 (permalink)
New Member
 
Join Date: Aug 2007
Model: Curve
PIN: N/A
Carrier: TMO
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

the last two numbers are .89

Where can I find a diff OS then to download grade?

Ow and tmo site wont let me log in cause theyre doing something so Ill change that later
Offline  
Old 08-10-2007, 07:24 AM   #17 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

This info was already posted for you above. You need to install this software linked in [url=http://www.blackberryforums.com/general-8300-series-discussion/89908-curve-tmo.html#post628940]this post.

TMobile doesn't offer software for the Curve because they haven't released the Curve for TMobile.

To downgrade your OS, follow these instructions in this order:

1. Uninstall any newer OS's from your PC using Control Panel, Add/Remove Programs.
2. Download and install Deskotp Manager 4.2 SP2 from here
3. Download and install to your PC, the O2 OS (from the link above). Make sure the BB is not plugged in during this installation.
4. Delete the vendor.xml file located in c:\program files\common files\research in motion\apploader
5. Plug in BB. Open Desktop Manager and run Application Loader. It should show that a "downgrade" is pending.
6. Finish the installation.
Offline  
Old 08-10-2007, 11:38 AM   #18 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2006
Location: ny
Model: 8700g
Carrier: tmobile
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i didnt delete the vendor xml file before installing and now its basically the same as it was before i downgraded(att). I tried to reinstall the o2 update but it told me there is nothing to do because its already installed. how do i reinstall minus the xml file?

Last edited by precision80 : 08-10-2007 at 11:41 AM.
Offline  
Old 08-10-2007, 11:10 PM   #19 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Quote:
Originally Posted by precision80 View Post
i didnt delete the vendor xml file before installing and now its basically the same as it was before i downgraded(att). I tried to reinstall the o2 update but it told me there is nothing to do because its already installed. how do i reinstall minus the xml file?
What version is on your handheld now? You need to uninstall any versions later than the O2 version from the PC. Then make sure the O2 version is installed to the PC. Then delete the vendor.xml file (again) and try the load again.
Offline  
Old 08-10-2007, 11:27 PM   #20 (permalink)
Knows Where the Search Button Is
 
Join Date: Aug 2007
Model: 8800
PIN: N/A
Carrier: Tmobile USA
Posts: 41
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey guys I bought a Unlocked BlackBerry Curve and recieved it today. It is a at&t branded phone, and as soon as I stuck my SIM card in, TZones appeared as did the browser. It seems to work flawlessly...


However Im wondering like the OP, will the same thing happen to me as well? Where it works for a few days and then it stops and Im forced to install the O2 operating system? Im just wondering if I got lucky and dont have to install the O2 operating system, or should i just get it over with right now and install it.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.