BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-14-2007, 05:20 PM   #1 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Help! Dropped in Toilet... no backlight

Please Login to Remove!

A cry of help to any knowledgeable experts....

I managed to drop my 8300 Curve into a toilet this morning; albeit briefly. All my functions seem to be back to normal - I had some keys doing funky things - but I have no backlight.

Any advice?

Also, I checked the liquid damage indicator... still white.
Offline  
Old 08-14-2007, 05:42 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2007
Model: 8300
PIN: N/A
Carrier: Tmobile
Posts: 42
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Insurance
Offline  
Old 08-14-2007, 06:08 PM   #3 (permalink)
Thumbs Must Hurt
 
Dream Rider's Avatar
 
Join Date: Jun 2007
Location: Bothell WA
Model: 8220
OS: 4.6.0.200
PIN: N/A
Carrier: AT&T
Posts: 159
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DMAC18 View Post
A cry of help to any knowledgeable experts....

I managed to drop my 8300 Curve into a toilet this morning; albeit briefly. All my functions seem to be back to normal - I had some keys doing funky things - but I have no backlight.

Any advice?

Also, I checked the liquid damage indicator... still white.
Tune off the phone and remove the battery. You need to give the phome a few days to dry WITHOUT POWER!!! Put the device by a fan to help the drying process. It is important to NOT check the device to see if it is ok until you give it several days. Powering it on while damp can damage it more. If it is going to recover it need time.
Here is the link to show where the indicator really is:
http://farm2.static.flickr.com/1068/...a66d09.jpg?v=0
__________________
If you are going to dream - DREAM LARGE

Last edited by Dream Rider : 08-14-2007 at 06:14 PM.
Offline  
Old 08-14-2007, 06:08 PM   #4 (permalink)
Retired BBF Moderator
 
Thatzmister2u's Avatar
 
Join Date: Feb 2007
Location: Nor Cal
Model: 9000
PIN: ups! ;)
Carrier: AT&T
Posts: 5,890
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Your probably too late but you could try.....start with pulling the battery right now and go read....

Got Your BlackBerry Wet? - BlackBerryFAQ

It might save you some serious cash if it ever happens again.

Sorry for the potential loss....

Best of luck!

E-
__________________
Unlocked | AT&T BES
*gasp* Un-protected...


www.horizonwirelessonline.com - Unlocks and Repairs
Offline  
Old 08-14-2007, 11:55 PM   #5 (permalink)
BlackBerry Extraordinaire
 
Join Date: May 2005
Location: AZ
Model: 9900
Carrier: ATT
Posts: 1,111
Post Thanks: 0
Thanked 14 Times in 14 Posts
Default

and i have sent my bb for diving twice and came out ok because i put the bb in a glass jar or some small container and put my show vac thru the lid and suck the moisture out for atleast 10-15 times and then let it dry. both times worked for me. If you tried turning on ----OUT of LUCK
Offline  
Old 08-15-2007, 05:57 AM   #6 (permalink)
No longer Registered.
 
greggebhardt's Avatar
 
Join Date: Jan 2005
Location: Jacksonville, FLorida
Model: 9000!
PIN: NOT!
Carrier: AT&T
Posts: 3,762
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sounds like it was not turned off after the emersion. Still worth trying to dry out!
Offline  
Old 08-15-2007, 06:16 AM   #7 (permalink)
Thumbs Must Hurt
 
Kriz's Avatar
 
Join Date: Jun 2005
Location: Detriot
Model: 9000
Carrier: AT&T
Posts: 124
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok..don't laugh..The jar or ziplock thing works if you put a piece of white bread in there..I know..But a friend dropped his phone in the toilet, took the battery out, cover off and put inside a ziplock bag and put a piece of white wonder bread in there..a day later all was good...makes ya "wonder" lol...but it did work
__________________
Treo 600, 650, 7520, Moto Q, 7130c, 8800, 8300, 8820, 8310, 9000, 9700
Offline  
Old 08-15-2007, 08:00 AM   #8 (permalink)
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks for your replies

All -

Thanks for your replies. I think that I probably screwed up trying to turn it on directly after. It is seemingly dead now. I have insurance through NCOA and the white box by the sim card is still white... Any other considerations before trying with an insurance claim on it?

A very greatful DMAC
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.