BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-05-2010, 01:32 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2006
Model: 9630
OS: 5.0.0.484
Carrier: Verizon
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgrading T-mobile 8520 to OS or 5.0.0.411 5.0.0.509

Please Login to Remove!

I can't seem to upgrade my T-mobile 8520 to the new OS 5.0 software. I also have a Tour, so I uninstalled all the files related to that device. I tried both versions of the device software available for the 8520. I deleted the vendor file and I get error messages every time. Using apploader, i get a message that "The blackberry Desktop software does not have blackberry device software for the device..." I have no idea what the problem is because I definitely have a white T-mobile 8520.

I read in a couple of other forums that I should delete the vendor.xml and make sure to disconnect from the internet when i run the install. this does not work either. i also read that i should go into add/remove programs and modify the installation for blackberry desktop manager, making sure that automatically checked for updates is turned out. this doesn't work either. someone wrote about the apploader or DM connecting to the internet and re-creating another vendor.xml file.

when i try to install not through apploader but through DM, DM sees the upgrade but when i try to install, it says that the upgrade is only for customers with an active blackberry service plan (something like that).

any help?
Offline  
Old 03-05-2010, 01:40 PM   #2 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

You already said the answer.

You need a BlackBerry data plan to upgrade to 5.0.
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Old 03-05-2010, 01:43 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2006
Model: 9630
OS: 5.0.0.484
Carrier: Verizon
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jsconyers View Post
You already said the answer.

You need a BlackBerry data plan to upgrade to 5.0.
Thanks for your response. I do have email and internet on that phone. Doesn't that require a data plan?
Offline  
Old 03-05-2010, 01:47 PM   #4 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

You need a BlackBerry data plan.
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Old 03-05-2010, 02:08 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2006
Model: 9630
OS: 5.0.0.484
Carrier: Verizon
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jsconyers View Post
You need a BlackBerry data plan.
Thanks for clearing this up. Yep, don't have a bberry data plan on the 8520. No workaround avail to upgrade? How about when t-mobile releases official?
Offline  
Old 03-05-2010, 02:28 PM   #6 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

No workaround that I am aware of. It doesn't matter if T-Mobile officially releases it or not. To upgrade to 5.0, you will need a BB Data plan.
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Old 03-08-2010, 01:13 PM   #7 (permalink)
Knows Where the Search Button Is
 
jj10174's Avatar
 
Join Date: Aug 2007
Location: Kent, OH
Model: 9700
OS: 5.0.0.330
Carrier: T-Mobile
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I know this is only slighly related. I upgraded by 8520 to 5.0.0.441, and wanted to enable the Visual Voice mail. While TMO does not charge for visual voice mail, they do have to add the provisioning. I had to convince they support person to change my line to a 9700 so their system would allow they to add the feature.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.