BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-17-2010, 05:53 PM   #1 (permalink)
New Member
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: t-mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default can't install 5.0 on curve 8520

Please Login to Remove!

I have a 8520 and I recently tried to upgrade to 5.0 and the desktop managers keeps telling me that no software updates are required for my device. I currently have the 4.6.1.259. Anybody know why I cant upgrade or how to do it? i have no data plan and i have deleted the vendor file in app loader afer that is there another vendor file somewhere. what are the next steps. thanks for your help.
Offline  
Old 08-17-2010, 07:09 PM   #2 (permalink)
CrackBerry Addict
 
Superh3ro's Avatar
 
Join Date: Nov 2008
Location: Kuwait
Model: 9900
OS: 7.0.0.598
PIN: N/A
Carrier: Zain kw
Posts: 578
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

this will be helpful

How do I upgrade the OS on my BlackBerry? - BlackBerryFAQ
__________________
-->>xxx1090;wixxx1090;xxx1090;exxx1103;
-->>facexxx1074;ooxxx954;

xxx9608;xxx9553;xxx9612;xxx9474;xxx9608;xxx9474;xxx9553;xxx9612;xxx9553;xxx9474;xxx9474;xxx9608;xxx9553;xxx9612;xxx9474;xxx9553;xxx9608;xxx9474;
supexxx1103;xxx1085;xxx1079;roxxx63743;xxx1084;ac.coxxx1084;
Offline  
Old 08-17-2010, 07:39 PM   #3 (permalink)
New Member
 
Join Date: May 2008
Model: 8100
PIN: N/A
Carrier: t-mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

no luck
Offline  
Old 08-17-2010, 09:49 PM   #4 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,806
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

Actually it wasn't helpful.

The problem is you don't have a data plan. OS 5 will not install EASILY without a data plan. Search or hunt around for threads on how to install OS 5 without a data plan. It can be done, it is just more work.
Offline  
Old 11-18-2010, 10:28 AM   #5 (permalink)
New Member
 
Join Date: Nov 2010
Model: torch
PIN: N/A
Carrier: orange
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: can't install 5.0 on curve 8520

i have exactly the same problem! we have two blackberry curve 8520 and one has updated to 5 but the other says no update required!!!!
Offline  
Old 11-19-2010, 01:07 PM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
Calebrity's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia
Model: 9900
OS: 7.x.x.x
PIN: N/A
Carrier: Virgin mobile
Posts: 374
Post Thanks: 6
Thanked 35 Times in 31 Posts
Default Re: can't install 5.0 on curve 8520

I have had to downgrade to DTM 5.0 and it installed from there for 1 of my 8520, it will accept the update if your are going from 5.0 to a higher 5.0, but if your going from 4.6 to 5.0 then it will give issues with DTM 6.0 saying about the data plan.
__________________
Current Device Bold 9900
Other Devices: to many to list before Signature restrictions
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.