BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-05-2012, 10:06 AM   #1 (permalink)
New Member
 
Join Date: Feb 2012
Model: 8520
PIN: N/A
Carrier: MTN
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry problems with my EDGE

Please Login to Remove!

I just bought a blackberry phone 8520 (curve 2) and bought a data plan on it for the BIS. I discovered that the "edge" isnt changing from the small to the big "EDGE". I tried inserting my sim into another blackberry phone and it was working perfectly well. Please what can I do?
Offline  
Old 03-05-2012, 11:44 AM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,035
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default Re: problems with my EDGE

Did you try the battery pull that was mention in response to your other post?

Did you enter the IMEI and PIN into your carrier's BIS site so that RIM knows that you are using the new device? Are you sure that your carrier has properly activated this new device with a BB plan?
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 03-05-2012, 09:07 PM   #3 (permalink)
BlackBerry Mensa
 
tsac's Avatar
 
Join Date: Mar 2005
Location: Others run out when we run in
Model: Z10
OS: 10.010219
PIN: No Pin just a Tack
Carrier: at&t
Posts: 8,339
Post Thanks: 43
Thanked 588 Times in 581 Posts
Default Re: problems with my EDGE

Buy it off Ebay?
__________________
If someone helps, tell them by clicking the Thanks button


9810 BES
Z10 on BES
9700 BIS
Offline  
Old 03-06-2012, 05:19 AM   #4 (permalink)
New Member
 
Join Date: Feb 2012
Model: 8520
PIN: N/A
Carrier: MTN
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: problems with my EDGE

yea, my carrier has activated the device with a BB plan and I've also done the battery pull (hard reset) on countless occasions but its still not working. I've tried inserting my sim card into other BB devices around and its working fine. I really dont know what to do again!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: problems with my EDGE
Thread Thread Starter Forum Replies Last Post
help EDGE on 7100t Problems royx117 General Legacy Device Discussion 5 09-29-2008 10:01 AM
8120 T-Mobile Edge problems studerje General 8100 Series Discussion - Pearl 5 06-01-2008 12:53 AM
iEnterprises Launches Mobile Edge Express for Leading CRM Providers Sith_Apprentice BlackBerry World 2012 0 05-13-2008 09:35 PM
No EDGE (only edge) and other problems Bostonimann General BlackBerry Discussion 2 10-29-2006 09:04 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.