BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-25-2009, 10:17 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Location: Athens
Model: Z10
PIN: N/A
Carrier: Vodafone (Greece)
Posts: 87
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Uncaught exception

Please Login to Remove!

when i reboot the 8900, i get an uncaught exception:pishModalScreen called by a non-event thread...what is this ?

if I am not wrong this happened after upgrading to .152. But on the other hand I have been upgraded for more that 2 weeks, with no need to reboot and everything seems to work perfect.


what is this?
Offline  
Old 02-25-2009, 10:20 AM   #2 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

Have you installed any 3rd party applications or themes since your last reboot?
Offline  
Old 02-25-2009, 10:25 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Location: Athens
Model: Z10
PIN: N/A
Carrier: Vodafone (Greece)
Posts: 87
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Yes I have...but everything seems to work just fine. Is it something serious or I can leave it?
Offline  
Old 02-25-2009, 10:35 AM   #4 (permalink)
BlackBerry Extraordinaire
 
raja_3012's Avatar
 
Join Date: May 2008
Location: Irving, TX
Model: iPhn4
OS: iOS 4.3.2
Carrier: AT&T
Posts: 1,137
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you try a battery pull?
__________________
Regards|Raja
BlackBerry FAQ

Nokia 2100 > Nokia 6100 > Samsung t319 > Nokia 5300 > Blackberry 8320 > Blackberry 8900 > iPhone 3GS > iPhone 4
Offline  
Old 02-25-2009, 10:36 AM   #5 (permalink)
BlackBerry Extraordinaire
 
raja_3012's Avatar
 
Join Date: May 2008
Location: Irving, TX
Model: iPhn4
OS: iOS 4.3.2
Carrier: AT&T
Posts: 1,137
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

here is the link.. 1st step to take if device is having problems? - BlackBerryFAQ
__________________
Regards|Raja
BlackBerry FAQ

Nokia 2100 > Nokia 6100 > Samsung t319 > Nokia 5300 > Blackberry 8320 > Blackberry 8900 > iPhone 3GS > iPhone 4
Offline  
Old 02-25-2009, 10:40 AM   #6 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

I was assuming by reboot the OP was referring to a battery pull.

If everything is working fine, then it may just be a nuisance more than an issue. If it does become and issue, then remove the 3rd party application.
Offline  
Old 02-25-2009, 10:44 AM   #7 (permalink)
BlackBerry Extraordinaire
 
raja_3012's Avatar
 
Join Date: May 2008
Location: Irving, TX
Model: iPhn4
OS: iOS 4.3.2
Carrier: AT&T
Posts: 1,137
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I assumed he could mean Soft reboot. But anyways.. you are right this error is surely happening due to a 3rd party.. if "Garias" has less number of 3rd party apps, he can experiment by installing and uninstalling them and check whether or not the error still exists. It is not abnormal though that 3rd party apps may behave erroneously after a week or 2 of usage.
__________________
Regards|Raja
BlackBerry FAQ

Nokia 2100 > Nokia 6100 > Samsung t319 > Nokia 5300 > Blackberry 8320 > Blackberry 8900 > iPhone 3GS > iPhone 4
Offline  
Old 02-25-2009, 11:07 AM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Location: Athens
Model: Z10
PIN: N/A
Carrier: Vodafone (Greece)
Posts: 87
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Thanks... I will see if it affects anything else. Since I don't have any issue I will just ignore it.
Offline  
Old 02-25-2009, 11:21 AM   #9 (permalink)
BlackBerry Extraordinaire
 
raja_3012's Avatar
 
Join Date: May 2008
Location: Irving, TX
Model: iPhn4
OS: iOS 4.3.2
Carrier: AT&T
Posts: 1,137
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try one more thing...

Goto Options > Advanced Options > Applications and check if there any applications which are appearing in bold font.

If yes, uninstall just that application and then reboot. I am guessing you may not get the error again. My best bet is you have a GPS application installed in your berry which is causing this issue.
__________________
Regards|Raja
BlackBerry FAQ

Nokia 2100 > Nokia 6100 > Samsung t319 > Nokia 5300 > Blackberry 8320 > Blackberry 8900 > iPhone 3GS > iPhone 4
Offline  
Old 02-25-2009, 05:57 PM   #10 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I also have that problem and my vlingo app was in bold on the application list. If I remove it does anyone know where I can get vlingo that won't throw any exception during a reboot?
Offline  
Old 02-25-2009, 07:01 PM   #11 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have removed the applications that I had added and it still throws the exception and won't let me make calls. Any ideas or how to do a complete reset to how it originally came?
Offline  
Old 02-25-2009, 07:22 PM   #12 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

Have a backup of your data ready.

Options > Security Options > General Settings > Menu Key > Wipe Handheld.
Offline  
Old 02-26-2009, 03:42 PM   #13 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Location: Athens
Model: Z10
PIN: N/A
Carrier: Vodafone (Greece)
Posts: 87
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

And after the wipe what do you do to restore the device? It needs again the upgrade of the OS?
Offline  
Old 02-26-2009, 03:47 PM   #14 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

The wipe I mentioned will only erase the data on the device. You will not need to load the OS. You would need to restore your data.
Offline  
Old 02-26-2009, 03:50 PM   #15 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Location: Athens
Model: Z10
PIN: N/A
Carrier: Vodafone (Greece)
Posts: 87
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

What about loaded third party programs?
Offline  
Old 02-26-2009, 03:53 PM   #16 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

How do I backup my Third Party Applications on my BB? - BlackBerryFAQ
Offline  
Old 02-27-2009, 01:37 AM   #17 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Location: Athens
Model: Z10
PIN: N/A
Carrier: Vodafone (Greece)
Posts: 87
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I deleted all the 3rd parties software that was in bold in the applications menu. Still there was the error message. I did 3-4 battery pulls. When I was almost ready to do the wipe, the error message dissapeared. I reinstalled the software and everything seems ok. (still the same applications are shown in bold exactly as before (ascendo datavault, IM skype, IM messanger, Klondike, viigo)....strange things....
Offline  
Old 02-27-2009, 09:08 AM   #18 (permalink)
BlackBerry Extraordinaire
 
raja_3012's Avatar
 
Join Date: May 2008
Location: Irving, TX
Model: iPhn4
OS: iOS 4.3.2
Carrier: AT&T
Posts: 1,137
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Garias View Post
I deleted all the 3rd parties software that was in bold in the applications menu. Still there was the error message. I did 3-4 battery pulls. When I was almost ready to do the wipe, the error message dissapeared. I reinstalled the software and everything seems ok. (still the same applications are shown in bold exactly as before (ascendo datavault, IM skype, IM messanger, Klondike, viigo)....strange things....
hmm.. this is really strange.
__________________
Regards|Raja
BlackBerry FAQ

Nokia 2100 > Nokia 6100 > Samsung t319 > Nokia 5300 > Blackberry 8320 > Blackberry 8900 > iPhone 3GS > iPhone 4
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.