BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-01-2009, 10:44 AM   #1 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile USA
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgraded OS, Now Can't Delete Messages

Please Login to Remove!

I upgraded my T-Mobile Curve 8900 to OS 4.6.1.168 last night. Everything is working great, and the issues I was having with Slacker seem to be gone. However, when I go to delete a SMS text message, it won't delete. The BlackBerry lets me select delete from the menu, and when I confirm I want to delete the message, it returns me back to the list of messages, but what I tried to delete is still there. I've tried this with multiple messages and it won't let me delete any SMS text messages. However, when I go into my e-mail, I can delete e-mail messages from any of the three accounts I have linked to the BlackBerry just fine. Other than this one issue, everything else seems to be fine? Any ideas? I've pulled the battery and SIM card twice now with no change.
Offline  
Old 04-01-2009, 10:55 AM   #2 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

Welcome to the forums.

If you highlight a date and press the menu key, then select delete prior, does that delete the messages for you?
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Old 04-01-2009, 11:52 AM   #3 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile USA
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jsconyers View Post
Welcome to the forums.

If you highlight a date and press the menu key, then select delete prior, does that delete the messages for you?
Tried that too, and it won't work.

And thanks for the welcome! Long time lurker here, but finally registered this morning after this problem came up.
Offline  
Old 04-01-2009, 11:57 AM   #4 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

You can delete the entire database. It sounds like it may be corrupt.

Connect your device to you PC, launch DM, go into Backup/Restore and select advanced. On the right side you should see the device databases. Highlight SMS Messages and click the clear button. That will clear your SMS database.

After you've done that, send yourself a test SMS message and see if you can delete it.
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Old 04-01-2009, 12:07 PM   #5 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile USA
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks will try that.
Offline  
Old 04-01-2009, 01:07 PM   #6 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile USA
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, can't clear the SMS database. It's grayed out and won't let me clear it. I can back it up, but that's it.
Offline  
Old 04-01-2009, 01:10 PM   #7 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

Very odd that it's grayed out.
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Old 04-01-2009, 01:19 PM   #8 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

Do you have SMS and email separated?

Try a battery pull and check the database again.
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Old 04-01-2009, 01:23 PM   #9 (permalink)
BlackBerry Extraordinaire
 
TheBigNewt's Avatar
 
Join Date: Oct 2006
Location: Prescott, AZ
Model: 8900
OS: 5.0.0.411
Carrier: Tmobile
Posts: 1,641
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sounds like you ought to wipe and reload if that doesn't work. It shouldn't do that and the module shouldn't be grayed out either.
__________________
BB 8900 Tmobile, Moto Droid Verizon
Offline  
Old 04-01-2009, 02:33 PM   #10 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile USA
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just discovered at lunch that I can't send SMS messages either. I've been receiving them just fine but went to reply to one and found my option to send SMS messages is gone. Guess I'm going to have to wipe and reinstall. UGH!
Offline  
Old 04-01-2009, 05:26 PM   #11 (permalink)
New Member
 
Join Date: Apr 2009
Model: 8900
PIN: N/A
Carrier: T-Mobile USA
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

After a wipe and reactivation, and reloading some of the backed up data (the rest I can do without), I'm back in business. What a pain. I've done a few BlackBerry OS upgrades before but this is the first that I've had get botched up like this. Fortunately now everything appears to be working again.
Offline  
Old 04-01-2009, 06:03 PM   #12 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,071
Post Thanks: 139
Thanked 140 Times in 121 Posts
Default

Glad you got it back up and running!
__________________
The difference between stupidity and genius is that genius has its limits.
When you take things for granted, the things you are granted, get taken.
Even a mosquito doesn't get a pat on the back until it starts to work.
Too many people miss the silver lining because they're expecting gold.
[BES 5.0.3 / GroupWise 2012 HP2]
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.