BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-15-2009, 07:30 PM   #1 (permalink)
CrackBerry Addict
 
slmoney's Avatar
 
Join Date: May 2006
Location: St Louis
Model: 8900
OS: 4.6.1.199
Carrier: TMobile
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Odd: Invisishield and the 8900

Please Login to Remove!

I purchased 2 screen protectors from Zagg (Invisishield) for my 8900. The shields work great with 1 exception (and this is what I am wondering).

When I use my device with the T-Mobile Holster for the 8300, I've noticed a smudge on the top center of my screen. The smudge gets darker with time. I freaked out of course, thinking it was the magnet messing up the screen.

Then one day, my boss (who has an 8320) asked me how his screen could have gotten a black mark on it (he even installed the shield). I put 2 & 2 together....the darn shields do not like magnets. I took my shield off (so did he), and our screens were perfect.

I reported the problem to Zagg (to which they said they would send a replacement)...the Cust Rep told me that the shields have a material in them that may or may not react to magnets...So..why would I put a replacement on just to have it resmudge?

In the meantime...an ad caught my eye for PhantomSkinz...I ordered 2...and wow..no smudges! The screens were easy to install and work great.


Did anyone else ever have that issue with Zagg's product being defective like that?
Offline  
Old 04-15-2009, 08:59 PM   #2 (permalink)
BlackBerry Master
 
dankarlinski's Avatar
 
Join Date: May 2007
Model: 1
Carrier: 1
Posts: 3,391
Post Thanks: 1
Thanked 2 Times in 2 Posts
Default

Wirelessly posted (My Bold)

I have used them on a bold, curve, pearl, and a laptop. No issues
Offline  
Old 04-15-2009, 09:48 PM   #3 (permalink)
CrackBerry Addict
 
BallHawk3's Avatar
 
Join Date: Jul 2006
Location: Los Angeles
Model: 9700
OS: 5.0.0.714
Carrier: T-Mobile
Posts: 828
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Never had this issue either. Had them for years, them and bestskinsever.
Offline  
Old 04-15-2009, 11:32 PM   #4 (permalink)
BlackBerry Extraordinaire
 
david9962000's Avatar
 
Join Date: May 2007
Location: Los Angeles, CA
Model: 9360
OS: 7.1.0.694
Carrier: at&t
Posts: 1,377
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have it on my screen, no issue.
__________________
BlackBerry user since the 7230.
Offline  
Old 04-16-2009, 09:41 AM   #5 (permalink)
CrackBerry Addict
 
slmoney's Avatar
 
Join Date: May 2006
Location: St Louis
Model: 8900
OS: 4.6.1.199
Carrier: TMobile
Posts: 615
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

See..this is what I mean. I've used the Shield on my previous devices without an issue...its just that when I use it in conjunction with the holstered case (that has a magnetic flap) that the screens appear smudged.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.