BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General 8900 Series Discussion - Javelin (http://www.blackberryforums.com/general-8900-series-discussion-javelin/)
-   -   Unable To Access Wifi (http://www.blackberryforums.com/general-8900-series-discussion-javelin/202761-unable-access-wifi.html)

8281311 08-31-2009 11:49 AM

Unable To Access Wifi
 
I am a newbie for blackberries. I recently got a curve 8900. i have an unlimited BIS data plan BUT i am unable to connect to my home wifi router. i have done the following to establish a working connection but havent suceeded yet:

1. changed WPA-Personal TKIP key to WEP key which is supported by 8900. no results!!

2. changed WEP key to NO SECURITY on router's end. no results!!

3. repeatedly deleted WIFI Profiles and get them detected after scanning with different set of encryptions. no results!!

4. changed the option of browser to HOTSPOT BROWSER in the advanced option from internet browser. no results!!

5. battery pull on all the above steps. still no results!!

6. disabling APN from TCP/IP in "Advance Options", then adding IP/DNS, and then again making it to acquire IP/DNS automatically. but no results!!


My phone detects and connects to my offfice router which is without any encrption, but cannot connect to home router! despite all the above. though the home screen shows the SSID and the device says "connected to the router" but the wifi icon remains grey (inactive) and there is a grey dash (-) instead of green tick in connection manager!!!!

following is the configuration at present after wifi diagnostics:

Wi-Fi
Current Profile: ROUTER1
SSID: ROUTER1
AP MAC Address: 00:0F:66:2C:**:**
Security Type: WEP
Local IP Address: 192.168.1.2
Signal Level: -57 dBm
Connection Data Rate: 48 Mbps
Status: Network acquired

VPN
Current Profile:
Concentrator Address:
Contact: N/A
Authentication: N/A
Secure Device IP:
Status: VPN profile is not found.

BlackBerry Infrastructure
Connecting: Trying...
Authenticating router: N/A
Authenticating server: N/A

following is the settings at my router side

default transmit key# 1
WEP Encryption64 bits 10 hex digits
passphrase: *********
key 1: 0**********7
key 2: 2**********8
key 3: 9**********1
key 4: B**********E

MAC Address: 00:0F:66:2C:**:**

my router is a linksys WRT54G & my laptops, iPOD Touch and Nokia N & E series phones work fine with them!!!!!!

i would appreciate if anyone can give a solution plz.

Thankz in advance

MidnightDraven 08-31-2009 12:47 PM

reboot the router.
turn off and turn on.
sounds easy and stupid, but try it.

PredatorUK 09-08-2009 05:54 PM

Seems too obvious but this is exactly what happens when the WEP key is not input correctly or the firewall prevents authentication. Re-boot the router. Enable WEP - get the passkey and write it down. Then make sure you input numbers as its easy on a BB to put in letters. Then check your firewall settings on our router. Is it set to enable connections? firewalls will prevent anything attaching itself to your router if told not to. Good luck. This isnt a problem with your BB, this is a router issue.

wjereb 09-13-2009 08:05 AM

Do you have MAC Address filtering enabled on your router? If so, you'll have to add the MAC address of your BB.

Bill J

wherman 09-15-2009 07:43 PM

The old switch-aroo
 
It seems that you can't browse with just wifi anymore by default. I bought the flip to use with wi-fi many months ago, but would not spend $25 a month for a data service. It took some work, but I got wifi to work on the Flip.(y) It was a simple as configuring the browser to use the hotspot browser.

Then came the 503 error to which the supposed solution is to reload the software.(n) This killed my wifi browsing.(n) I wasted some time and gave up.

Today I decided to waste a couple hours with T-Mobile support.:-( The third call yielded an intelligent support rep :smile:who explained to me that they allowed the wifi access for a while and now require a data plan. Because my phone once worked and no longer worked, she explained why this happened and how to work around it.

She said that the wifi browsing looks for a "service book" before allowing browsing. I lost that "service book" by updating my software.(n) To add the service book, you can add the data services and then cancel them.(y) This should allow you to browse the Internet with wifi. It hasn't activated yet, so I can't verify this.

Of course there must be some way to put a "service book" on a blackberry, at least an unlocked one, with the right know how. For me ordering and cancelling is a good enough solution.

unknownballa 09-17-2009 02:01 PM

Hey!

I had the same problem with my curve.. Once connected to wifi

Open your browser.... it will say it is unable to connect.... after that go into options....

browser configuration... and select HOT SPOT BROWSER... its defaulted to rogers for me.. but once i selected that it was all good :D


All times are GMT -5. The time now is 03:04 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.