BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-13-2010, 08:15 PM   #1 (permalink)
New Member
 
Join Date: Sep 2010
Model: 8900
PIN: N/A
Carrier: Tata Docomo
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8900: All Keys + Trackball wont work.

Please Login to Remove!

Hello,

I have the 8900 and my carrier is Tata Docomo. None of the keys and the trackball are working, This includes the mute key on top of the phone, the lock key, the side push button keys , . . all keys are not working. And neither is the trackball.



I flashed the OS, as in reinstalled the OS, 5.0.090 (Platform 4.0.023) but that didnt solve the problem.



I've also plugged out the media card, to avoid any conflicts.



Have done hard resets of course, but thats not helped either.





Except for the keys not functioning, the phone is otherwise functioning, I can recieve calls, which I of course cant pick up. I am being able to use it as a modem and connect to the internet using Desktop Manager. The Desktp manager is detecting the phone, too.



The Desktop manager version I am using is 5.0.1.11.

Out of the 252.5 M device space available, I have 131.0 M free.

I have not let any moisture into my phone.



Please help!
Offline  
Old 09-13-2010, 08:23 PM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,030
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Did it get wet or did you drop it? Sure sounds like moisture damage to me.

By hard reset, do you mean a battery pull?

How did you flash the OS?
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 09-13-2010, 08:36 PM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Dec 2006
Model: I747
OS: 4.1.1
Carrier: at&t
Posts: 2,340
Post Thanks: 43
Thanked 117 Times in 107 Posts
Default

Are you the original owner of the device? I agree with dubdub, sounds like moisture damage.
Posted via BlackBerryForums.com Mobile
Offline  
Old 09-14-2010, 08:31 AM   #4 (permalink)
New Member
 
Join Date: Sep 2010
Model: 8900
PIN: N/A
Carrier: Tata Docomo
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you guys for the reply.

I have not got the phone wet, or exposed it to any places with a high moisture content like hot steamy baths or such. This problem suddenly occur ed, The keys stopped working when I was in a call and I did a bat pull, and they have not been working since.

Yep, I meant a bat pull by hard reset.
I flashed the OS by downloading 5.0.0.90 of easy-share, and deleting the Vender.xml in commonfiles/rim, and then using Desktop manager to load the OS.

Can I please ask why you asked if I was the original owner? The phone was given to me by my previous employer and I bought it off them when I quit.

So do you guys think this more of a hardware fault than software? Should I get it checked by a service rep? It's not under warranty and . . .
Offline  
Old 09-14-2010, 08:39 AM   #5 (permalink)
BlackBerry Extraordinaire
 
Join Date: Dec 2006
Model: I747
OS: 4.1.1
Carrier: at&t
Posts: 2,340
Post Thanks: 43
Thanked 117 Times in 107 Posts
Default

I asked if you were the original owner because it may have gotten the moisture damage prior to you taking ownership and is just now showing the signs.

If you have already reloaded the OS, the only thing I can think of is to have it looked at by a service tech or purchase a new device.
__________________
The Search tool and BlackBerryFAQ answer many questions.
Offline  
Old 09-16-2010, 05:15 AM   #6 (permalink)
New Member
 
Join Date: Sep 2010
Model: 8900
PIN: N/A
Carrier: Viettel Telecom
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Devnull's opinion is correct. I have a Javelin 8900 of AT&T that has same symptom. I ask the seller to do the warranty, but after 1 month, he said that he can not repair that problem, and he gave me another mainboard of O2 UK. Now i have a 8900 with outside logo is AT&T, but inside logo is O2 UK
Offline  
Old 09-20-2010, 07:34 PM   #7 (permalink)
New Member
 
Join Date: Nov 2008
Model: 8120
PIN: N/A
Carrier: o2
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Talking Problem solved

you need a new keypad to be replaced this the hole frame that holds the blackberry togther got my repaired in a unofficial blackberry repair centre.

uk-Repair.com try them
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.