BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-27-2010, 11:37 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2009
Model: 9550
PIN: N/A
Carrier: Digicel
Posts: 43
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default 8900 Invalid Sim Card - NOT WORKING :x

Please Login to Remove!

Hello guys. hope you can help me out with this.

I have this 8900 running 5.0.0.1168. The phone ran out of its battery and shut down. When plugged in and turned on it is suddenly asking for MEP CODE since the it has an "Invalid Sim Card". This is the same sim card of the carrier, never changed it. I tried taking my sim card to another phone and it worked fine, but none of the sim cards I put on the 8900 works at all.

I got an unlock code from a secure source (have unlocked 20+ phone from this site), after typed the code, pressed enter and the phone restarts. When the phone is up the error is still there. Doesn't matters how many times you put the MEP Code it still says 10 attempts left.


Have you ever saw this? Do you have any idea on how to start troubleshooting this?

Thank you!
Offline  
Old 09-27-2010, 01:30 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2009
Model: 9550
PIN: N/A
Carrier: Digicel
Posts: 43
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

I tried to reload the software using (c:-common files-rim-etc). It finishes and the problem continues.

Should I wipe the device using BBSAK?
Offline  
Old 09-29-2010, 06:09 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2009
Model: 9550
PIN: N/A
Carrier: Digicel
Posts: 43
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Wiped and installed OS using BBSAK and the same problem.
PLEASE HELP!!!
Offline  
Old 10-05-2010, 08:39 PM   #4 (permalink)
New Member
 
Join Date: Jan 2010
Model: 8900
OS: 4.6.1.230
PIN: N/A
Carrier: T-Mobile USA
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had a similar problem last week with my 8900. I installed OS 5 and then, when phone ran out battery, when Icharged back, got a message Invalid SIM card. Installed OS 4.6.1.231 back and the problem remained. Had to replace the SIM card. And now the OS 5 is not available anymore from the Desktop Manager 6.0.0.43. It shows OS 4.6.1.231 as the latest.
Offline  
Old 10-06-2010, 09:42 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2009
Model: 9550
PIN: N/A
Carrier: Digicel
Posts: 43
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Try downloading the 5.0 from this site. DM shows the last software that is available for your carrier.

Did you solve this? if yes, how?
Offline  
Old 10-06-2010, 03:44 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2009
Model: 9550
PIN: N/A
Carrier: Digicel
Posts: 43
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Really? Nobody knows how to fix it? Is the phone dead?

If you can't post the fix. PM me!
Offline  
Old 10-08-2010, 02:36 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2009
Model: 9550
PIN: N/A
Carrier: Digicel
Posts: 43
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hello guys. Phone can't be fix. I used the "M" software, everything was fine, the phone got its OS running well, but the issue is still there.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.