BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-26-2008, 10:11 AM   #1 (permalink)
CrackBerry Addict
 
Join Date: Oct 2004
Model: 9800
OS: 6.0.0.337
Carrier: (`.at&t.)
Posts: 825
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unlocked bold with tmo sim intl roaming

Please Login to Remove!

Does anyone have this working? an unlocked bold with a US Tmobile sim and international roaming working?
Tmobile has a security lock on the sim for intl roaming cause they say they don't support the bold? I don't see what that has to do with it.
Just trying to see if anyone else has this working.

oh and the same sim in the curve was roaming fine. then switched to bold and roaming is locked. not sure if user gave them imei of bold and maybe giving them imei of curve will take off roaming lock.
Offline  
Old 09-26-2008, 08:03 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2006
Location: L.A. and NY
Model: 9900
OS: 7.0.0.540
Carrier: T-Mobile
Posts: 184
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I bought and used my Bold in Munich, with my T-Mobile USA SIM. Worked and roamed fine.
__________________
Thanks,

Jeff
www.jeffharris.com
Offline  
Old 09-26-2008, 08:31 PM   #3 (permalink)
New Member
 
gorilla66's Avatar
 
Join Date: Aug 2008
Model: 9000
PIN: N/A
Carrier: movistar
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am roaming in south america with a US Tmobile sim now, the phone works fine, as well as the email, I don't have a browser because tmob doesn't carry the model so they don't have the service books, same problem in the US, only can browse through wifi


Quote:
Originally Posted by Inphektion View Post
Does anyone have this working? an unlocked bold with a US Tmobile sim and international roaming working?
Tmobile has a security lock on the sim for intl roaming cause they say they don't support the bold? I don't see what that has to do with it.
Just trying to see if anyone else has this working.

oh and the same sim in the curve was roaming fine. then switched to bold and roaming is locked. not sure if user gave them imei of bold and maybe giving them imei of curve will take off roaming lock.
Offline  
Old 09-26-2008, 10:28 PM   #4 (permalink)
CrackBerry Addict
 
Join Date: Oct 2004
Model: 9800
OS: 6.0.0.337
Carrier: (`.at&t.)
Posts: 825
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks guys. I've narrowed it down to a sim card issue. I got a new tmo sim and shipping it to india now. Will know in a few days if that solved problem.

Just wanted to make sure I wasn't crazy and there was something with tmo not working I wasn't aware of as I really just deal with att.
Offline  
Old 09-27-2008, 05:56 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2006
Model: 9000
Carrier: TMobile US
Posts: 37
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sounds solved, but can confirm it works fine. Rogers device, T-Mo USA, working on UK providers (Voda, Orange, Tmo)
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.