BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-06-2008, 07:25 AM   #1 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2006
Location: Baton Rouge, La
Model: 9810
Carrier: AT&T
Posts: 261
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default XP x64 and Bold do not work together

Please Login to Remove!

Anyone know how to fix it? Windows XP x64 works with the 8100, 8120, 8130, 8800, 8310 and 8830. But when I plug in the Bold, Windows fails to find a USB driver allowing it to work. I downloaded AT&Ts firmware 4.6.0.167 as well as the unreleased 4.6.0.168 with nothing. But they work on XP/Vista x32 O/S's.

Any Ideas?
Offline  
Old 11-06-2008, 09:05 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2008
Location: Frisco, TX
Model: 8130
PIN: N/A
Carrier: Alltel
Posts: 107
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you try installing Desktop manager? It works on my XP x64 and Vista x64 machines just fine.
__________________
me: AT&T Bold 9000 with all the goodies.
g/f: T-Mobile Curve 8900
Offline  
Old 11-06-2008, 12:57 PM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2006
Location: Baton Rouge, La
Model: 9810
Carrier: AT&T
Posts: 261
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

For some reason the Device Id on my x64 OS shows the Bold as \VID_0FCA&PID_8004\
x32 OS's show it as \VID_0FCA&PID_8004&MI_00\

The .Inf file only shows \VID_0FCA&PID_8004&MI_00\

I am on the phone with RIM and told them when I remove the &MI_00 from the .Inf "Blackberry Smartphone" is recognized. They are perplexed just as much as I am. It solves the problem of not recognizing the Bold, but ultimately prevents switching back and forth between 9xxx and 8xxx devices. I switch back and forth as we use my computer for Blackberry Firmware Upgrades.

I will post a solution when we find one.
Offline  
Old 11-06-2008, 01:13 PM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
masonfoley's Avatar
 
Join Date: Oct 2004
Location: Atlanta, GA
Model: 9000
Carrier: AT&T
Posts: 221
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What language of the OS are you using (i.e. English-US vs. English-UK)? Or maybe a double-byte character set (DBCS) - Asian?

Maybe it's a localization issue?

EDIT: Also, are you using Mass Storage mode on the device? Perhaps try it with it ON or OFF?
__________________
Cheers,
Mason

"If tyranny and oppression come to this land, it will be in the guise of fighting a foreign enemy. No Nation could preserve it's freedom in the midst of continual warfare." -- James Madison.

Last edited by masonfoley : 11-06-2008 at 01:15 PM.
Offline  
Old 11-06-2008, 01:35 PM   #5 (permalink)
CrackBerry Addict
 
BBSwany's Avatar
 
Join Date: May 2008
Location: Colorado
Model: Z10
OS: 10
Carrier: Straight Talk
Posts: 684
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bimmerd00d View Post
Did you try installing Desktop manager? It works on my XP x64 and Vista x64 machines just fine.
Same here. Try downloading and installing Desktop Manager 4.6. My Bold works just fine on my Vista x64 machine.
__________________
HOW-TO's | TIPS & TRICKS | WALLPAPERS: BBGrounds
Bold OR Storm on T-Mo? WANT YOUR BROWSER & MMS? CLICK ME!

[SIGPIC][/SIGPIC]
Offline  
Old 11-06-2008, 01:55 PM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
masonfoley's Avatar
 
Join Date: Oct 2004
Location: Atlanta, GA
Model: 9000
Carrier: AT&T
Posts: 221
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bbswany View Post
Same here. Try downloading and installing Desktop Manager 4.6. My Bold works just fine on my Vista x64 machine.
Just to be clear, he's having problems with XP x64. Not Vista.
__________________
Cheers,
Mason

"If tyranny and oppression come to this land, it will be in the guise of fighting a foreign enemy. No Nation could preserve it's freedom in the midst of continual warfare." -- James Madison.
Offline  
Old 11-06-2008, 02:00 PM   #7 (permalink)
CrackBerry Addict
 
BBSwany's Avatar
 
Join Date: May 2008
Location: Colorado
Model: Z10
OS: 10
Carrier: Straight Talk
Posts: 684
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by masonfoley View Post
Just to be clear, he's having problems with XP x64. Not Vista.
I understand that perfectly, however the member I quoted has both Vista x64 and XP x64 and works on both. My recommendation was to download Desktop Manager 4.6 to match the OS version on the Bold. I just made a reference that I have a 64 bit OS as well should he have any further questions.
__________________
HOW-TO's | TIPS & TRICKS | WALLPAPERS: BBGrounds
Bold OR Storm on T-Mo? WANT YOUR BROWSER & MMS? CLICK ME!

[SIGPIC][/SIGPIC]

Last edited by BBSwany : 11-06-2008 at 02:03 PM.
Offline  
Old 11-06-2008, 02:07 PM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
masonfoley's Avatar
 
Join Date: Oct 2004
Location: Atlanta, GA
Model: 9000
Carrier: AT&T
Posts: 221
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Understood but my perhaps not-so-ticky-tack issue is bringing up Vista at all in this conversation.

Seeing it mentioned for a second time, I was concerned it would be confusing the issue and wanted others seeing the thread for the first time to not lose site of his issue's context.
__________________
Cheers,
Mason

"If tyranny and oppression come to this land, it will be in the guise of fighting a foreign enemy. No Nation could preserve it's freedom in the midst of continual warfare." -- James Madison.
Offline  
Old 11-06-2008, 07:21 PM   #9 (permalink)
CrackBerry Addict
 
BBSwany's Avatar
 
Join Date: May 2008
Location: Colorado
Model: Z10
OS: 10
Carrier: Straight Talk
Posts: 684
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by masonfoley View Post
Understood but my perhaps not-so-ticky-tack issue is bringing up Vista at all in this conversation.

Seeing it mentioned for a second time, I was concerned it would be confusing the issue and wanted others seeing the thread for the first time to not lose site of his issue's context.
True, true.. My mistake. Back to the task at hand! XP 64 bit only..
__________________
HOW-TO's | TIPS & TRICKS | WALLPAPERS: BBGrounds
Bold OR Storm on T-Mo? WANT YOUR BROWSER & MMS? CLICK ME!

[SIGPIC][/SIGPIC]
Offline  
Old 11-06-2008, 07:44 PM   #10 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2006
Location: Baton Rouge, La
Model: 9810
Carrier: AT&T
Posts: 261
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for all the replies.

I am currently running 4.6.0.13 Desktop Manager. RIM T-Support had me remove it, download the 4.6 USB Drivers as well as 4.6 Device Manager. Then install 4.6 USB -> 4.6 Device Manager -> 4.6.0.13 Desktop Manager. Still nothing. The only thing I found was the Device Id XP x64 detects is not listed in the RimUSBNT.INF file which prevents the USB driver from loading in the 4.6 Device Manager. Only the USB Serial Device Driver.

RIM recreated the issue and stated a solution will be made available Monday. In the meantime, I edited the oem26.INF file in the Windows\Inf folder which is the RimUSBNT.INF after install. Removed the &MI_00 from the list so the Device Id for the Bold is detected and all is well as long as no one connects an 8xxx device seeking a firmware upgrade.

Last edited by vhato : 11-06-2008 at 07:46 PM.
Offline  
Old 11-06-2008, 08:59 PM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
masonfoley's Avatar
 
Join Date: Oct 2004
Location: Atlanta, GA
Model: 9000
Carrier: AT&T
Posts: 221
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vhato View Post
RIM recreated the issue and stated a solution will be made available Monday. In the meantime, I edited the oem26.INF file in the Windows\Inf folder which is the RimUSBNT.INF after install. Removed the &MI_00 from the list so the Device Id for the Bold is detected and all is well as long as no one connects an 8xxx device seeking a firmware upgrade.
That is more than half the battle right there and that is getting the vendor to reproduce the issue. I'm sure it's a relief to know that it wasn't a one off issue for just you. You actually did RIM a favor. Good of you to keep on it and move it towards a resolution.
__________________
Cheers,
Mason

"If tyranny and oppression come to this land, it will be in the guise of fighting a foreign enemy. No Nation could preserve it's freedom in the midst of continual warfare." -- James Madison.
Offline  
Old 11-06-2008, 09:54 PM   #12 (permalink)
Thumbs Must Hurt
 
Join Date: Jul 2008
Location: Frisco, TX
Model: 8130
PIN: N/A
Carrier: Alltel
Posts: 107
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have noticed that I can't sync via bluetooth. It pairs, connects, but as soon as it tries to sync it hangs up and Desktop Manager crashes. I believe it's something to do with my TrendNet bluetooth dongle more than BB DM or the phone. It did the same with the Pearl I have as well.
__________________
me: AT&T Bold 9000 with all the goodies.
g/f: T-Mobile Curve 8900
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.