BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-10-2009, 02:30 PM   #1 (permalink)
CrackBerry Addict
 
lraed74's Avatar
 
Join Date: Aug 2005
Location: Columbus, OH
Model: S2
OS: 5.0
Carrier: Verizon
Posts: 720
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Bold wont start after changing trackball

Please Login to Remove!

A friend of mine was changing his trackball to the black one. I watched him take it all apart, change the trackball and then put it all back together with no issues, it was all quick and clean. Now with putting the battery in, nothing, notta, zilch happens. The red LED doesnt flash or anything, its like he isnt even putting the battery in. Anyone else have this and something he missed with putting things back together? I checked the LED connector and that was fine but the device just wasnt turning on, no backlight, LED or anything.

So, any help would be appreciated.

Thanks
Offline  
Old 02-10-2009, 04:02 PM   #2 (permalink)
New Member
 
Join Date: Jan 2009
Model: Tour
PIN: N/A
Carrier: Sprint
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

He might of got some static and fried the bold. Did he use a ground strap when handling the bold's electronics? Was he standing on carpet?
Offline  
Old 02-10-2009, 04:12 PM   #3 (permalink)
CrackBerry Addict
 
lraed74's Avatar
 
Join Date: Aug 2005
Location: Columbus, OH
Model: S2
OS: 5.0
Carrier: Verizon
Posts: 720
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wasnt using a ground strap but was on a plastic chair mat at a desk.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.