BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General 9000 Series Discussion - Bold (http://www.blackberryforums.com/general-9000-series-discussion-bold/)
-   -   TCP/IP settings - PLEASE HELP (http://www.blackberryforums.com/general-9000-series-discussion-bold/192462-tcp-ip-settings-please-help.html)

etjandra 06-04-2009 09:57 AM

TCP/IP settings - PLEASE HELP
 
I am currently using generic data plan on my BB. I have followed all the instruction and had done so many research on it, but it seems that I am missing something. I am having difficulties with Opera Mini, which I use as internet browser, sometimes it does not want to connect to the internet and message: TUNNEL FAILED / BAD DNS ADDRESS shows up, and in order to get it connect , I have to either turn off my mobile connection and then turn it back up or restarting opera. I have done so many settings combination and nothing helps. I was wondering if there is any other additional setting I need to perform in order to get this correctly. By the way, I have tried removing opera mini and then re-install it, battery pull, etc2 but nothing changed. And other application, such as gmail, facebook, beejive are working fine. No problem whatsoever.

Please help guys! I am frustrated with this!

JSanders 06-04-2009 10:01 AM

Nothing more really...OM is just goofy that way and always has been, for some users.

What HAS worked in the past is, to set your APN/TCP settings correctly for your carrier, and save. OM is installed. Do a powered on battery pull reboot... and then...

Just wait. It could be a day or three, and it might start working. The fact that it can be a delayed fix has been mentioned here in the forums numerous times.

Good luck.

ree_mn 06-05-2009 01:47 PM

etjandra,
My experience with OperaMini is that, there are two types of failures with socket protocol enabled.

1) Socket protocol fails a half day or so after a reboot. A reboot fixes the problem. No restarting of the Data Services or the Mobile Network seems to help fix it, only a reboot. This would seem to be a problem on the blackberry itself.

2) Socket protocol fails and even reboots don't get it working again. This happens more often than I'd like and I'm guessing that it's either the opera proxy servers being down or unreachable through your provider. Usually, within hours to days, with no intervention on your part, it all starts working again.

In both cases, if you want to avoid a reboot or waiting switch the protocol in OM to HTTP so it connects through BIS the way most other apps on the blackberry do. This of course makes for slower browsing, but it's all that works sometimes.

etjandra 06-07-2009 10:34 AM

Thanks guys for the infos! but, does the protocol automatically change? thats what happen to mine.

ree_mn 06-08-2009 02:00 PM

If it's set to socket and you get an IO error and then you select run connection test, it will switch it to HTTP for you and you'll have to switch it back to socket manually.


All times are GMT -5. The time now is 02:06 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.