BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 06-08-2009, 02:33 AM   #1 (permalink)
Just me
fonejunkie's Avatar
Join Date: Jul 2006
Model: iFone
OS: iOS4
PIN: Not on my iPhone5
Carrier: iPhone5 on AT&T Mobility
Posts: 2,292
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Slashed Battery Icon

Please Login to Remove!

I got my new Bold about 2 weeks ago, and in preparation for a family vacation, I purchased a spare battery (OEM 1500 mah BlackBerry battery) and a BlackBerry branded "mini charger" from I received the battery and charger on Saturday and plugged the charger in and inserted the new battery in the charger. I let it charge overnight, and early this afternoon I attempted to try the new battery in my Bold.

When I inserted the battery, the led glowed red for about 10 seconds and then went out, but the phone itself never powered up. After pulling the battery and repeating the reset process a couple of times, I plugged my Bold containing the new battery into the wall charger. The led glowed red again for about 10 seconds and then the screen lit up... but instead of powering up, I got an icon of a battery with a red slash across it.

What does this icon mean? Is it telling me that the battery is not charged? Is it telling me that the battery is not taking a charge/is bad? There is nothing in the manuals about the battery icon (at least not that I can find)... and I am mildly upset... I am leaving on vacation on Wednesday morning - not sufficient time to get a replacement battery/charger...

With the original battery in the phone, my Bold powers up and runs almost all day... so I guess I will just have to make do for now.

But I am anxious to identify the problem with the battery... as long as the problem IS the battery, I can deal with it... if it's the phone I am really going to be upset... grrrr...
Old 06-08-2009, 04:05 AM   #2 (permalink)
BlackBerry Master
dankarlinski's Avatar
Join Date: May 2007
Model: 1
Carrier: 1
Posts: 3,391
Post Thanks: 1
Thanked 2 Times in 2 Posts

Wirelessly posted (My Bold)

This icon means that the phone is not picking up the battery. Try to start it with just the battery. If it doesn't work, it looks like that battery is bad
Old 06-08-2009, 07:49 AM   #3 (permalink)
BBF Moderator
akosnitzky's Avatar
Join Date: Jul 2005
Location: Southern Florida
Model: 9650
Carrier: Verizon BIS
Posts: 14,484
Post Thanks: 6
Thanked 7 Times in 7 Posts

Wirelessly posted (Its All About the U!)

I had that icon when I tried to put a Pearl battery in a curve.
Follow @akosnitzky on Twitter

Old 06-08-2009, 09:11 AM   #4 (permalink)
Stuck In The '70's Mod
ndub33's Avatar
Join Date: Feb 2006
Location: The 'burbs east of Seattle.
Model: 9810
Carrier: T-Mobile
Posts: 7,599
Post Thanks: 0
Thanked 4 Times in 4 Posts

Alos, try cleaning the contacts on both the device and the battery.
1st Step in Troubleshooting: Do you have a BlackBerry Data Plan?
2nd Step in Troubleshooting: Pull the Battery.
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.