BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-24-2009, 12:04 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2005
Location: Singapore
Model: 9700
OS: 5.0.0.423
Carrier: SingTel
Posts: 94
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default WiFi icon greyed out with no data service?

Please Login to Remove!

Hi guys, I've noticed something strange, wondering if you know what's happening. For some reason, I'm using my Bold without a data service for a few days, and noticed that the WiFi icon is greyed out (used to be solid when I had a data service SIM card). This happens for my home and office WiFi. And even after using the hotspot browser to "log in", the icon stays greyed.

Just today, when I switched to a data SIM card borrowed from my IT guys, the WiFi icon became solid again. Is there a reason why?

Also, is it a requirement to do the hotspot log in before the WiFi connection is used? Supposing I have 3G and WiFi coverage and am connected to WiFi (like at home or in office), does the Blackberry automatically choose the faster network, or would I have to do the hotspot log in manually to trigger the WiFi connection?
Offline  
Old 07-24-2009, 02:10 AM   #2 (permalink)
BlackBerry Extraordinaire
 
miamirulz29's Avatar
 
Join Date: Apr 2009
Location: The 305!
Model: 9000
OS: 5.0.0.592
PIN: N/A
Carrier: AT&T
Posts: 1,219
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The blackberry would choose the faster connection however I don't know why the wifi icon would be greyed out only if your data was off.
Offline  
Old 07-24-2009, 02:17 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2005
Location: Singapore
Model: 9700
OS: 5.0.0.423
Carrier: SingTel
Posts: 94
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks! Yes it's very puzzling. When the icon's greyed out, I could still do the hotspot log in, and surf using the hotspot browser, but the icon would stay greyed out all the time. Only with the data-enabled SIM would be icon be solid.

If I check under "Manage Connections", it would show that the WiFi network is connected, but on the RHS where you'd expect to see a green tick (for connected), I see a dash. Strange, but hotspot browser still works then.
Offline  
Old 07-24-2009, 09:21 AM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
JW021979's Avatar
 
Join Date: Apr 2008
Location: UK
Model: 9700
OS: 5.0.0.421
Carrier: O2 UK
Posts: 207
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The WIFI icon goes white to show you have a Blackberry connection. You wont get a white icon unless you have a Blackberry enabled SIM in the phone.
__________________
Scientia est potentia
Offline  
Old 07-24-2009, 10:43 AM   #5 (permalink)
New Member
 
Join Date: Feb 2007
Location: San Diego, CA
Model: 8900
OS: 4.6.1.250
Carrier: T-Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

My Coworker is having this exact problem with her Bold. Any help would be appriciated.
Offline  
Old 07-24-2009, 10:50 AM   #6 (permalink)
Knows Where the Search Button Is
 
wim.decuypere's Avatar
 
Join Date: Jul 2009
Location: Roeselare (Belgium)
Model: 9000
OS: 4.6.0.282
PIN: N/A
Carrier: Proximus
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JW021979 View Post
The WIFI icon goes white to show you have a Blackberry connection. You wont get a white icon unless you have a Blackberry enabled SIM in the phone.
The solution to my problem to.
Offline  
Old 07-30-2009, 09:08 AM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Sep 2006
Location: Paris & Beirut
Model: 9981
OS: 7.1.0.523
Carrier: Orange FR & Etisalat AE
Posts: 334
Post Thanks: 6
Thanked 24 Times in 12 Posts
Default

Quote:
Originally Posted by wim.decuypere View Post
The solution to my problem to.
...and same here.

I have noticed that when the icon is greyed, you can still browse the web in wi-fi, but can't sue some other applications that require data. -- I may be wrong, but that's my impression.
Offline  
Old 07-30-2009, 10:58 AM   #8 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2006
Model: LEZ10
OS: 10.0.10
Carrier: Rogers CA
Posts: 1,704
Post Thanks: 20
Thanked 77 Times in 68 Posts
Default

There are four states for the Wi-Fi icon:
1. Icon not visible: Wi-Fi radio is off.

2. Icon is gray, no access point name is displayed: Wi-Fi radio is on but not connected.

3. Icon is gray, access point name displayed: Wi-Fi is connected to the named hotspot, but is not (yet) connected to RIM via the Wi-Fi. There are a number of reasons for this, but not having a Blackberry data plan with appropriate SIM is a big one. In this state the Hotspot Browser (and some other applications) can use Wi-Fi to connect to what ever the hotspot allows, hopefully the Internet but maybe an internal corporate network.

4. Icon is white, access point name displayed: Wi-Fi is connected to the named hotspot and a connection has been made to RIM. In this state all BIS/BES traffic will use Wi-Fi/Internet for the leg between RIM and the Blackberry instead of the wireless provider's towers. There is also a special case for this state. If the Blackberry is activated on a BES, and it is able to connect to the BES through the hotspot, the Icon will also be white.

Clues as to why a Blackberry is in a particular state can be gotten from the Wi-Fi Diagnostics. Select Manage Connections -> Wi-Fi Options, Menu -> Wi-Fi Tools -> Wi-Fi Diagnostics. There is also Site Survey, Ping and DNS Lookup available for your investigative pleasure.

Enjoy.
__________________
My other Blackberry is a PlayBook.

Last edited by hrbuckley : 07-30-2009 at 10:59 AM. Reason: Clarity
Offline  
Old 07-30-2009, 11:06 AM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Sep 2006
Location: Paris & Beirut
Model: 9981
OS: 7.1.0.523
Carrier: Orange FR & Etisalat AE
Posts: 334
Post Thanks: 6
Thanked 24 Times in 12 Posts
Default

Thanks. for once I read a clear description of the differences of that various conditions. My frustration is lately the inability to move from situation 3 to 4, as per your description.

It used to usually always be in state 4, but since a couple of days, my icon is only sticking to grey.

Anything you think I could do to resolve? -- Incidentally, I am on BIS.

Thanks
Offline  
Old 07-30-2009, 05:59 PM   #10 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2006
Model: LEZ10
OS: 10.0.10
Carrier: Rogers CA
Posts: 1,704
Post Thanks: 20
Thanked 77 Times in 68 Posts
Default

Question 1: Is it just one hotspot, or several/all?

This is where those diagnostic tools come in handy.

The first one to try is Wi-Fi Diagnostics. If you don't understand what is there, use the option to email the results. If you email them to yourself then copy and past them here we can have a look at them. Or you can PM them to me if you don't want the data made that public.
__________________
My other Blackberry is a PlayBook.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.