BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-29-2009, 03:24 PM   #1 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default HELP: Bold XBM (Warranty) through AT&T

Please Login to Remove!

So Ive received my 3rd Bold today under the warranty exchange. Ive had countless issues with the others. With the reception going to "SOS" as a primary issue. I had the latest OS that let you switch to 2G, but now im no where near a 3G area anyways so it doesnt matter.

Anyways, Im getting really fed up with this thing. I paid $541 for it and Im having ridiculous issues. Id LOVE it if it just worked properly! AT&T said they cant send me a new oe cause they only have refurbs. And I know if I ask for something else, theyll just offer me like a Fuze or possibly a Javelin. I dont want the Fuze at all and the Javelin is nice, but its a step down from the Bold. Im not taking a hit to the wallet because BB made a crappy phone.

Is there anything I can do? Any way they could send me a new one or something GOOD? I guess they probably wouldnt send an unlocked Tour would they? lol How about a Bold 2? I heard rumors about it, whens it coming out?
Offline  
Old 07-29-2009, 03:33 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2009
Model: 9000
PIN: N/A
Carrier: at&t
Posts: 48
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Fat Ryan View Post
So Ive received my 3rd Bold today under the warranty exchange. Ive had countless issues with the others. With the reception going to "SOS" as a primary issue. I had the latest OS that let you switch to 2G, but now im no where near a 3G area anyways so it doesnt matter.

Anyways, Im getting really fed up with this thing. I paid $541 for it and Im having ridiculous issues. Id LOVE it if it just worked properly! AT&T said they cant send me a new oe cause they only have refurbs. And I know if I ask for something else, theyll just offer me like a Fuze or possibly a Javelin. I dont want the Fuze at all and the Javelin is nice, but its a step down from the Bold. Im not taking a hit to the wallet because BB made a crappy phone.

Is there anything I can do? Any way they could send me a new one or something GOOD? I guess they probably wouldnt send an unlocked Tour would they? lol How about a Bold 2? I heard rumors about it, whens it coming out?
Sounds like you will have to either accept a refurb replacement.. Or you can Wipe your device with JL_Cmdr and start fresh with a new OS.. OS .282 from vodafone or rogers.. or even .266 from vodafone.. at&t should be launching .285 soon. I would call at&t and talk to somone in tech support make sure there are no network issues in the areas that your around. This can often be a cause of what your seeing happen
__________________
Follow me on Twitter
Offline  
Old 07-29-2009, 03:37 PM   #3 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,798
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

Are you in a marginal reception area? Phone itself may not matter. Dropping to SOS indicates no carrier coverage at all. Not sure that it is the phone since you've had 3 of them...

And I would doubt they'd send you a Tour as that is a CDMA device. And not on AT&T.
Offline  
Old 07-29-2009, 03:43 PM   #4 (permalink)
BlackBerry Extraordinaire
 
miamirulz29's Avatar
 
Join Date: Apr 2009
Location: The 305!
Model: 9000
OS: 5.0.0.592
PIN: N/A
Carrier: AT&T
Posts: 1,219
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You will probably have to go with a refurbished bold, they won't give you a new bold.
Offline  
Old 07-29-2009, 04:07 PM   #5 (permalink)
Just me
 
fonejunkie's Avatar
 
Join Date: Jul 2006
Model: iFone
OS: iOS4
PIN: Not on my iPhone5
Carrier: iPhone5 on AT&T Mobility
Posts: 2,292
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

AT&T's policy is to replace your new phone with a new phone in the first 30 days. Beyond 30 days, you will most likely get a refurb. There is an outside chance you will get a new one, but if they have refurbs in stock, that is what you will get for a warranty replacement months 2-12.
Offline  
Old 07-29-2009, 07:04 PM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Sep 2008
Model: 9700
PIN: N/A
Carrier: att
Posts: 373
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (bold 9000)

Have them check your sim card. I had a faulty card and when I switched towers while driving I would drop call then be without service for a min or two.
Offline  
Old 07-29-2009, 08:05 PM   #7 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

the area i was in before was philly suburbs. about 20 min north of me was the 3G border, so i was in a 3G area. i always had dropped calls there, it was terrible, pretty much every single call got dropped or failed. once i got the 3G turned off, the dropped calls stopped for the most part. but if the phone loses signal, it doesnt get it back when you are back in an area with reception, it just stays at SOS. and it seems to drop to SOS very easily or for o aparent reason.

now im here at virginia tech for grad school, no 3G here. ive been here for about a month and i have the same issues. i also recently started getting popups saying my certificates are invalid. these popups are VERY annoying cause they happen every 1-2 seconds.

i havent yet replaced my SIM card yet, but chances are its not that. ive read up a lot about the Bold...its garbage, thats pretty much everyones opinion. it has a LOT of potential, but BB *messed* up big time with some things. ive heard about so many Bold issues its not even funny. i worked for AT&T as a salesman for the last year and everyone who came up with a Bold had the same issues i did. also, ive tried stickin my SIM in spare 2610's i have and i get full reception with them while my Bold only has like 2-3 bars.

i do think, though, that ill take a trip down to the local AT&T store and get a free SIM just to make sure...

Last edited by JSanders : 07-29-2009 at 11:08 PM. Reason: You're in college? Chill on the junior high expletives
Offline  
Old 07-29-2009, 08:31 PM   #8 (permalink)
BlackBerry Extraordinaire
 
miamirulz29's Avatar
 
Join Date: Apr 2009
Location: The 305!
Model: 9000
OS: 5.0.0.592
PIN: N/A
Carrier: AT&T
Posts: 1,219
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, I think it has to do with your sim card. My bold was having problems, and they gave me a new sim, everything worked like a charm.
Offline  
Old 07-29-2009, 09:02 PM   #9 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

well then Bolds must fry SIM cards cause ive seen pretty much all my issues with countless Bolds at work
Offline  
Old 07-29-2009, 10:07 PM   #10 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i just installed OS 5.0.0.90 (platform 4.3.0.16) on my replacement. i keep getting popups about uncaught exceptions. any idea what to do here? also, my recption seems to be worse now. i went from 2-3bars EDGE to 0-1 bars EDGE. WTF? ok now it says SOS! and in the options it says my mobile network provider is TMobile? WTF is goin on here?
Offline  
Old 07-29-2009, 10:24 PM   #11 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

now it wont let me reinstall 4.6.0.477 :(

Last edited by JSanders : 07-29-2009 at 11:09 PM. Reason: language, ditto
Offline  
Old 07-29-2009, 11:06 PM   #12 (permalink)
BBF Spam Killer Moderator
 
daphne's Avatar
 
Join Date: May 2007
Location: on a sunny beach
Model: Z
OS: 10.2.1.12
PIN: X1ZPY34K
Carrier: VZW
Posts: 9,165
Post Thanks: 122
Thanked 146 Times in 116 Posts
Default

Please watch the language. Thanks.
__________________
Report spam text messages to 7726
#BlackBerry by choice #BlacBerry 10 is here!
Offline  
Old 07-29-2009, 11:09 PM   #13 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by daphne View Post
Please watch the language. Thanks.
funny its not edited out automatically...

anyways, do you have any input on this issue?
Offline  
Old 07-29-2009, 11:13 PM   #14 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

It's not edited out automatically because you should know better

The Bold is one of the best devices RIM has made, my favorite so far. I've had no problems, so your "everyone" statement is far from true.

Get a SIM exchange, for one thing.

Two, I have been in and out of the Va Tech area quite a bit and the ATT coverage there has improved somewhat over the past five years, but it's still not stellar unless you're firmly in a cell area.

Thirldy, don't expect your Bold to work anywhere near to correct with the 5.0.0.90 beta. Just don't even try. Go with the latest (.282) and be done.

So, what issues are you having installing that OS? Just saying it "won't let me" doesn't help anyone help you.

Last edited by JSanders : 07-29-2009 at 11:14 PM.
Offline  
Old 07-29-2009, 11:28 PM   #15 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JSanders View Post
It's not edited out automatically because you should know better

The Bold is one of the best devices RIM has made, my favorite so far. I've had no problems, so your "everyone" statement is far from true.

Get a SIM exchange, for one thing.

Two, I have been in and out of the Va Tech area quite a bit and the ATT coverage there has improved somewhat over the past five years, but it's still not stellar unless you're firmly in a cell area.

Thirldy, don't expect your Bold to work anywhere near to correct with the 5.0.0.90 beta. Just don't even try. Go with the latest (.282) and be done.

So, what issues are you having installing that OS? Just saying it "won't let me" doesn't help anyone help you.
just cause you dont have issues doesnt mean its not a big issue. trust me man, if youve worked for AT&T as a salesman or CSR, you know. im from philly where the reception on any AT&T or Verizon phone ive ever used is stellar. the Bold is by far the worst for reception.

i know VT is kinda in the middle of nowhere. i guess i expected more given the size of the school and that my little boondock undergrad school was even more remote yet had a Verizon AND AT&T tower in the town lol.

i knew there were issues with 5.0, i never said it is supposed to wrok or anything like that. i was just seeing if it was a simple fix someone knew about. but now its just pissing me off so i want to go back to 4.6.

i deleted the vendor file and the 5.0OS file in the shared folder, then ran loader.exe...theres no mention of loading an OS now. im trying to find a thread about going from 5.0 back to 4.x because i feel like ive read somewhere thats theres more to it than simply going from 4.6.0.xxx to 4.6.0.xxx
Offline  
Old 07-29-2009, 11:59 PM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2009
Model: 9000
PIN: N/A
Carrier: at&t
Posts: 48
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Fat Ryan View Post
just cause you dont have issues doesnt mean its not a big issue. trust me man, if youve worked for AT&T as a salesman or CSR, you know. im from philly where the reception on any AT&T or Verizon phone ive ever used is stellar. the Bold is by far the worst for reception.

i know VT is kinda in the middle of nowhere. i guess i expected more given the size of the school and that my little boondock undergrad school was even more remote yet had a Verizon AND AT&T tower in the town lol.

i knew there were issues with 5.0, i never said it is supposed to wrok or anything like that. i was just seeing if it was a simple fix someone knew about. but now its just pissing me off so i want to go back to 4.6.

i deleted the vendor file and the 5.0OS file in the shared folder, then ran loader.exe...theres no mention of loading an OS now. im trying to find a thread about going from 5.0 back to 4.x because i feel like ive read somewhere thats theres more to it than simply going from 4.6.0.xxx to 4.6.0.xxx
dude .. are you sure you didnt put the sim card in upside down? because this will cause the issue you are complaining about.. uncaught exception and java error.. go check your sim card. and no bolds dont fry sim cards. thats an ignorant comment.. you need a new sim card from what it seems.. call att and see if theres any work being done in the area that your at.. if they give u a new sim card and theres no problems with the towers in the area, then blame your phone
__________________
Follow me on Twitter
Offline  
Old 07-30-2009, 12:07 AM   #17 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by xplode View Post
dude .. are you sure you didnt put the sim card in upside down? because this will cause the issue you are complaining about.. uncaught exception and java error.. go check your sim card. and no bolds dont fry sim cards. thats an ignorant comment.. you need a new sim card from what it seems.. call att and see if theres any work being done in the area that your at.. if they give u a new sim card and theres no problems with the towers in the area, then blame your phone
1. my SIM card works PERFECTLY in the other AT&T phones ive used (2 2610's, tilt, e71x, v3xx, 737)
2. they are not working on the towers
3. like ive stated, im getting a new SIM tomorrow

btw, i hope the question about puttig the SIM in upside down was a joke...
Offline  
Old 07-30-2009, 12:13 AM   #18 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2009
Model: 9000
PIN: N/A
Carrier: at&t
Posts: 48
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Fat Ryan View Post
1. my SIM card works PERFECTLY in the other AT&T phones ive used (2 2610's, tilt, e71x, v3xx, 737)
2. they are not working on the towers
3. like ive stated, im getting a new SIM tomorrow

btw, i hope the question about puttig the SIM in upside down was a joke...
It was actually a statement/question.. You wouldnt believe how many people on forums lack common sense... You ask for help and people tell you what you can try and you just complain and bash those who try to help.. I give up dude.. enjoy mediocre phone service due to ignorance.
__________________
Follow me on Twitter

Last edited by xplode : 07-30-2009 at 12:17 AM.
Offline  
Old 07-30-2009, 12:17 AM   #19 (permalink)
No longer Registered.
 
Join Date: Mar 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 56
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by xplode View Post
It was actually a statement.. You wouldnt believe how many people on forums lack common sense... You ask for help and people tell you what you can try and you just complain and bash those who try to help.. I give up dude.. enjoy mediocre phone service due to ignorance.
i wish i could be as e-popular as you... must takes years of threading to become so clever.

im going to bed, i have class at 8am. ill be back tomorrow once i get the new SIM, dont wait up.
Offline  
Old 07-30-2009, 12:24 AM   #20 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,798
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

Quote:
Originally Posted by Fat Ryan View Post
im going to bed, i have class at 8am.
Well, that explains the know it all attitude.
Have fun.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.