BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-25-2009, 08:28 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2008
Location: Pisa, Italy
Model: 9000
OS: 5.0
Carrier: 3 Italy
Posts: 183
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Buyed an used Bold and it has a white line on the screen appearing after a while...

Please Login to Remove!

Hi!
I have buyed an used BB Bold 9000 from a guy at a good cheap price.
It works perfectly, but it has only one problem at the screen.

I have noticed that after a few seconds that the screen is on, an horizontal line at about one inch from the bottom of the screen starts blinking, and after just about 30 seconds the line stops blinking and it becomes white, so to end in having a while line on the screen!

If I turn off the screen or if I put the device in stand-by mode, or if I lock the keyboard (in other words..if I turn off the screen), when I turn the device back on again, the white line is disappeared, but it starts again blinking and becoming white after quite the same seconds as before!!

What could it be?
Is it a problem relatd to the screen?
Can I try to open the device and cleen the screen plug?
Should I change the display?

Thank you for everything!
Offline  
Old 08-25-2009, 10:27 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2007
Model: 9700
Carrier: AT&T
Posts: 155
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sounds like a bad lcd screen. Hope you didn't pay too much for the phone because a new screen will run you around $60 on eBay.
Offline  
Old 08-25-2009, 12:27 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2008
Location: Pisa, Italy
Model: 9000
OS: 5.0
Carrier: 3 Italy
Posts: 183
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have payed 280xxx8364;, and it has been buyed in December 2008...and it still has guarantee on it until December 2010.....so I think I'll go to try for a guarantee screen replacement!

Ps: on the official Rim/BB forums someone told me about some "moisture damage"... Do you think that I could probably clean the inside of the device and the screen plug to have it back working good?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.