BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-01-2009, 03:40 PM   #1 (permalink)
New Member
 
Join Date: Oct 2009
Model: 9000
PIN: N/A
Carrier: Tmobile/switching to AT&T
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BlackBerry Bold, no charge, no LED, no power.

Please Login to Remove!

Hi, I'm new here (as you can probably see). I was given a BlackBerry Bold as a gift last week for my upcoming trips. The first night, when I inserted the battery, I was able to turn it on for about 2 minutes. Afterwards I turned it off and proceeded to charge the battery. However, after hours of charging, it never came on (the light didnt come on red anymore at this point, or any other color). I continued to let it charge for about a day and a half. I read things online about letting it charge for 2-3 hours and taking the battery out and putting it back in, and so on but nothing has seemed to work. I was wondering, could there be a problem with my USB port? And if there is no fix for this that I can do myself, how can I go about getting a replacement. Or will I have to just buy one? I didnt buy this myself, and I have no idea exactly where it was purchased. Is there a manufacturer warranty? I'm totally out of ideas and any help would be very much appreciated.


Jin
Offline  
Old 10-01-2009, 03:44 PM   #2 (permalink)
CrackBerry Addict
 
TTsoldier's Avatar
 
Join Date: Sep 2009
Location: Trinidad and Tobago
Model: 9700
OS: 5.0.0.656
PIN: 2168B71A
Carrier: bmobile
Posts: 644
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Have you tried it with a wall charger?

Maybe you can try wiping it with JL_cmder and reloading the OS.
Offline  
Old 10-01-2009, 05:04 PM   #3 (permalink)
New Member
 
Join Date: Oct 2009
Model: 9000
PIN: N/A
Carrier: Tmobile/switching to AT&T
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

well, I've tried plugging it into the wall charger, but still no light comes on and it doesnt power up. I also tried plugging it into the usb on the back of my PC , and it wont even recognize its there, but the pc recognizes my ps3 controller and other accesories. Its weird, its like the phone is completely dead now.
Offline  
Old 10-01-2009, 07:48 PM   #4 (permalink)
CrackBerry Addict
 
TTsoldier's Avatar
 
Join Date: Sep 2009
Location: Trinidad and Tobago
Model: 9700
OS: 5.0.0.656
PIN: 2168B71A
Carrier: bmobile
Posts: 644
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

did u try usin jl cmder?
Offline  
Old 10-01-2009, 09:26 PM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Sep 2009
Model: 8900
PIN: N/A
Carrier: digicell
Posts: 60
Post Thanks: 0
Thanked 3 Times in 1 Post
Default

i haven't heard of anything like this yet...try out the above and let us know
Offline  
Old 10-01-2009, 09:41 PM   #6 (permalink)
New Member
 
Join Date: Oct 2009
Model: 9000
PIN: N/A
Carrier: Tmobile/switching to AT&T
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the help so far you guys.

I tried Jl_Cmder. I used a sort of tutorial from blackberryfaq.com for it, and one showing what to do if Jl_Cmder wont connect and wipe, but neither worked (i cant post links yet due to the post count rule). The problem is, the PC still wont recognize that I have the blackberry connected to it, and no LED light comes on. Is there maybe anything else I could try?
Offline  
Old 10-01-2009, 10:26 PM   #7 (permalink)
BlackBerry Extraordinaire
 
miamirulz29's Avatar
 
Join Date: Apr 2009
Location: The 305!
Model: 9000
OS: 5.0.0.592
PIN: N/A
Carrier: AT&T
Posts: 1,219
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try putting a different battery in the bold and see if it works
__________________
This isn't the real Caesar's Palace, is it?
What do you mean?
Did um, did Caesar live here?
Um... no.
I didn't think so.
Offline  
Old 10-02-2009, 06:41 AM   #8 (permalink)
New Member
 
Join Date: Oct 2009
Model: 9000
PIN: N/A
Carrier: Tmobile/switching to AT&T
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

well, unfortunately I dont have a spare battery to test it with, but I have a feeling its not the battery. Its definitely worth a try though, so I'll see if I can get my hands on a battery sometime today or tomorrow. If that doesnt work, is it likely that I just have to replace the whole phone? And if thats the case, will a manufacturer warranty be valid for me, seeing as how this was a gift? I cant really afford to buy a new one right now, so if thats the case, Im probably out of luck.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.