BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-26-2009, 04:46 AM   #1 (permalink)
New Member
 
Join Date: Nov 2009
Model: 9000
PIN: N/A
Carrier: Fido
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default SIM toolkit control error AT&T want to work on FIDO

Please Login to Remove!

So i unlocked with a new code but I still have this msg when I use my 3G as network
when 2G, it can make calls and msg, not when 3G is on.

So is there a way to get that rid of?

or is that the AT&T not allowing any 3G networks other than themselves even after unlock?!

Please help!
Offline  
Old 11-27-2009, 02:19 PM   #2 (permalink)
New Member
 
Join Date: Jul 2009
Location: Dubai/Waterloo,ON
Model: 9000
PIN: N/A
Carrier: Etisalat/Rogers
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

A lot of people, including myself, have had the same problem bringing an unlocked AT&T Bold to the Rogers network (which is what FIDO uses), just google the problem and you'll find multiple posts. I've heard the only simple solution is changing the sim card to an older Rogers 3040 model sim card. If FIDO doesn't use a Rogers sim card you're just going to have to go to a FIDO stand and try out multiple sim cards until you find one that works. When I went to Rogers they were going to charge me $40 to get a new sim card so I'm assuming it will be the same for FIDO. However, I didn't want to pay $40 so I found another much more technical solution that is free. If you're interested, just pm to get the details on how to do it because there are a lot of steps.
Offline  
Old 11-27-2009, 05:51 PM   #3 (permalink)
New Member
 
Join Date: Apr 2009
Model: 9000
PIN: N/A
Carrier: Rogers
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

all i did was upgraded the OS to the newest 5.0 but deleted the vendor.xml file so I could load it on...the new os allowed me to pick 2g instead of 3g on my bold so although I am always connected to 2g, I get way better battery life than I would if I was on 3g.
Offline  
Old 12-01-2009, 02:50 PM   #4 (permalink)
New Member
 
Join Date: Dec 2009
Model: 9530
PIN: N/A
Carrier: rogers
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The only way to fix the sim toolkit error right now is to use your phone on the 2 G EDGE network. This will allow you to make and receive sms and phone calls.
Offline  
Old 12-27-2009, 04:33 PM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2008
Model: 8320
PIN: N/A
Carrier: Rogers
Posts: 50
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by chubby127 View Post
A lot of people, including myself, have had the same problem bringing an unlocked AT&T Bold to the Rogers network (which is what FIDO uses), just google the problem and you'll find multiple posts. I've heard the only simple solution is changing the sim card to an older Rogers 3040 model sim card. If FIDO doesn't use a Rogers sim card you're just going to have to go to a FIDO stand and try out multiple sim cards until you find one that works. When I went to Rogers they were going to charge me $40 to get a new sim card so I'm assuming it will be the same for FIDO. However, I didn't want to pay $40 so I found another much more technical solution that is free. If you're interested, just pm to get the details on how to do it because there are a lot of steps.
If you can share with me the tech solution and steps, will I be able to use my 4000 series Rogers sim card on my at&t Bold on 3G network? Please e,mail me the tech steps to [email address] Thanks so much in advance.
Offline  
Old 12-28-2009, 04:02 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Location: vancouver
Model: 9700
PIN: 21C1DB50
Carrier: Mobilicity
Posts: 40
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

mine is voda version. im using it on fido with no problem. mind u im using my original fido sim card from 5 years ago.
Offline  
Old 12-31-2009, 02:24 AM   #7 (permalink)
New Member
 
Join Date: Dec 2009
Model: 9700
PIN: N/A
Carrier: fido
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default hopefully this will work for you... let me know...

Hi there, I had the same problem on my att bold 9700... this worked for me... let me know if it works for you:

1. goto options --> phone options
2. goto smart dialing
3. in smart dialing for country code instead of the stock "+1" change it to "unknown"

voila! now you can dial out again

my sim is the new UO2 series from FIDO if it makes any sense to anyone...

Cheers,
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.