BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-26-2009, 12:15 AM   #1 (permalink)
New Member
 
Join Date: Dec 2009
Model: 9000
PIN: N/A
Carrier: atandt
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default HELP PLEASE, turns on with white screen

Please Login to Remove!

So my 9000 just freezes suddenly, so I took out the battery (fully charged) and try to restart the phone.
But after the battery is in, red light on as normal, then white background with the little loading black square in the middle for a little bit.
BUT THEN !!! the loading square is gone and only the blank white screen is on forever.
I have repeated taking the battery out for like 8 times and its still the same !!!
PLEASE give me some help.
Offline  
Old 12-28-2009, 05:30 AM   #2 (permalink)
CrackBerry Addict
 
Join Date: Dec 2008
Location: Airport lounges and starbuxxx
Model: 9900
OS: 7.0.0.296
Carrier: Vodafone Business
Posts: 573
Post Thanks: 1
Thanked 5 Times in 4 Posts
Default

You will have to either buy a new screen, or wipe/reinstall your operating system, or leave the battery out for 10-20 minutes re-insert and fully charge, or replace your handset, or a possible combination of those.

Consult the FAQ for most of the above, start with the least expensive solution and work your way up. A quick search on "white screen" would surface previously posted relevant threads.
Offline  
Old 12-28-2009, 07:24 AM   #3 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,030
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Quote:
Originally Posted by melvino View Post
So my 9000 just freezes suddenly, so I took out the battery (fully charged) and try to restart the phone.
But after the battery is in, red light on as normal, then white background with the little loading black square in the middle for a little bit.
BUT THEN !!! the loading square is gone and only the blank white screen is on forever.
I have repeated taking the battery out for like 8 times and its still the same !!!
PLEASE give me some help.

Does an error code display on the screen - something like JVM523 or similar?

What were you doing just prior to this happening?

We really need a bit more info, but my initial thought is you need to reload the OS. See the yellow sticky at the top of the 9000 section and follow the directions EXACTLY. Be patient. It takes a while.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 12-30-2009, 03:28 PM   #4 (permalink)
No longer Registered.
 
Join Date: Aug 2008
Location: USA / UK
Model: XXXXi
OS: v6.XXX
Carrier: A Good One
Posts: 327
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ye had the same problem. This is what Ive come up with.

If you see the any kind of loading sign, through the initial booting process aka turning it on, then your LCD is not damaged. Look around this forum and find the HARD-RESET & MEM-CARD TAKEOUT RESET etc.....

However If you turn the phone on, (you obviously get the red light for a few secs) and in this case you do not see no sign of loading and go straight to the white screen. You need a new LCD.

Its not just you, its a big problem for the Bold.

Hope this helps
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.