BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-26-2009, 10:07 AM   #1 (permalink)
New Member
 
Join Date: Dec 2009
Model: bold
PIN: N/A
Carrier: maxis
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Help, Bought A New Bb Bold But Screen Doesnt Show Anything During Charging

Please Login to Remove!

i just bought a new BB bold 9000. I started charging and the red LED turned on. then, after a few seconds the LED turned off and a battery image appear on the screen for a few seconds and disappear . what is happening exactly?
Offline  
Old 12-26-2009, 10:17 AM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: Z30
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,920
Post Thanks: 61
Thanked 253 Times in 184 Posts
Default

Wirelessly posted (9520; (I'm mobile))

Wow. Give people more than three minutes to answer your inquiry.


Your battery is dead. Give it 2 to 3 hours to charge and then with the charger still connected remove the battery and replace to reboot.

Last edited by JSanders : 12-26-2009 at 10:22 AM.
Offline  
Old 12-26-2009, 10:19 AM   #3 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: BBPP
OS: 10.3.3
Carrier: T-Mobile USA
Posts: 13,958
Post Thanks: 24
Thanked 525 Times in 510 Posts
Default

Wirelessly posted (8820)

Give it some time for someone who knows the answer to respond. You don't need to bump.
__________________
- Ira
Offline  
Old 12-26-2009, 11:20 AM   #4 (permalink)
New Member
 
Join Date: Dec 2009
Model: bold
PIN: N/A
Carrier: maxis
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

but why wont it shows any sign of charging? is this normal for new batteries?
Offline  
Old 12-26-2009, 11:35 AM   #5 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: SGS7
Carrier: Verizon
Posts: 27,908
Post Thanks: 32
Thanked 459 Times in 395 Posts
Default

By new, do you mean new from a carrier or new from eBay?
Offline  
Old 12-26-2009, 11:38 AM   #6 (permalink)
BlackBerry Extraordinaire
 
kirrinjones's Avatar
 
Join Date: Apr 2006
Location: Jamaica
Model: 9000
OS: 5.0.0.610
PIN: 208E7C41
Carrier: LIME, Jamaica
Posts: 1,533
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

If you charge the battery for 2-3 hours and still no go, then you may need a new battery.
__________________
-----------------------------------------------------
Website - http://kirrinjones.wordpress.com
Twitter - http://www.twitter.com/kirrinjones
Offline  
Old 12-26-2009, 11:44 AM   #7 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: Z30
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,920
Post Thanks: 61
Thanked 253 Times in 184 Posts
Default

Wirelessly posted (9520; (I'm mobile))

Quote:
Originally Posted by amrulkareem
but why wont it shows any sign of charging? is this normal for new batteries?
You can also try a different charger.
Has it already been 2-3 hours?
Offline  
Old 12-26-2009, 11:59 AM   #8 (permalink)
New Member
 
Join Date: Dec 2009
Model: bold
PIN: N/A
Carrier: maxis
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by NJBlackBerry View Post
By new, do you mean new from a carrier or new from eBay?
not from ebay. i bought it at a shopping complex
Offline  
Old 12-26-2009, 12:02 PM   #9 (permalink)
New Member
 
Join Date: Dec 2009
Model: bold
PIN: N/A
Carrier: maxis
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JSanders View Post
Wirelessly posted (9520; (I'm mobile))



You can also try a different charger.
Has it already been 2-3 hours?

the light only on the first few seconds. hmm im not sure. i dont think it has been 2 to 3 hours. perhaps only 1 hour, but still not showing any progress.
i never deal with a problem like this with my previous phone. sighh
Offline  
Old 12-26-2009, 01:16 PM   #10 (permalink)
BlackBerry Extraordinaire
 
miamirulz29's Avatar
 
Join Date: Apr 2009
Location: The 305!
Model: 9000
OS: 5.0.0.592
PIN: N/A
Carrier: AT&T
Posts: 1,219
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Something is probably either wrong with the charger or the battery. Go to a store and ask them if you can try out a new battery/charger.
__________________
This isn't the real Caesar's Palace, is it?
What do you mean?
Did um, did Caesar live here?
Um... no.
I didn't think so.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.