BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   General 9000 Series Discussion - Bold (http://www.blackberryforums.com/general-9000-series-discussion-bold/)
-   -   FIX: White Screen of Death (http://www.blackberryforums.com/general-9000-series-discussion-bold/225556-fix-white-screen-death.html)

wildlemon747 04-30-2010 07:01 PM

FIX: White Screen of Death
 
If any of you are encountering the error where your blackberry goes to a white screen after a random amount of time then requiring a restart to correct, I have found the problem to be the battery. I was using a third party battery, once I popped in the original one, all problems were resolved. Hope this helps anyone with a similar problem.

Lukenthegreat 05-02-2010 01:45 PM

good looking out.

jrags0951 05-10-2010 06:47 PM

White Screen
 
My BB9700 would only boot up to a blank white screen. I changed the battery, went to T Mobile and got a new Sim Card, used the drop method, plugged it in to my PC and Desktop Manager....everything I could think of.
I finally downloaded the Operating Software and uploaded it. Still nothing. So I called customer support and thankfully the phone was under warranty. The new one went to white screen only. I sent it back and the third one arrived. It too would only boot up to white screen. Out of desperation, I downloaded an OLDER version of the OS. I uploaded it and low and behold the damn phone finally booted up. I'll never upgrade the OS again.

Dubdub 05-10-2010 07:38 PM

jrags, do you have an 8900 as stated in your profile or a 9700 as in your post? If it is the 9700, please update your profile.

Thanks

bradman16 05-10-2010 10:16 PM

Thats super thanks! my buddy had this problem and you helped out huge.

jimfraser 05-11-2010 10:23 AM

Quote:

Originally Posted by wildlemon747 (Post 1601368)
If any of you are encountering the error where your blackberry goes to a white screen after a random amount of time then requiring a restart to correct, I have found the problem to be the battery. I was using a third party battery, once I popped in the original one, all problems were resolved. Hope this helps anyone with a similar problem.

I have only been getting the white screen of death during the last three weeks and only with a third party battery (one clearly a third party battery, the other purporting to be a RIM original, but at half the price of a battery from a recoginzed vendor, I have my doubts). I will put my original rim battery in and see if it is the battery. I am suspitious that it may be the battery, but logic says it should not be. The white screens of death are so random, that I cannot pin point what triggers them.

darkamikaze 05-11-2010 07:14 PM

wow .. surprising i'm not the only one who has this problem..

I'm believing it is the battery that could be the culprit..

for me.. it will just randomly disintegrate into the white screen.. and the only thing i could do is a battery pull.

Although after the battery pull, my battery is low bat and it will most likely do the white screen again after that.. and as far as I keep trying it will just die out. The only way I can fix it is if I charge it.. :/ it just happened right now but I have no charger for another 2 hours..

will update when I get it charged

I might try a different OS just to see if it makes a difference.. but it's so random so it's hard to test things out.. Not to mention it doesn't happen to frequently..

wildlemon747 05-11-2010 07:22 PM

Quote:

Originally Posted by darkamikaze (Post 1605661)
wow .. surprising i'm not the only one who has this problem..

I'm believing it is the battery that could be the culprit..

for me.. it will just randomly disintegrate into the white screen.. and the only thing i could do is a battery pull.

Although after the battery pull, my battery is low bat and it will most likely do the white screen again after that.. and as far as I keep trying it will just die out. The only way I can fix it is if I charge it.. :/ it just happened right now but I have no charger for another 2 hours..

will update when I get it charged

I might try a different OS just to see if it makes a difference.. but it's so random so it's hard to test things out.. Not to mention it doesn't happen to frequently..

This is the exact scenario that occurred to me when I used a third party battery. Are you using a RIM issued battery?

darkamikaze 05-11-2010 07:33 PM

Quote:

Originally Posted by wildlemon747 (Post 1605662)
This is the exact scenario that occurred to me when I used a third party battery. Are you using a RIM issued battery?

yep I actually am X_x... mm what version are you running?
5.0.0.592/5.0.0.1004

I'm thinking maybe downgrading.. or something start from there.

I checked my phone and my battery white marks to see if they have been water damaged.. but nothing :/ ..

I notice, that the screws sometimes get loose in the back of my phone when I remove the back cover. I've tighten it, I think it just keeps getting loose.

So many factors.. so hard to know what variable is off!!

wildlemon747 05-11-2010 07:35 PM

I'm on 5.0.0.509. Was on .592 and found it buggy, perhaps consider a downgrade?

darkamikaze 05-12-2010 02:40 AM

I just might, I'll let you know

ccbl 05-12-2010 10:30 AM

mine does this once in a while. especially when battery is running low.. it seems to just give up on life and not run up to par. still using oem everything but has the latest os..

called rogers about this and they said i should downgrade back to original os. Every time the phone goes to sleep mode and i wake it back up with any button the screen goes white.. and will stay white until i hit some other buttons.. sometimes its takes 3-4. whats the reason for that?

ash146 05-16-2010 09:18 PM

Quote:

Originally Posted by darkamikaze (Post 1605661)
wow .. surprising i'm not the only one who has this problem..

I'm believing it is the battery that could be the culprit..

for me.. it will just randomly disintegrate into the white screen.. and the only thing i could do is a battery pull.

Although after the battery pull, my battery is low bat and it will most likely do the white screen again after that.. and as far as I keep trying it will just die out. The only way I can fix it is if I charge it.. :/ it just happened right now but I have no charger for another 2 hours..

will update when I get it charged

I might try a different OS just to see if it makes a difference.. but it's so random so it's hard to test things out.. Not to mention it doesn't happen to frequently..

this happens to me except mine is the original RIM issue battery. I've seen this more and more since I upgraded from the previous 2 O/S v5.0 listed in this forum. and when i do reboot, its complete battery dump - as if my BB just threw up and told me to eat sh!t.

Bulkhead 07-15-2010 02:00 PM

I have this situation also. I recently got a "new" bold as a replacement for my prior phone. That one had the trackball get jammed up. ATT replaced it, but my new phone suffers from this white screen issue.

It is random, but has happened 4 times in 2 weeks. Annoying. I found that the phone appears to still "work" or respond.

I press and hold the red hangup button until the phone shuts down.

Then, I turn it back on - seems to work. Better than a battery pull if you need to use the phone right away.

I am going to call my replacement store to ask about the battery issue and see if they will replace it or the whole dang phone again.

Frustrating as it takes several days to "move into" a new phone....

Hope this helps someone!

Cheers

cmuncan 07-16-2010 08:10 AM

I too have had this happen a couple of times. I use only the original RIM batteries. The problem seems to happen when the battery is ~18% full. I just do a battery pull and it works again. I will have to try what Bulkhead suggested whereby pressing the power button to shut off the device. That is much quicker than a battery pull.

Cheers.


All times are GMT -5. The time now is 06:06 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.