BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 04-30-2010, 07:01 PM   #1 (permalink)
Thumbs Must Hurt
 
wildlemon747's Avatar
 
Join Date: Aug 2007
Location: Kirkland, WA
Model: 9800
PIN: N/A
Carrier: AT&T
Posts: 75
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default FIX: White Screen of Death

Please Login to Remove!

If any of you are encountering the error where your blackberry goes to a white screen after a random amount of time then requiring a restart to correct, I have found the problem to be the battery. I was using a third party battery, once I popped in the original one, all problems were resolved. Hope this helps anyone with a similar problem.
Offline  
Old 05-02-2010, 01:45 PM   #2 (permalink)
New Member
 
Join Date: Jan 2010
Location: Toronto
Model: 9000
PIN: N/A
Carrier: Rogers
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

good looking out.
Offline  
Old 05-10-2010, 06:47 PM   #3 (permalink)
New Member
 
Join Date: May 2010
Model: 8900
PIN: N/A
Carrier: T Mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default White Screen

My BB9700 would only boot up to a blank white screen. I changed the battery, went to T Mobile and got a new Sim Card, used the drop method, plugged it in to my PC and Desktop Manager....everything I could think of.
I finally downloaded the Operating Software and uploaded it. Still nothing. So I called customer support and thankfully the phone was under warranty. The new one went to white screen only. I sent it back and the third one arrived. It too would only boot up to white screen. Out of desperation, I downloaded an OLDER version of the OS. I uploaded it and low and behold the damn phone finally booted up. I'll never upgrade the OS again.
Offline  
Old 05-10-2010, 07:38 PM   #4 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App6+
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,038
Post Thanks: 52
Thanked 777 Times in 737 Posts
Default

jrags, do you have an 8900 as stated in your profile or a 9700 as in your post? If it is the 9700, please update your profile.

Thanks
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 05-10-2010, 10:16 PM   #5 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9700
PIN: N/A
Carrier: telus
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thats super thanks! my buddy had this problem and you helped out huge.
Offline  
Old 05-11-2010, 10:23 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Apr 2005
Location: Toronto Canada
Model: Q10
OS: 10.2.1.21
Carrier: Rogers
Posts: 439
Post Thanks: 12
Thanked 13 Times in 13 Posts
Default

Quote:
Originally Posted by wildlemon747 View Post
If any of you are encountering the error where your blackberry goes to a white screen after a random amount of time then requiring a restart to correct, I have found the problem to be the battery. I was using a third party battery, once I popped in the original one, all problems were resolved. Hope this helps anyone with a similar problem.
I have only been getting the white screen of death during the last three weeks and only with a third party battery (one clearly a third party battery, the other purporting to be a RIM original, but at half the price of a battery from a recoginzed vendor, I have my doubts). I will put my original rim battery in and see if it is the battery. I am suspitious that it may be the battery, but logic says it should not be. The white screens of death are so random, that I cannot pin point what triggers them.
Offline  
Old 05-11-2010, 07:14 PM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Model: 9000
OS: 5.0
PIN: 20d94251
Carrier: AT&T or Cingular
Posts: 198
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

wow .. surprising i'm not the only one who has this problem..

I'm believing it is the battery that could be the culprit..

for me.. it will just randomly disintegrate into the white screen.. and the only thing i could do is a battery pull.

Although after the battery pull, my battery is low bat and it will most likely do the white screen again after that.. and as far as I keep trying it will just die out. The only way I can fix it is if I charge it.. :/ it just happened right now but I have no charger for another 2 hours..

will update when I get it charged

I might try a different OS just to see if it makes a difference.. but it's so random so it's hard to test things out.. Not to mention it doesn't happen to frequently..
__________________
----
Blackberry. It tastes good.
----
Offline  
Old 05-11-2010, 07:22 PM   #8 (permalink)
Thumbs Must Hurt
 
wildlemon747's Avatar
 
Join Date: Aug 2007
Location: Kirkland, WA
Model: 9800
PIN: N/A
Carrier: AT&T
Posts: 75
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by darkamikaze View Post
wow .. surprising i'm not the only one who has this problem..

I'm believing it is the battery that could be the culprit..

for me.. it will just randomly disintegrate into the white screen.. and the only thing i could do is a battery pull.

Although after the battery pull, my battery is low bat and it will most likely do the white screen again after that.. and as far as I keep trying it will just die out. The only way I can fix it is if I charge it.. :/ it just happened right now but I have no charger for another 2 hours..

will update when I get it charged

I might try a different OS just to see if it makes a difference.. but it's so random so it's hard to test things out.. Not to mention it doesn't happen to frequently..
This is the exact scenario that occurred to me when I used a third party battery. Are you using a RIM issued battery?
Offline  
Old 05-11-2010, 07:33 PM   #9 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Model: 9000
OS: 5.0
PIN: 20d94251
Carrier: AT&T or Cingular
Posts: 198
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wildlemon747 View Post
This is the exact scenario that occurred to me when I used a third party battery. Are you using a RIM issued battery?
yep I actually am X_x... mm what version are you running?
5.0.0.592/5.0.0.1004

I'm thinking maybe downgrading.. or something start from there.

I checked my phone and my battery white marks to see if they have been water damaged.. but nothing :/ ..

I notice, that the screws sometimes get loose in the back of my phone when I remove the back cover. I've tighten it, I think it just keeps getting loose.

So many factors.. so hard to know what variable is off!!
__________________
----
Blackberry. It tastes good.
----
Offline  
Old 05-11-2010, 07:35 PM   #10 (permalink)
Thumbs Must Hurt
 
wildlemon747's Avatar
 
Join Date: Aug 2007
Location: Kirkland, WA
Model: 9800
PIN: N/A
Carrier: AT&T
Posts: 75
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm on 5.0.0.509. Was on .592 and found it buggy, perhaps consider a downgrade?
Offline  
Old 05-12-2010, 02:40 AM   #11 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2008
Model: 9000
OS: 5.0
PIN: 20d94251
Carrier: AT&T or Cingular
Posts: 198
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just might, I'll let you know
__________________
----
Blackberry. It tastes good.
----
Offline  
Old 05-12-2010, 10:30 AM   #12 (permalink)
New Member
 
Join Date: Apr 2010
Model: 9000
PIN: N/A
Carrier: Rogers
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

mine does this once in a while. especially when battery is running low.. it seems to just give up on life and not run up to par. still using oem everything but has the latest os..

called rogers about this and they said i should downgrade back to original os. Every time the phone goes to sleep mode and i wake it back up with any button the screen goes white.. and will stay white until i hit some other buttons.. sometimes its takes 3-4. whats the reason for that?
Offline  
Old 05-16-2010, 09:18 PM   #13 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2006
Location: TO
Model: 9000
Carrier: Rogers
Posts: 54
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by darkamikaze View Post
wow .. surprising i'm not the only one who has this problem..

I'm believing it is the battery that could be the culprit..

for me.. it will just randomly disintegrate into the white screen.. and the only thing i could do is a battery pull.

Although after the battery pull, my battery is low bat and it will most likely do the white screen again after that.. and as far as I keep trying it will just die out. The only way I can fix it is if I charge it.. :/ it just happened right now but I have no charger for another 2 hours..

will update when I get it charged

I might try a different OS just to see if it makes a difference.. but it's so random so it's hard to test things out.. Not to mention it doesn't happen to frequently..
this happens to me except mine is the original RIM issue battery. I've seen this more and more since I upgraded from the previous 2 O/S v5.0 listed in this forum. and when i do reboot, its complete battery dump - as if my BB just threw up and told me to eat sh!t.
Offline  
Old 07-15-2010, 02:00 PM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2006
Location: San Diego
Model: 9000
OS: 5.0.0.411
Carrier: ATT
Posts: 50
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

I have this situation also. I recently got a "new" bold as a replacement for my prior phone. That one had the trackball get jammed up. ATT replaced it, but my new phone suffers from this white screen issue.

It is random, but has happened 4 times in 2 weeks. Annoying. I found that the phone appears to still "work" or respond.

I press and hold the red hangup button until the phone shuts down.

Then, I turn it back on - seems to work. Better than a battery pull if you need to use the phone right away.

I am going to call my replacement store to ask about the battery issue and see if they will replace it or the whole dang phone again.

Frustrating as it takes several days to "move into" a new phone....

Hope this helps someone!

Cheers
__________________
H/W: 9000, Platform:5.2.0.76, Apps:5.0.0.822, Carrier:ATT
Offline  
Old 07-16-2010, 08:10 AM   #15 (permalink)
Thumbs Must Hurt
 
cmuncan's Avatar
 
Join Date: Jan 2009
Location: Waterloo, Ontario
Model: 9000
OS: 5.0.0.592
Carrier: Rogers
Posts: 74
Post Thanks: 2
Thanked 0 Times in 0 Posts
Default

I too have had this happen a couple of times. I use only the original RIM batteries. The problem seems to happen when the battery is ~18% full. I just do a battery pull and it works again. I will have to try what Bulkhead suggested whereby pressing the power button to shut off the device. That is much quicker than a battery pull.

Cheers.
__________________
___________________
cmuncan

If at first you don't succeed, give up because if you can't do it right the first time, you'll never be able to do it!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Carlisle IT50062 Cateraide IT Insulated Beverage Server / Dispenser, 5 Gallon,
$129.98
Carlisle IT50062 Cateraide IT Insulated Beverage Server / Dispenser, 5 Gallon, picture1 pc USED Yaskawa Server SGDM-15ADA-TE3B
$962.85
1 pc USED Yaskawa Server SGDM-15ADA-TE3B pictureNEW Bunn BM27792.0005 27792.0005 soft heat SH Server timer circuit board
$98.76
NEW Bunn BM27792.0005 27792.0005 soft heat SH Server timer circuit board picture100pcs New Hard Drive HDD Caddy Pop Swap Server Tray Screw DIY Computer Pop FJ
$4.84
100pcs New Hard Drive HDD Caddy Pop Swap Server Tray Screw DIY Computer Pop FJ picture100pcs New Hard Drive HDD Caddy Pop Swap Server Tray Screw DIY Computer Pop FJ
$4.84
100pcs New Hard Drive HDD Caddy Pop Swap Server Tray Screw DIY Computer Pop FJ picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.