BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-23-2010, 09:06 AM   #1 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8700g
PIN: N/A
Carrier: T-Mobile
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BB Bold 9000: white screen of death? Any fixes?

Please Login to Remove!

Hi Everyone

i just got the international version of the bold 9000 off of Amazon.com, i was soo excited to receive it. Of course when I go to turn it on, theres nothing but a plain white screen. I searched online and found some people with similar issues but they either had a previously functioning blackberry before, or they had at least some sort of message at the white screen.

When I put in the battery, the red LED light turned on for a few seconds then the trackball turned white then immediately the screen came on...only to be white no hourglass, no error message, nothing...

Anybody have any suggestions or possible fixes for this issue. I would hate having to return this awesome phone. Thanks in advance guys
Offline  
Old 08-23-2010, 09:47 AM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,036
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Reinstall the OS.

See the yellow sticky at the top of the 9000 section for the latest OS and instructions.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 08-23-2010, 11:26 AM   #3 (permalink)
Thumbs Must Hurt
 
lukynk2bb's Avatar
 
Join Date: Dec 2008
Location: Prague
Model: 9900
OS: 7.1.0.342
PIN: 29A563C4
Carrier: Vodafone CZ BIS
Posts: 71
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Try to reinstall OS - I was searching a little bit and found one guy with similar problem and it was hardware error - so if you connect your BB to the PC and PC won't recognize it - maybe hardware problem:( so try it and let us know
Posted via BlackBerryForums.com Mobile
Offline  
Old 08-23-2010, 12:20 PM   #4 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8700g
PIN: N/A
Carrier: T-Mobile
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

@Dubdub & lukynk2bb
the problem is I can't see anything on the screen. however the computer does recognize the device when I connect it. so I installed BB Desktop Manager 6, connected my BB and updated the device software. but this did not alleviate the problem, the screen is still plain white.
Offline  
Old 08-23-2010, 12:32 PM   #5 (permalink)
Thumbs Must Hurt
 
lukynk2bb's Avatar
 
Join Date: Dec 2008
Location: Prague
Model: 9900
OS: 7.1.0.342
PIN: 29A563C4
Carrier: Vodafone CZ BIS
Posts: 71
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

And when you were reinstalling OS in your BB have you restore settings or have you made plain reinstal without restoring data and settings?
Posted via BlackBerryForums.com Mobile
Offline  
Old 08-23-2010, 12:42 PM   #6 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,036
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

After the restore, try a battery pull and see if that does anything.

If not and you still have a white screen, send it back for a replacement.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 08-23-2010, 12:44 PM   #7 (permalink)
EPIC MOD
 
ezrunner's Avatar
 
Join Date: Mar 2006
Location: Virginia Beach
Model: ZED10
OS: DOS 3.1
PIN: INK STICK
Carrier: Tmobile
Posts: 12,214
Post Thanks: 9
Thanked 6 Times in 6 Posts
Default

Could be a bad lcd or connection between pcb and lac also
Posted via BlackBerryForums.com Mobile
Offline  
Old 08-23-2010, 12:49 PM   #8 (permalink)
Thumbs Must Hurt
 
lukynk2bb's Avatar
 
Join Date: Dec 2008
Location: Prague
Model: 9900
OS: 7.1.0.342
PIN: 29A563C4
Carrier: Vodafone CZ BIS
Posts: 71
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

Could be hardware problem, but first try to reinstall it without restoring data and settings. If it wont help send it back as mentioned. Let us know
Posted via BlackBerryForums.com Mobile
Offline  
Old 08-23-2010, 01:23 PM   #9 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8700g
PIN: N/A
Carrier: T-Mobile
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

the first thing i tried was pulling the battery. then i tried to fully charge the battery, nothing...what sucks about this whole situation is that i never even used the phone :( i guess this things gotta go back first thing in the morning, thanks for all your help guys!
Offline  
Old 08-25-2010, 11:48 AM   #10 (permalink)
New Member
 
Radioactive-Man's Avatar
 
Join Date: Aug 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

2nd the reinstall OS.
Offline  
Old 08-30-2010, 10:14 AM   #11 (permalink)
Knows Where the Search Button Is
 
amico_pl's Avatar
 
Join Date: Dec 2008
Location: Warsaw, Poland
Model: 9800
OS: 6.0.0.600
Carrier: Plus GSM
Posts: 36
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

In my case it was a screen problem. Replacement was needed.
Bought off eBay and installed myself.
__________________
My PDA history: Psion 3->Psion 3a->Psion 5->Palm V->Palm Vx->Palm Tungsten T3->Fujitsu Siemens N560 (mistake!)->BB 8700g->BB8310->BB 9000->BB 9800
Offline  
Old 08-30-2010, 03:38 PM   #12 (permalink)
New Member
 
Join Date: Aug 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i would use jl_cmder to "wipe" first, then reinstall the OS.

if that doesn't work, maybe it's a defective unit. amazon has a good return policy, should be able to exchange it for you.
Offline  
Old 08-31-2010, 02:21 AM   #13 (permalink)
New Member
 
Join Date: Aug 2010
Model: 9000
PIN: N/A
Carrier: celcom
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

these problem same like me!, "device errors 370" alwys to reset, after a few minutes out of a white screen, why is there so
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.