BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-16-2010, 07:14 PM   #1 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Screen Problem!

Please Login to Remove!

I bought my Blackberry Bold 9000 brand new from the store when I opened my account. I have had the phone for maybe 7 months and after about a month of having the phone a spot showed up on the screen in the left top corner. (View picture in attachment) The spot began looking like some kind of brightness problem but only in one spot then as the weeks went by it began to progress down the screen now ending at the bottom near the track ball. The phone has no major damage, never been in water, never dropped, and everything else still works fine.


When I called AT&T to see about getting it fixed they told me that maybe it just needed to be updated with the latest software update. I done this but as I figured it did not fix the problem. So, my main question is does anyone have any idea of what might be causing the problem and how I can fix it?

-Miranda
Attached Thumbnails
Screen Problem!-edit.jpg  
Offline  
Old 09-18-2010, 01:24 AM   #2 (permalink)
Thumbs Must Hurt
 
mccraney4's Avatar
 
Join Date: Jan 2006
Location: New Orleans
Model: 9670
OS: 6.0.407
PIN: 328B86A6
Carrier: Sprint
Posts: 71
Post Thanks: 0
Thanked 3 Times in 3 Posts
Default

your better off just ordering a new screen and replacing it yourself, if you are comfortable doing that, other wise they will charge you for the screen saying you droped it or some excuse same thing happened to mine and i got the run around so i just bought a 28 dollar screen on ebay and replaced it myself, works fine now
__________________
Geaux Tigers

R.I.P 7520, 8700, 8310, 8800, 9000, 9700, 9800, and last but not least the Curve 3G (8310 in disguise)
Offline  
Old 09-18-2010, 07:47 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Dec 2006
Model: I747
OS: 4.1.1
Carrier: at&t
Posts: 2,340
Post Thanks: 43
Thanked 117 Times in 107 Posts
Default

I can not see the problem viewing the image you provided.
__________________
The Search tool and BlackBerryFAQ answer many questions.
Offline  
Old 09-18-2010, 07:55 AM   #4 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,020
Post Thanks: 54
Thanked 778 Times in 740 Posts
Default

If it is still under warranty, go to an ATT store, show then the problem and get another. Might be a refurb, but at least it will work.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.