BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-10-2008, 01:19 PM   #1 (permalink)
New Member
 
Join Date: Dec 2008
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't submit a form on the web browser

Please Login to Remove!

Am I just using the web browser completely wrong?

To visit a link -- highlight the link, press blackberry button, select "Get link"? Seems cumbersome, but nothing else works.

Submitting a form is impossible. I can't click on web form buttons.
Offline  
Old 12-10-2008, 01:28 PM   #2 (permalink)
Knows Where the Search Button Is
 
unclemetz's Avatar
 
Join Date: Jul 2007
Location: Charlotte, NC
Model: 9530
OS: 5.0.0.328
PIN: N/A
Carrier: Verizon
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is this happening for all pages? The inability to submit a form could be b/c JavaScript is not turned on (Options --> Browser Config --> Support JavaScript checkbox), depending on if the page executes JS to submit the form.

Not sure about the link issue. Might try the "Cursor Mode" to make it easier to see you are clicking on the link. I have to do this often.
Offline  
Old 12-10-2008, 01:46 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2008
Location: Southern New Mexico
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by benw-sf View Post
Am I just using the web browser completely wrong?

To visit a link -- highlight the link, press blackberry button, select "Get link"? Seems cumbersome, but nothing else works.

Submitting a form is impossible. I can't click on web form buttons.
I have had this problem, too. I estimated that about 95% of the instances where I need to enter something on a form it works. But, there are some web sites that I cannot for the life of me make work. Example: signing in to MyYahoo.

Good luck on solving this, as I am interested too!

Steve
Offline  
Old 12-12-2008, 12:33 PM   #4 (permalink)
New Member
 
Join Date: Dec 2008
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 4.7 upgrade fixes the problem

zehnmm -- Yahoo was the test-case for me, too. I thought it ironic that one of the few Applications available is Flickr, but you can't use the Flickr site!

Anyway, after installing the 4.7 upgrades (and, as a non-Windows-person, that was no fun) it works -- clicking Enter after filling out a form now submits the form (previously it moved you to the next field).
Offline  
Old 12-16-2008, 08:26 PM   #5 (permalink)
Thumbs Must Hurt
 
mrjerome's Avatar
 
Join Date: Oct 2004
Location: Jacksonville, Fl
Model: 9530
OS: 4.7.0.114
Carrier: Verizon
Posts: 112
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Curser mode is the answer and turn on javascript
__________________
Kyocera QCP 6035> Motorola V600> PocketPC> HP6315> BlackBerry 7100t> Treo 600/650/700w/700wx/700p> BlackBerry 8830/8130/8330/9530
Offline  
Old 12-16-2008, 08:56 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Dec 2008
Model: 9530
PIN: N/A
Carrier: verizon
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have had no problems w/ javascript on. Page loads a little slower, but the pages all work.
Offline  
Old 12-18-2008, 12:45 PM   #7 (permalink)
New Member
 
Join Date: Dec 2008
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Javascript & cursor mode weren't the problem

The initial version of the browser just flat didn't *work*, whether in cursor mode or not or with Javascript enabled or not. It just didn't work. The upgrade fixed this problem, but, if you don't have a Windows PC installing the upgrade is no fun. Why the thing can't upgrade itself over the data network is simply beyond me, but, anyway.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.