BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-22-2008, 11:22 PM   #1 (permalink)
New Member
 
Join Date: Dec 2008
Model: 9500
PIN: N/A
Carrier: Rogers
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unlocked Storm dosen't work with Rogers!

Please Login to Remove!

I bought an unlocked storm today. Originally a verizon phone. I can make and receive phone calls but none of my data works. The edge is lower case and from what I understand that means that the data is not working. I phoned Rogers and they said it still says I'm using my Bold, which means the storm is not registering. I tried trouble shooting myself and with the Rogers rep. who used to work for t-mobile. My BBM doesn't work as well, and I have no browser emoticon. GPS does not work either!

When I go to status my pin says FFFFFFFF and beside ESN (dec) it says 00000000000 and beside ESN (hex) it says 0.

Any idea what the problem could be? How can I get my data up and running?

Last edited by too solid : 12-22-2008 at 11:25 PM.
Offline  
Old 12-22-2008, 11:28 PM   #2 (permalink)
No longer Registered.
 
Join Date: Jun 2007
Model: 9530
OS: 4.7.0.XXX
PIN: G Pong Champ
Carrier: T-Mobile U.S.
Posts: 5,515
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The PIN and ESN mean fried device. Return it. There is no other option.
Offline  
Old 12-23-2008, 12:14 AM   #3 (permalink)
New Member
 
Join Date: Dec 2008
Model: 9500
PIN: N/A
Carrier: Rogers
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks brother! i contacted the seller and were going to meet up in a few days when he gets some new ones straight from verizon. if the new one doesn't work ill have to stick with my bold! its wierd though, i have a friend with a verizon unlocked storm and it works perfectly with the rogers network, data and all. seems like the storm i recieved is just a doozey!
Offline  
Old 12-23-2008, 02:12 AM   #4 (permalink)
No longer Registered.
 
Join Date: Jun 2007
Model: 9530
OS: 4.7.0.XXX
PIN: G Pong Champ
Carrier: T-Mobile U.S.
Posts: 5,515
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (TMO 8120 4.5.0.69)

I have an unlocked Verizon Storm working great on T-Mobile. You just got a bad one.
Offline  
Old 03-26-2009, 04:55 PM   #5 (permalink)
New Member
 
Join Date: Mar 2009
Model: 9500
PIN: N/A
Carrier: Rogers
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unlocked storm 9530

Hi,

Can anybody help me with my issue? i bought an unlocked storm 9530... however i my data does not work. Rogers switched my pin over to the new device. what can i do to make my data work?

Please help.

Thanks,

J.
Offline  
Old 03-26-2009, 07:55 PM   #6 (permalink)
New Member
 
Join Date: Feb 2009
Model: 9530
PIN: N/A
Carrier: Fido
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Jmore View Post
Hi,

Can anybody help me with my issue? i bought an unlocked storm 9530... however i my data does not work. Rogers switched my pin over to the new device. what can i do to make my data work?

Please help.

Thanks,

J.
LOL maybe you bought the OP's phone.

I presume you have a BIS data plan (which are different than the common data plans)?

do you see EDGE (upper case) in the top corner? If not, try a battery pull. If that still doesn't work, then return your phone.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.