BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-26-2009, 08:01 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Dec 2006
Location: Canada/USA
Model: 8900
Carrier: Rogers/TMobile
Posts: 60
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unlocked A Storm - Does not Recognize SIM Card, WTF??

Please Login to Remove!

Has anyone seen this?

I have unlocked a Storm (Code Accepted) and when i insert a valid SIM Card (ATT) the device says insert SIM card, and on the screen ,it says SOS!!

I need help, if i can fix this, I am going back to my Bold.

Thanks,
Offline  
Old 02-26-2009, 08:04 PM   #2 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

Have you set it to GSM Only mode?
__________________
I h8 txtspk.
Offline  
Old 02-26-2009, 08:09 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Dec 2006
Location: Canada/USA
Model: 8900
Carrier: Rogers/TMobile
Posts: 60
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dc/dc View Post
Have you set it to GSM Only mode?
Yep, no service, SOS??
Offline  
Old 02-27-2009, 02:08 PM   #4 (permalink)
New Member
 
Join Date: May 2006
Location: NC
Model: 9530T
OS: 4.7.0.109
PIN: 305CSE01
Carrier: T-Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mine did that as well. I ended up having to get a new SIM card. I don't know if I fried the damn thing or what. My wife's SIM worked in it, but mine wouldn't.
__________________
BB 9530 on TMO, OS .109 w/ .90 Radio file....
Offline  
Old 03-30-2009, 09:35 AM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
b3n_asian_freak's Avatar
 
Join Date: Jul 2006
Location: Houston, TX
Model: 9700
OS: 5.0.0.344
PIN: It changes so often....
Carrier: T-Mobile
Posts: 326
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Any explantion for it from experts please?
I tried to sell my phone and it didn't go through since the guy's AT&T sim card didn't work, it shows SOS on the unlocked Storm. As soon as I put mine in, T-Mobile, it picks up signal right away. It pissed me of as well as embarrased me...
__________________
-------------------------
T-Mobile / 9700
Offline  
Old 04-02-2009, 10:17 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
b3n_asian_freak's Avatar
 
Join Date: Jul 2006
Location: Houston, TX
Model: 9700
OS: 5.0.0.344
PIN: It changes so often....
Carrier: T-Mobile
Posts: 326
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found a solution and thought that it would be useful to post my solution up here since we never got any response.
What's going on is the sim card is loose in the Storm, in fact the AT&T 3G sim card is slightly thinner than a T-Mobile sim card.
Anyway, just slide the sim card in with a piece of paper and the your Storm should be up and running now...
__________________
-------------------------
T-Mobile / 9700
Offline  
Old 06-21-2009, 12:02 PM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2007
Location: Bellevegas
Model: 8900
Carrier: Rogers
Posts: 95
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

THIS WORKED!! I've been messing around with this thing since yesterday and finally I got it working. Thanks b3n_asian_freak

I modified your process slightly, I used some scotch tape and did a few layers as I couldn't get the SIM and paper to slide in.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.