BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-09-2009, 09:44 PM   #1 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Aug 2007
Model: 9530
OS: .75
PIN: N/A
Carrier: Verizon
Posts: 212
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question NullPointerException {Now with exciting new problems!!!

Please Login to Remove!

Hi gang. So yesterday I woke and battery pulled to the dreaded "Uncaught exception: java.lan.NullPointerException" startup error. Joy! I haven't installed anything new in three weeks so it can't be that (assumption). This error also eliminated my two mailboxes from the desktop but kept my SMS box. At different times I would also get the a "net_rim_bb_messaging_app(70) (and 204) is not responding, Process Terminated." What's interesting is that even though I can't access my mailboxes, my desktop indicator still keeps the correct count of how many new email I have AND the new email ringtones still play.
Now onto the 'new ' problems that I haven't read about in any other forum yet (knows where the search button is). I launched Desktop Manager and a window saying 'Device Application Updates' pops up, then I get an error, saying "Failed to Connect to Device. Make Sure Device Is Connected and Then Try Again." So I exit out of that, then try to sync contacts and get this error "Communication Error Between and Desktop Manager". Basically I can't backup anything or access anything. Total suckage!
Just to satisfy curiosity, I then booted into OSX and fired up Missing Sync, but same thing, I can mount the SD card, but I can't sync or back up anything else. Next I decided to start uninstalling any apps to see if that would make a difference. Now I'm down to just the Storm O.S. and I'm still getting this damn error! Does anyone have any ideas/answers? suggestions? anyone? Bueller?

Forgot: using original .75 o.s.

Last edited by suicidepact : 04-09-2009 at 10:25 PM. Reason: omissions
Offline  
Old 04-10-2009, 06:25 AM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2009
Location: San Marcos, TX, USA
Model: 9530
OS: 4.7.0.75
PIN: 3053D7B3
Carrier: Verizon
Posts: 165
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by suicidepact View Post
"net_rim_bb_messaging_app(70)
mine is always process id #69 instead of 70...that is most interesting...wonder what the prior 68, or in your case 69, processes are....
Offline  
Old 04-10-2009, 06:40 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2009
Location: San Marcos, TX, USA
Model: 9530
OS: 4.7.0.75
PIN: 3053D7B3
Carrier: Verizon
Posts: 165
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

sounds like some type of formatting error corrupted parts of the OS itself and microSDHC card and or you have had a hardware failure with your microUSB connection or microSDHC card

but according to this tear-down, the microUSB and microSDHC are not necessarily connected by anything except directly to the processor...

cool hardware diagram of the 9530:
http://www.phonewreck.com/wiki/image...ck_diagram.jpg

device application updates popup? does it say anything else?
Offline  
Old 04-10-2009, 07:31 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2007
Model: 9800
OS: 6.0.0.337
Carrier: Vodafone
Posts: 125
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

It seems it's a database corruption. I had similar issue. Take out the SD card and wipe the device.
Offline  
Old 04-10-2009, 08:25 AM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Aug 2007
Model: 9530
OS: .75
PIN: N/A
Carrier: Verizon
Posts: 212
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, I haven't found anyone on any forum who has had this same problem where they couldn't even connect to Desktop Manager. Mine didn't have anything to with blank SMS messages. Mine so far looks to be a unique and beautiful snowflake. It's also a great excuse to start from scratch and install the .113 firmware and then the Aerize Card Loader app.
Offline  
Old 04-11-2009, 03:03 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Aug 2007
Model: 9530
OS: .75
PIN: N/A
Carrier: Verizon
Posts: 212
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Jason, those were the only errors I received, they really limited what I was able to do. Very interesting schematics drawing though. Where are you finding all this?
I hope it isn't hardware related, but I have installed .113 with no problem (except for losing all data prior to my last full backup.)

On a side note, anyone reading this now should take the time to make a full backup of your BB for no other reason than that it could happen to you. I'm fortunate enough that it happened while I was in the country and not traveling. T

Thanks for the advice muratcolakoglu, that's exactly what I had to do.
Offline  
Old 04-11-2009, 11:30 AM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2009
Location: San Marcos, TX, USA
Model: 9530
OS: 4.7.0.75
PIN: 3053D7B3
Carrier: Verizon
Posts: 165
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by suicidepact View Post
Jason, those were the only errors I received, they really limited what I was able to do. Very interesting schematics drawing though. Where are you finding all this?
I hope it isn't hardware related, but I have installed .113 with no problem (except for losing all data prior to my last full backup.)
just google searching....hope so too...doesn't sound like it if you were able to get .113 running again though

i'm gonna backup my BB today!
Offline  
Old 04-11-2009, 03:14 PM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Aug 2007
Model: 9530
OS: .75
PIN: N/A
Carrier: Verizon
Posts: 212
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yep, corrupted db it was. The .113 beta is pretty sweet besides the rather ugly looking keyboard in landscape (I love the new select tool though).
Also Jason regarding Aerize Card Loader, either it doesn't work for Storm or all it really does it download a copy of the same program to the SD card when you do an OTA install.
Offline  
Old 04-11-2009, 03:51 PM   #9 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2009
Location: San Marcos, TX, USA
Model: 9530
OS: 4.7.0.75
PIN: 3053D7B3
Carrier: Verizon
Posts: 165
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

interesting...i will see if i can investigate this more...i'm backing up my phone later and then i will see about the .113 beta install and then aerize and reinstall all the apps...

i'm curious about the "ugly landscape mode keyboard" you speak about...did they try to do the shared key SureType keyboard? i want that feature because my fingers are big even for qwerty in landscape mode, but i wasn't sure if they were going to do it although i heard that the portrait mode now supports individual qwerty keys...

completely off topic, another feature that i thought about that goes with the landscape keyboard request is that i'd like to see a way to turn off the view mode switching because of the accelerometer for instances like when you are laying down using your blackberry...i wonder how the iphone implemented that or if they even did...i'm pretty sure many people will have encountered the problem of trying to use the phone when laying down and it switches view modes that correlate to gravity and not your eyes...just a thought though...
Offline  
Old 04-13-2009, 04:56 PM   #10 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Aug 2007
Model: 9530
OS: .75
PIN: N/A
Carrier: Verizon
Posts: 212
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

About the ugly keyboard, in landscape the layout is the same except that insome instances the border is thinner in places and a bit inconsistent. On the plus side in the browser the 'enter' key is replaced by a 'Go' key outlined in green.

I haven't tried the SureType, but I have have tried and still use QWERTY in both use landscape and portrait. Believe it or nor it's acceptable in portrait.

Last edited by suicidepact : 04-13-2009 at 04:58 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.