BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-25-2009, 12:28 PM   #1 (permalink)
New Member
 
Join Date: Apr 2009
Model: 9530
PIN: N/A
Carrier: telus
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default new to blackberry and need some help.

Please Login to Remove!

i used the storm for about a week and it worked fine. i was on vacation and the battery died on me about 2 days ago, today when i got home i tried to charge it however its not charging. when i plug in the cable nothing happens, not even a light or a sound. i have the cable plugged in as i write this, its been in for about 30 mins now and still nothing, it wont turn on. i checked to see the battery and that seems fine. do you guys think because the battery completely died it will take long before anything actually happens? thanks
Offline  
Old 04-25-2009, 12:31 PM   #2 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,524
Post Thanks: 214
Thanked 341 Times in 307 Posts
Default

Leave it in there for a few hours. If it doesn't charge, come back.
__________________
I h8 txtspk.
Offline  
Old 04-25-2009, 06:22 PM   #3 (permalink)
New Member
 
Join Date: Apr 2009
Model: 9530
PIN: N/A
Carrier: telus
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

still nothing. some advice plz.
Offline  
Old 04-25-2009, 08:36 PM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2009
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 22
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I suggest you just bring it back and replace it. I couldn't tell you exactly what is wrong because it could be the phone or the battery. Seems like a manufacturer problem so bring it in and get a new one
Offline  
Old 04-25-2009, 08:48 PM   #5 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App6+
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,036
Post Thanks: 52
Thanked 777 Times in 737 Posts
Default

How are you charging it - wall charger or via the USB? Have you tried a different source/outlet/charger to try to troubleshoot the problem?
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

CC8: Genuine OEM Apple Mac LONG DVI to VGA Video Adapter Cable 603-2120/591-011
$9.34
CC8:  Genuine OEM Apple Mac LONG DVI to VGA Video Adapter Cable 603-2120/591-011 pictureLot of 2 Vintage Genuine OEM Nukote BM160 Ribbon Apple Imagewriter NEC PC8023A
$12.75
Lot of 2 Vintage Genuine OEM Nukote BM160 Ribbon Apple Imagewriter NEC PC8023A pictureOEM Part HARD Drive assembly 250mb SCSI Oerlikon 901-416 APPLE iTRADE-AG with c
$137.5
OEM Part HARD Drive  assembly 250mb SCSI Oerlikon 901-416 APPLE iTRADE-AG with c pictureSeagate 750GB 7200 RPM 3.5" ST3750640NS OEM Apple Hard Drive Wiped
$35.99
Seagate 750GB 7200 RPM 3.5Lot of 3 Wiped Seagate 750GB 7200 RPM 3.5" ST3750640NS OEM Apple Hard Drives
$89.99
Lot of 3 Wiped Seagate 750GB 7200 RPM 3.5






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.