BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-26-2009, 06:32 PM   #1 (permalink)
Thumbs Must Hurt
 
starbai's Avatar
 
Join Date: Feb 2008
Location: Fort Lauderdale, FL
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgrading my phone's firmware/software just isn't working--- Please help!

Please Login to Remove!

Guys I've been upgrading the software on this phone ever since I first got it with both offical and unoffical releases.

Today for some reason Its not letting me. I'm trying to download and install

".122" - For my 9530.

I download the installation file, install it and plug my phone in and run desktop manager.

But it doesn't recognize that theres a new software to update/install... I dont know why??? I've tried reinstalling it... letting it go through some kind of update, and it stays on .109...

Why? What am I missing?
Offline  
Old 04-26-2009, 06:36 PM   #2 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

Have you deleted vendor.xml?
__________________
I h8 txtspk.
Offline  
Old 04-26-2009, 06:38 PM   #3 (permalink)
Thumbs Must Hurt
 
starbai's Avatar
 
Join Date: Feb 2008
Location: Fort Lauderdale, FL
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No I havent, but I dont know why that should matter. I've upgraded the software several times without having to do that. was that a pre req for .122 to work?
Offline  
Old 04-26-2009, 06:40 PM   #4 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

That should be done before every software upgrade for good measure, but it is a requirement if you are loading software distributed by a different vendor (which is the case for you).
__________________
I h8 txtspk.
Offline  
Old 04-26-2009, 07:37 PM   #5 (permalink)
Thumbs Must Hurt
 
starbai's Avatar
 
Join Date: Feb 2008
Location: Fort Lauderdale, FL
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

did it, unfortunately didn't fix it.

any other suggestions? wierdest freakin thing. I've probalby done about 10 upgrades (I usually do them whether they're official or not) this is the first one thats ever done this.
Offline  
Old 04-26-2009, 07:50 PM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2005
Model: 8330
Carrier: Verizon
Posts: 74
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Delete vendor.xml and run loader.exe for that same directory. I couldn't get DM to run the upgrade, but running loader.exe out of that directory did the trick.
Offline  
Old 04-26-2009, 09:42 PM   #7 (permalink)
Thumbs Must Hurt
 
starbai's Avatar
 
Join Date: Feb 2008
Location: Fort Lauderdale, FL
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by tobenning View Post
Delete vendor.xml and run loader.exe for that same directory. I couldn't get DM to run the upgrade, but running loader.exe out of that directory did the trick.
when you say loader.exe are you refering to the desktop manager program?

I deleted vendor.xml first

So far I'm making a little more progress...

from blackberry desktop manager, i click on 'application loader' then i click on update software and then I see 4.7.0.132.

I check that one, and uncheck (4.7.0.75, as it is my current software)

I hit Next, and then it says "No Software update is required for your device"

doesn't install anything... whats up here?
Offline  
Old 04-26-2009, 09:44 PM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Mar 2006
Location: DC
Model: 9550
Carrier: Verizon
Posts: 338
Post Thanks: 2
Thanked 8 Times in 8 Posts
Default

In the same folder as the vendor.xml (usually C:\Program Files\Common Files\Research In Motion\AppLoader) you'll fine Loader.exe - use it to update rather than desktop manager.

-jk
Offline  
Old 04-26-2009, 10:34 PM   #9 (permalink)
Thumbs Must Hurt
 
starbai's Avatar
 
Join Date: Feb 2008
Location: Fort Lauderdale, FL
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jmwking View Post
In the same folder as the vendor.xml (usually C:\Program Files\Common Files\Research In Motion\AppLoader) you'll fine Loader.exe - use it to update rather than desktop manager.

-jk
that worked!

thanks!
Offline  
Old 05-01-2009, 01:26 AM   #10 (permalink)
Thumbs Must Hurt
 
starbai's Avatar
 
Join Date: Feb 2008
Location: Fort Lauderdale, FL
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by starbai View Post
that worked!

thanks!
I dont understand, every firmware update I do, official or not, tricks my phone into thinking its got a headphone plugged in and I can't hear or say anything into the handset when making a phone call.

If I go back to .75 its fine.

Everything I try, even .109 which i used for a very long time gives me this problem... does anyone know how I can get the phone to work the way it used to??
Offline  
Old 05-01-2009, 07:15 AM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2009
Model: 9530
OS: 4.7.0.148
PIN: N/A
Carrier: Verizon
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you do a battery pull after the upgrade?
Offline  
Old 05-01-2009, 07:55 AM   #12 (permalink)
BlackBerry Extraordinaire
 
zero7404's Avatar
 
Join Date: Apr 2007
Location: tri-state
Model: 9530
OS: 5.0.0.328
PIN: n/a
Carrier: tmob
Posts: 1,097
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

download a utility like Crackmem. make sure you have the OS you want to install on the phone installed on your pc. then use DM to back up all your information using the backup tool. also, back up your 3rd party apps on the device.

close out DM, then start crackmem with the phone connected, select the OS on the left hand pane. then click the button that says "wipe device". it'll ask you to confirm by typing "BrickMyPhone", do it and then it will wipe the phone and start loader.exe to install the OS.

after that you might have to restore your data and 3rd party apps using DM.
__________________
AIM//App World//BEIKS Dictionary//DataVault//GPS Tracker//MissingLight//QuickLaunch//StormLevel Pro//StormLight//Tetris//VA Wallpaper Changer
Offline  
Old 05-01-2009, 10:14 AM   #13 (permalink)
Thumbs Must Hurt
 
starbai's Avatar
 
Join Date: Feb 2008
Location: Fort Lauderdale, FL
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by zero7404 View Post
download a utility like Crackmem. make sure you have the OS you want to install on the phone installed on your pc. then use DM to back up all your information using the backup tool. also, back up your 3rd party apps on the device.

close out DM, then start crackmem with the phone connected, select the OS on the left hand pane. then click the button that says "wipe device". it'll ask you to confirm by typing "BrickMyPhone", do it and then it will wipe the phone and start loader.exe to install the OS.

after that you might have to restore your data and 3rd party apps using DM.
Is this a proven method for getting rid of my trouble? Or is it just a good suggestion for soemthing to try?

Eithe rway /I'm greatful for the suggestion, and I will try it either way, I just want to know what to expect?

And yes I did do 4-5, 30 or more second battery pulls.
Offline  
Old 05-01-2009, 10:29 AM   #14 (permalink)
BlackBerry Extraordinaire
 
zero7404's Avatar
 
Join Date: Apr 2007
Location: tri-state
Model: 9530
OS: 5.0.0.328
PIN: n/a
Carrier: tmob
Posts: 1,097
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

it works for me, but after it wipes the device it proceeds to load the OS you have installed on your PC via the blackberry apploader. which means all your personal data won't be restored automatically because it wiped the device before apploader starts.

have you tried removing DM and any other BB software from your system, reinstalling it, see if it works ?

if not, then proceed with crackmem, it should do the job. just remember to use DM to back up your personal data and 3rd party apps. for 3rd party apps backup and restore, see this thread:

http://www.blackberryforums.com/rim-...arty-apps.html
__________________
AIM//App World//BEIKS Dictionary//DataVault//GPS Tracker//MissingLight//QuickLaunch//StormLevel Pro//StormLight//Tetris//VA Wallpaper Changer
Offline  
Old 05-01-2009, 10:34 AM   #15 (permalink)
Thumbs Must Hurt
 
starbai's Avatar
 
Join Date: Feb 2008
Location: Fort Lauderdale, FL
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 77
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by zero7404 View Post
it works for me, but after it wipes the device it proceeds to load the OS you have installed on your PC via the blackberry apploader. which means all your personal data won't be restored automatically because it wiped the device before apploader starts.

have you tried removing DM and any other BB software from your system, reinstalling it, see if it works ?

if not, then proceed with crackmem, it should do the job. just remember to use DM to back up your personal data and 3rd party apps. for 3rd party apps backup and restore, see this thread:

http://www.blackberryforums.com/rim-...arty-apps.html
Did you have the same problem with the 'headphone icon' appearing and the speaker, mic on the handset shutting off as a result?
Offline  
Old 05-01-2009, 11:04 AM   #16 (permalink)
BlackBerry Extraordinaire
 
zero7404's Avatar
 
Join Date: Apr 2007
Location: tri-state
Model: 9530
OS: 5.0.0.328
PIN: n/a
Carrier: tmob
Posts: 1,097
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (9530)

Quote:
Originally Posted by starbai
Quote:
Originally Posted by zero7404 View Post
it works for me, but after it wipes the device it proceeds to load the OS you have installed on your PC via the blackberry apploader. which means all your personal data won't be restored automatically because it wiped the device before apploader starts.

have you tried removing DM and any other BB software from your system, reinstalling it, see if it works ?

if not, then proceed with crackmem, it should do the job. just remember to use DM to back up your personal data and 3rd party apps. for 3rd party apps backup and restore, see this thread:

http://www.blackberryforums.com/rim-...arty-apps.html
Did you have the same problem with the 'headphone icon' appearing and the speaker, mic on the handset shutting off as a result?
I never noticed a headphone jack icon when using it....and i didn't have the mic issue....so i can't say
__________________
AIM//App World//BEIKS Dictionary//DataVault//GPS Tracker//MissingLight//QuickLaunch//StormLevel Pro//StormLight//Tetris//VA Wallpaper Changer

Last edited by zero7404 : 05-01-2009 at 12:03 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.