BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-02-2009, 05:58 PM   #1 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: Sasktel
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Storm can't get out of headset mode to place calls

Please Login to Remove!

Yeah... the headset isn't even plugged in but it's still in headset mode. Of course, when you place a call there is of course the "handset" button but this does nothing at all! This is pretty awesome for me right now because I don't have my headset with me and I need to make a f*****g call!

Restarted the device... to no avail...

I'm pretty enraged right now... any help would be great...

Thanks in advance!

edit; somebody please help me before I throw this $900 phone against a concrete wall...
edit2; went to music>options>enable handset. music started playing from the earpiece... tried to make a call and nothing. WTF RIM!? I NEED TO USE MY PHONE. THIS IS BS.
edit3; trying bat pull...

Last edited by christopherj : 06-02-2009 at 06:12 PM.
Offline  
Old 06-02-2009, 06:20 PM   #2 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: Sasktel
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

aaaand the battery pull did, you guessed it, NOTHING!


WHAT. THE. HELL.

My phone is useless to me until I can get home and get my headset... and even then I need to carry it around with me everywhere... this is so f*cked.
Offline  
Old 06-02-2009, 06:23 PM   #3 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: Sasktel
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

For the love of god somebody please help me I need to use my phone

Last edited by christopherj : 06-02-2009 at 06:37 PM.
Offline  
Old 06-02-2009, 06:40 PM   #4 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: Sasktel
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

lol this is ridiculous... so i tried going to music and then enable handset. music plays out of the handset like normal. so i try placing a call with the music playing out of the handset and to really no surprise at all, it switches back to headset mode for the duration of the call... then back to handset mode to continue playing music.

Alright so if no one no here can help me, can someone at least tell me how to report this to RIM? Pretty serious bug since it has rendered the actual PHONE part of my phone completely useless.
Offline  
Old 06-02-2009, 06:55 PM   #5 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: Sasktel
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I made it home and I've got the headset now but the problem still persists. Gonna head to my wireless store and see if they can do something. If not hopefully someone has some insight by the time I get back...
Offline  
Old 06-03-2009, 08:28 AM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2008
Location: NJ
Model: 9530
Carrier: T-Mobile
Posts: 175
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What OS are you using? Did you try up/downgrading your OS to see if that was an issue. That use to happen to me to, and I installed the OS with the headphone jack in the phone and it somehow fixed. it. Give it a go!

-Scott
__________________
He who knows, and knows not what he knows, knows nothing.
Offline  
Old 06-03-2009, 10:13 AM   #7 (permalink)
New Member
 
Join Date: Jun 2009
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same issue. The default setting is Headset when I make or recieve a call. After the call is initiated I am able to change the setting to either Speaker/Handset/Bluetooth via the options menu. (what a hastle)

Where is the default for this setting assigned? Anyone know?

This just started yesterday after I upgraded to the newly released software.
Offline  
Old 06-03-2009, 10:33 AM   #8 (permalink)
New Member
 
Join Date: Jun 2009
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Found the same thread on blackberry.com. The phone thinks there is a headset plugged in.

I took my headphones, plugged them into my phone, then called my voicemail, unplugged my headphones and it now works. You may have to repeat this a few times if it doesn't work right way. Below is a link to the same issue.
Offline  
Old 06-03-2009, 12:27 PM   #9 (permalink)
Thumbs Must Hurt
 
Join Date: Apr 2009
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 130
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You guys are making me extra glad I returned our 2 Storms before the 30 day period was up. I had all sorts of major issues with them--other than constant reboots the biggest issue was being unable to get into speaker phone mode when taking a call if the screen was in landscape mode when I hit "answer". and also there is no way to keep the mode set to "speaker phone". How lame is that?
Offline  
Old 06-03-2009, 01:07 PM   #10 (permalink)
Knows Where the Search Button Is
 
blackberryfront's Avatar
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: Verizon
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, sometimes you just need to insert the plug back into the jack and jiggle it around and remove it and then it will work again.
__________________
Blackberry Storm Front
Offline  
Old 06-15-2009, 06:19 PM   #11 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had this same problem after the new OS upgrade. I tried plugging in my headphones and unplugging them in the middle of a call several times without luck. It wasn't until I left them plugged in and did a battery pull and placed another call that it finally took it out of headset mode
Offline  
Old 06-15-2009, 10:23 PM   #12 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2007
Location: South Florida
Model: 9530
OS: 4.7.0.109
Carrier: Verizon
Posts: 55
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem. Found a fix on the web, and it worked for me.

Get a can of compressed air, one with the little red straws. Stick it in the headset jack and blast away. I did it a couple of times and all is fixed. There must be a switch inside that gets stuck.

Jeff
Offline  
Old 06-24-2009, 06:03 AM   #13 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can't believe it! It worked. Nothing else worked except the compressed air recommendation. Thank you very much Jeff!

Paolo
Offline  
Old 07-19-2009, 02:03 AM   #14 (permalink)
New Member
 
Join Date: Jul 2009
Model: 9530
PIN: N/A
Carrier: verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you upgraded from version 4.7.0.65 to 4.7.0.148 that is the problem, I had the same problem and I Downgraded, after the Downgrade The issue with the phone going into headset mode by it self, it got fixed.
Offline  
Old 07-21-2009, 12:48 AM   #15 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2009
Model: storm
PIN: N/A
Carrier: verizon
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

same thing happened to me. i took it in to verizon and they used compressed air and told me a contact in the head jack got slightly dislodged. problem solved in seconds.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.