BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-28-2009, 06:55 PM   #1 (permalink)
Thumbs Must Hurt
 
Smokey Joe's Avatar
 
Join Date: May 2008
Location: Cen*Cal
Model: 9530
OS: 5.0.0.328
PIN: 308547B0
Carrier: Verizon
Posts: 57
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default New Storm with new OS... Better!

Please Login to Remove!

So, my Storm got wet last week at the lake and after 4-5 days of letting it dry(while using) the ESC and green phone buttons still were not working. I went ahead and filed an insurance claim, paid my $50 deductable, and (amazingly) had a new phone delivered to my door in aprox. 24 1/2 hours! So, I get the new phone up and running, data transfered and all that good stuff no problem with the BB desktop software(phone already had the .148OS installed). Now after a couple days of use it seems that the phone works a whole lot better than my old phone with the new OS!! Has anyone else experienced this with the new phones OS pre-installed?
__________________
Don't let the man get you down!
Smokey Joe
Offline  
Old 06-28-2009, 07:24 PM   #2 (permalink)
CrackBerry Addict
 
Join Date: May 2006
Location: NewJersey
Model: 9900
OS: 7.1.0.284
PIN: 294E926C
Carrier: T-MOBILE
Posts: 640
Post Thanks: 1
Thanked 1 Time in 1 Post
Default

as i remember when i had a 9530 the .148 OS was running really snappy and smooth. my only issue was the EDGE connnection was not always up but as a whole the phone was def running better with the new upgrade. i am running on a vodafone 9500 with .151 its running nice. one thing i did notice when i intalled app world , there was major memory leak i would start with 49 megs of space and after a few hrs then phone would say 34 megs. i took app world off and all day the phone stays at 49 megs loveing the phone .
__________________
MY Collection:--8300,8700,8800,9000,9300,9500,9520,9700,9800,9860, 9900
Offline  
Old 06-29-2009, 04:15 PM   #3 (permalink)
New Member
 
sking337's Avatar
 
Join Date: Mar 2008
Location: here
Model: 9530
Carrier: VZW
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Smokey Joe View Post
So, my Storm got wet last week at the lake and after 4-5 days of letting it dry(while using) the ESC and green phone buttons still were not working. \
Little secret to speed the process up is to put it in a cup of rice. Works great for most electrical devices, just be sure to cover any holes that the rice may get into.
Offline  
Old 06-29-2009, 04:49 PM   #4 (permalink)
Thumbs Must Hurt
 
Smokey Joe's Avatar
 
Join Date: May 2008
Location: Cen*Cal
Model: 9530
OS: 5.0.0.328
PIN: 308547B0
Carrier: Verizon
Posts: 57
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sking337 View Post
Little secret to speed the process up is to put it in a cup of rice. Works great for most electrical devices, just be sure to cover any holes that the rice may get into.
Thanks... I had heard that but since it was working about 90% right it wasnt a huge issue. Insurance is a wonderful thing!!
__________________
Don't let the man get you down!
Smokey Joe
Offline  
Old 06-29-2009, 08:14 PM   #5 (permalink)
Knows Where the Search Button Is
 
genericbrand's Avatar
 
Join Date: Sep 2007
Model: 9530
PIN: N/A
Carrier: Verizon Wireless
Posts: 20
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just purchased a Storm last Friday and it is truly amazing. I don't have any experience with past OS builds though.
Offline  
Old 06-29-2009, 11:04 PM   #6 (permalink)
New Member
 
Join Date: Dec 2008
Location: Louisville Ky
Model: 9530
OS: .99
PIN: N/A
Carrier: verizon
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I agree it works a lot better. i traded my old storm in at the store because it was freezing a lot with the new OS.

Last edited by thetachi488 : 06-30-2009 at 12:49 AM.
Offline  
Old 07-15-2009, 01:56 AM   #7 (permalink)
New Member
 
Join Date: Jun 2009
Model: 9530
PIN: N/A
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I bought mine with the new OS preinstalled so I have no clue on the old one. Only issues I have is once in awhile it Restarts on its own. Dunno if its updating or not. But it diffly can be annoying considering it takes like 5 mins to load the phone
Offline  
Old 07-15-2009, 07:22 AM   #8 (permalink)
BlackBerry Extraordinaire
 
BCollins521's Avatar
 
Join Date: Sep 2006
Location: OH
Model: 9700
PIN: Ask...
Carrier: T-Mobile
Posts: 2,033
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

While .148 was nice...the newest .151 is a lot better in my opinion on my device. Although the Storm is different for each device
__________________
-Brian

Get My Themes Here! | [email address] | Twitter
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.