BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-23-2009, 12:31 PM   #1 (permalink)
USA
Knows Where the Search Button Is
 
USA's Avatar
 
Join Date: Jan 2007
Location: Atlanta, GA
Model: 9530
OS: .151
Carrier: VZW
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Public Contacts Are Now Missing Addresses (email and snail-mail)

Please Login to Remove!

I've been using my Storm for since December 2008 with a BES syncing my messages and meetings wirelessly and my notes and contacts with the USB cable. The notes and contacts are synced with the cable so that I can also include a public folder for contacts and notes. That way I get to see my contacts and my company's shared contacts (an Exchange 2003 Public Folder). That has worked great until recently.

In the past 3-4 weeks I've noticed something strange. The contacts from the shared public folder no longer have email addresses or snail-mail addresses on the BlackBerry. When I go back to Outlook I see the addresses are still in the contacts.

The timing of this is approximately the same time I changed my OS but I can't be sure that the changed happened exactly when I updated my OS.

I went from Bell Mobility released 4.7.0.122 when it was working to VZW released 4.7.0.148 when it started to hide/delete the addresses from the public folder contacts. I tried upgrading to Iusacell released 4.7.0.151 but that didn't fix the problem.

To try to resolve this I've removed sync to the public folder contacts, synced, and then added the public folder contacts back and resynced. I also tried a security wipe on the Storm with no luck.

Any help would be greatly appreciated.

Cheers-
Offline  
Old 07-23-2009, 01:33 PM   #2 (permalink)
KOR
CrackBerry Addict
 
KOR's Avatar
 
Join Date: Sep 2005
Model: None
Carrier: Typhoid Mary
Posts: 612
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Have you looked at the field mapping in Desktop Manager?
Offline  
Old 07-23-2009, 02:17 PM   #3 (permalink)
USA
Knows Where the Search Button Is
 
USA's Avatar
 
Join Date: Jan 2007
Location: Atlanta, GA
Model: 9530
OS: .151
Carrier: VZW
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by KOR View Post
Have you looked at the field mapping in Desktop Manager?
Thanks KOR, I did check the mapping after trying lots of other things first. I looked it over, and everything seemed to be logically placed. After that it occured to me that the mapping couldn't be the problem. From what I can tell there is only one defined mapping regardless of how many contacts folders you setup for syncing. While the public folder contacts isn't including the email addresses, my contacts folder from my mailbox _is_ including the email addresses.

I'll look for other missing data in the contacts from our public folders. Perhaps the next step is to reinstall the Desktop Manager. I was using 4.7 when I first noticed the problem. I upgraded to Desktop Manager 5.0 and that didn't resolve the problem.
Offline  
Old 07-24-2009, 10:50 AM   #4 (permalink)
KOR
CrackBerry Addict
 
KOR's Avatar
 
Join Date: Sep 2005
Model: None
Carrier: Typhoid Mary
Posts: 612
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

I'm no Exchange expert, so maybe someone else can chime in on this: perhaps a permissions issue on the PF's in question? I would think that if it is some kind of permissions issue that you just wouldn't get the record at all, not just a part of it. But, it can't hurt to check. Good luck with this. It's very odd.
Offline  
Old 07-24-2009, 06:35 PM   #5 (permalink)
USA
Knows Where the Search Button Is
 
USA's Avatar
 
Join Date: Jan 2007
Location: Atlanta, GA
Model: 9530
OS: .151
Carrier: VZW
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Resolved

KOR, thanks for the continued effort there. I appreciate it. If my hunch below had failed I would have tried your suggestion. Fortunately, I didn't have to.

There was probably a more graceful way to handle this but I didn't know the easy way to do it so I went a little overboard to "get 'er done". ...I was tired of screwing with it, and I needed those client email addresses with me while on the road.

I'll appoligize now because I'm not a technical writer and the following steps may be hard to follow.

I thought about uninstalling and reinstalling the Desktop Manager. I went to the BlackBerryFAQ looking for a way to completely remove all traces of the software and settings once uninstalled. What I found instead was a way to remove sync settings without uninstalling the product. Before taking those steps I first reverted it back to an mailbox only sync, and then set it to wirelessly sync all folders. I changed some data, confirmed good syncing and then went about deleting old settings for the Desktop Manager. I then started up the Desktop Manager and hooked up the USB cable and clicked on syncing. When I saw the message on the PC that the device was set for wireless sync I changed the Contacts and Notes back to _not_ sync wirelessly. In the Desktop Manager I added the two Public Folders with shared company Contacts and shared company Notes for wired sync. After a full sync all Contacts now show email addresses and street addresses.



This was a wierd one. One set of Contacts (the one from my mailbox) synced with full info. The other folder (a Public Folder) had started to not sync certain fields. Well, its back to normal now with both folders for Contacts and Notes syncing with the USB cable. Messages and Meetings sync wirelessly.

Cheers-
Offline  
Old 07-24-2009, 06:42 PM   #6 (permalink)
USA
Knows Where the Search Button Is
 
USA's Avatar
 
Join Date: Jan 2007
Location: Atlanta, GA
Model: 9530
OS: .151
Carrier: VZW
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down NOT Resolved

Um... Its doing it again. Cripes!

Maybe I'll try an older OS.

However, first I'm going to start drinking heavily.

I'll probably work on it some this weekend.
Offline  
Old 07-27-2009, 08:29 AM   #7 (permalink)
KOR
CrackBerry Addict
 
KOR's Avatar
 
Join Date: Sep 2005
Model: None
Carrier: Typhoid Mary
Posts: 612
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

I don't think the problem would be with Desktop Manager; it's usually pretty solid. If anything, I'd be suspect of Exchange/Public Folders since your personal contacts are syncing correctly.

Do you have the option to remove the device from BES, wipe it, and reactivate? If so, you may want to give that a try. Other than that, you may need to call RIM for support; they're generally pretty good.

I'm surprised no one else has chimed in on this one. Someone must have seen this behavior before.
Offline  
Old 07-27-2009, 01:12 PM   #8 (permalink)
USA
Knows Where the Search Button Is
 
USA's Avatar
 
Join Date: Jan 2007
Location: Atlanta, GA
Model: 9530
OS: .151
Carrier: VZW
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks KOR -- both good points. I checked my permissions for that public folder and found that I'm listed as an Owner. Also, something that I tried was to do a security wipe, then reactivate on the BES server. I think you're right about the Desktop Manager.

One nice benefit of upgrading to DM v5.0 is that it is blazing fast compared to v4.3 through v4.7 which were dreadfully slow.

An interesting thing I just remebered, I've got two coworkers doing what I'm trying to do with no problem. One of the coworkers has a Curve on Sprint, and one has an 8800 on AT&T. That alone makes me wonder about the OS that I've upgraded to. A downgrade is an easy enough test before I pay for a call to RIM.

"Once more unto the breach" (or whatever they say).
Offline  
Old 07-27-2009, 03:40 PM   #9 (permalink)
KOR
CrackBerry Addict
 
KOR's Avatar
 
Join Date: Sep 2005
Model: None
Carrier: Typhoid Mary
Posts: 612
Post Thanks: 7
Thanked 2 Times in 2 Posts
Default

Dunno. I'm running the same OS, have spot checked a bunch of records, and no problems with missing data.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.