BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-14-2009, 02:57 PM   #1 (permalink)
New Member
 
Join Date: Dec 2009
Model: 9500
PIN: N/A
Carrier: Vodafone
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem unlocking Storm from Vodafone

Please Login to Remove!

Any help is appreciated here peeps.

My 18 month old daughter has thrown my Mrs's phone down the loo so after a recent upgrade to a storm 2 I want to pass my Storm over to the Fun Regulation Authority to allow her to ride out her contract.

I have a couple of MEP2 codes to try on my phone from a reasonably reputable source but the instructions they have provided to me on how to get my Storm off the accursed Vodafone network don't work.

They read:

1. Insert a the desired sim from a different network
2. Enter the MEP2 code when prompted

But, it simply doesn't prompt me. It just says "invalid SIM" at the top of the screen.

So, is there anyway I can force the Storm to prompt me to ask for the unlock code, or, do you have any hints on what I'm doing wrong?

Cheers

Wayne
Offline  
Old 12-14-2009, 03:04 PM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Here are the steps that I have used on the Storm:

1. Turn off all of the wireless connections ( manage connections - turn all connections off )

2. Go to Options

3. Select Advanced Options

4. Select SIM Card

5. Hit menu select show keyboard

6. Enter mepd (you will not be able to see the typed info)

7. Enter the letters: mep2

8. Now it will say enter network mep code

9. Enter the code given you, usually about 16 digits
Offline  
Old 12-14-2009, 04:05 PM   #3 (permalink)
New Member
 
Join Date: Dec 2009
Model: 9500
PIN: N/A
Carrier: Vodafone
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Worked 1st time

Outstanding! Thank you.
Offline  
Old 12-21-2009, 06:36 PM   #4 (permalink)
New Member
 
Join Date: Dec 2009
Model: storm
PIN: N/A
Carrier: vodafone
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have done this and had code accepted but cannot use the phone to make or recieve calls or send sms ?? i can use the browser and use mms however. can anyone help as i have spent 60 pound on a new screen and 30 pound to unlock it and the bloody thing still dont work
Offline  
Old 12-21-2009, 06:42 PM   #5 (permalink)
New Member
 
Join Date: Dec 2009
Model: storm
PIN: N/A
Carrier: vodafone
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

plus a 12 month sim only contract as well with vodafone
Offline  
Old 12-21-2009, 07:20 PM   #6 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

woody, try getting a SIM swap from Voda, I've seen that work.
Offline  
Old 12-21-2009, 07:24 PM   #7 (permalink)
New Member
 
Join Date: Dec 2009
Model: storm
PIN: N/A
Carrier: vodafone
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

so it nothing to do with the operating system etc jsanders as i have no wireless update etc. if it is unlocked then it should work shouldnt it or are there other ways that it can be blocked. very confusing mate and frustrating. thought once unlocked pop in sim and off we pop. dont really want to spend any more money as might as well have bought new one
Offline  
Old 12-22-2009, 03:59 AM   #8 (permalink)
JJD
Knows Where the Search Button Is
 
Join Date: Jun 2008
Model: 9700
PIN: N/A
Carrier: T Mobile
Posts: 40
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default problem unlocking storm 2

I have a new storm 2 that has been supplied with an unlocking code. My problem is that i cannot get to a screen where i am actually asked to input the code.
I am doing the following:
1. SIM put in and all wireless turned off
2. Options, Advanced Options, SIM
3. mepd entered (nothing observed)
4. mep2 entered (nothing observed and i am not asked for anything)

I see the same thing with a t mobile and orange sim
I have spend hours trawling around youtube videos etc and the advice doesn`t really deviate from the above (which is not working).
Please help!
Offline  
Old 01-04-2010, 10:37 AM   #9 (permalink)
New Member
 
Join Date: Jan 2010
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check to see if you phone has been already unlocked.
Usually when the mepd window doesn't pop up that's why.
-Remove Sim
-Options
-Advanced Options
-Sim card
-New menu will pop up. Look for Networks
-If your device is unlocked it will read "disabled" or "inactive"
If it is still locked then there is an issue with the Blackberry software.
Offline  
Old 01-07-2010, 04:58 PM   #10 (permalink)
New Member
 
Join Date: Jan 2010
Model: 9500
PIN: N/A
Carrier: o2
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi my phone has been unlocked i phoned o2 to change contract and they told me i need to register it on ther website to get the software but as they dont supply storm phoned them they just sed i need to get it myself, also wen tryin to register for email i get a message sayin the wireless isnt registered so cant set it up any ideas??????
Offline  
Old 01-14-2010, 04:45 PM   #11 (permalink)
New Member
 
Join Date: Dec 2009
Model: None
PIN: N/A
Carrier: Rogers
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dear JSanders,

Need your help.

I have just unlocked my Telus Storm 2 to use with FIDO. Right now everything seems to be working fine. However, I am not sure if the phone unlocked correctly.

Now I have both the FIDO & Telus numbers active on the phone at the same time. When I choose 'GSM' the FIDO number get activated & on choosing '1XEV' the Telus number gets activated. I do not have a data plan on the FIDO number yet; will get a FIDO data plan once I cancel my 1 month Telus activation. On choosing 'GSM', I get lower case 'edge' & not 'EDGE'. Is this because I do not have a data plan on FIDO? The Wi-Fi is working fine on both.

At the time of switching off the phone it still shows the Telus logo even when the FIDO SIM is active. When I do a battery pull with the FIDO SIM active the Browser icon disappears when it switches back on. However, if I then turn on 'I XEV' in the mobile network connections I get the Browser back & it stays there even if I switch back to GSM on FIDO.

Is this normal or is there something wrong with the unlock? My concern is whether things will work once I have the Telus number disconnected.

Please advice.

Thanks.

Quote:
Originally Posted by JSanders View Post
Here are the steps that I have used on the Storm:

1. Turn off all of the wireless connections ( manage connections - turn all connections off )

2. Go to Options

3. Select Advanced Options

4. Select SIM Card

5. Hit menu select show keyboard

6. Enter mepd (you will not be able to see the typed info)

7. Enter the letters: mep2

8. Now it will say enter network mep code

9. Enter the code given you, usually about 16 digits
Offline  
Old 01-14-2010, 05:06 PM   #12 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Sounds like it is unlocked to me, you can verify and see on the device, by following the steps in this link:
How do I determine if my BlackBerry is "unlocked"? - BlackBerryFAQ

Pretty odd having the two numbers active on there, but I am assuming it is because you have the GSM SIM in the slot, and it will see it when you switch the 1XEV to GSM.

You won't get full EDGE on the device until the Data Plan is active ON that number and that SIM.
Offline  
Old 01-14-2010, 05:30 PM   #13 (permalink)
New Member
 
Join Date: Dec 2009
Model: None
PIN: N/A
Carrier: Rogers
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks JSanders. Followed the steps. The network shows 'Inactive' so it is unlocked.

I guess I just have to wait & see if things still work out fine once the Telus number is disconnected.

Till then I can use the data plan of Telus when I am away from wireless networks and still use my FIDO SIM on the phone. Pretty cool!!!!!
Offline  
Old 01-17-2010, 02:31 PM   #14 (permalink)
New Member
 
Join Date: Dec 2009
Model: None
PIN: N/A
Carrier: Rogers
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have unlocked my Storm 2 to use on FIDO. I have a huge problem of dropped calls. I cant seem to be able to click on the answer key to pick up the call. Even if I manage to click the key the calls just drops & I go back to the Home screen. What could the problem be? Is it a software issue? How do I fix this?

Any help will be appreciated.

Thanks.


Quote:
Originally Posted by tm2009 View Post
Thanks JSanders. Followed the steps. The network shows 'Inactive' so it is unlocked.

I guess I just have to wait & see if things still work out fine once the Telus number is disconnected.

Till then I can use the data plan of Telus when I am away from wireless networks and still use my FIDO SIM on the phone. Pretty cool!!!!!
Offline  
Old 02-23-2010, 06:14 AM   #15 (permalink)
New Member
 
Join Date: Feb 2010
Model: 9520
PIN: N/A
Carrier: DU
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello im new in the forum ...so forgive me if my question is a repeated one..but still here it is..

I bought a BB 9520 unlock(said the seller)..but still im getting the small edge icon even though that data plan is already active...is it an unlock problem or software.....my carrier is DU in UAE..


thanks...
Offline  
Old 02-23-2010, 07:29 AM   #16 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Gamemaster, your carrier DU, has the BlackBerry Data Plan provisioned to your account.

No generic data plan will work.
Offline  
Old 02-24-2010, 01:11 AM   #17 (permalink)
New Member
 
Join Date: Feb 2010
Model: 9520
PIN: N/A
Carrier: DU
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello

thanks for the answer...so i just need to coordinate with my carrier....and then i will post the result here ..thanks..
Offline  
Old 03-01-2010, 08:23 AM   #18 (permalink)
New Member
 
Join Date: Feb 2010
Model: 9520
PIN: N/A
Carrier: DU
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello,
Just got my BB back but its still the same problem....we put the same sim on a BOLD and we got the capital EDGE, when we put back on the storm2..again its the small edge..is the OS? or lacking any app??

please help..

thanks,
Offline  
Old 03-01-2010, 08:51 AM   #19 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Did you change the PIN/IMEI at the DU carrier BIS login site?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.